• 1
  • 26
  • 27
  • 28(current)
  • 29
  • 30
  • 45
WIP Ember Media Manager 1.9.x - Download & Discussion Thread
Thanks very much Rofl
Kodi v18.9 (Aeon MQ8 Multi-Mod) running on Windows 10
@DanCooper it seems that 'aired' date does not get pushed/synced for tv shows. Is there a bug?

Edit - Seems to be fixed now...possibly a fault with tvdb.
(2020-12-18, 10:35)DanCooper Wrote: A Youtube and HD-Trailers fixed version with some new feature will be release before christmas... for 100% shure!

Hmmmm  Huh
(2020-12-25, 07:57)ralfonat Wrote:
(2020-12-18, 10:35)DanCooper Wrote: A Youtube and HD-Trailers fixed version with some new feature will be release before christmas... for 100% shure!

Hmmmm  Huh
After a brief power failure 2 days ago, 2 hard disks in my RAID6 failed. I've been doing backups and rebuilds for the past few days.
Only one module has to be fixed for the release, but I can't do that today (still hangover from yesterday and pray for a successful rebuild).

Sorry for the delay, really wanted to give you a little Christmas present.
(2020-12-25, 17:47)DanCooper Wrote: After a brief power failure 2 days ago, 2 hard disks in my RAID6 failed. I've been doing backups and rebuilds for the past few days.
Only one module has to be fixed for the release, but I can't do that today (still hangover from yesterday and pray for a successful rebuild).

Sorry for the delay, really wanted to give you a little Christmas present.

oh shit. sounds like nothing got lost, so hopefully its just the PITA of waiting for rebuild.

Merry Christmas - I'll patiently wait for our present ;-)
(2020-12-25, 17:47)DanCooper Wrote:
(2020-12-25, 07:57)ralfonat Wrote:
(2020-12-18, 10:35)DanCooper Wrote: A Youtube and HD-Trailers fixed version with some new feature will be release before christmas... for 100% shure!

Hmmmm  Huh
After a brief power failure 2 days ago, 2 hard disks in my RAID6 failed. I've been doing backups and rebuilds for the past few days.
Only one module has to be fixed for the release, but I can't do that today (still hangover from yesterday and pray for a successful rebuild).

Sorry for the delay, really wanted to give you a little Christmas present.


Dan Don't you worry, X-Mas, New Year it doesn't matter. All it matters is that we have these functionality at your convenience !
So take your Time Bro ... but please just get these done !  Blush

I know previously I said about RT ratings , but if at all possible just see about ratings from IMDB, TMDB, TVDB, Rotten Tomatoes and Metacritic + YouTube /HD-trailers fix

Cheers , Happy Holidays & stay safe !
(2020-12-20, 00:07)ralfonat Wrote: anything we can help there? is it just a user-agent thing or something more complex?
I'm not shure. The connection will be closed by remote host if i use a simpel System.Net.WebClient. If you've time than try to create a solution in VisualStudio (please use a new project and don't change Embers source code).
(2020-12-26, 23:23)DanCooper Wrote:
(2020-12-20, 00:07)ralfonat Wrote: anything we can help there? is it just a user-agent thing or something more complex?
I'm not shure. The connection will be closed by remote host if i use a simpel System.Net.WebClient. If you've time than try to create a solution in VisualStudio (please use a new project and don't change Embers source code).

Works flawlessly for me.

Code goes here: (needs NuGet package Fizzler.Systems.HtmlAgilityPack)

Code:

{
    WebClient wc = new WebClient();
    string srchHtml = wc.DownloadString("https://www.videobuster.de/titlesearch.php?search_title=die+croods");

    string movieUrl = "";

    HtmlAgilityPack.HtmlDocument html = new HtmlAgilityPack.HtmlDocument();
    html.LoadHtml(srchHtml);
    HtmlAgilityPack.HtmlNode doc = html.DocumentNode;
    foreach (HtmlAgilityPack.HtmlNode resNode in doc.QuerySelectorAll("ul.list div.infos"))
    {
        HtmlAgilityPack.HtmlNode linkNode = resNode.QuerySelector("a.title");
        movieUrl = new Uri(new Uri("https://www.videobuster.de"), linkNode.GetAttributeValue("href", "")).ToString();
    }

    if (movieUrl.Length>0)
    {
        string movieHtml = wc.DownloadString(movieUrl);

        HtmlAgilityPack.HtmlDocument htmlMovie = new HtmlAgilityPack.HtmlDocument();
        htmlMovie.LoadHtml(movieHtml);
        HtmlAgilityPack.HtmlNode docMovie = htmlMovie.DocumentNode;
        foreach (HtmlAgilityPack.HtmlNode resNode in docMovie.QuerySelectorAll("div#trailer div.playlist div.item"))
        {
            Debug.WriteLine(resNode.InnerText);

            foreach (HtmlAgilityPack.HtmlNode metaNode in resNode.QuerySelectorAll("meta[itemprop=contentUrl]"))
            {
                string videoFileUrl = metaNode.GetAttributeValue("content", "");

                Debug.WriteLine(videoFileUrl);

                string tmpFile = System.IO.Path.GetTempFileName();
                wc.DownloadFile(videoFileUrl, tmpFile);

            }

            //HtmlAgilityPack.HtmlNode linkNode = resNode.QuerySelector("a.title");
            //movieUrl = new Uri(new Uri("https://www.videobuster.de"), linkNode.GetAttributeValue("href", "")).ToString();
        }

    }
}

https://dotnetfiddle.net/ywYwvW
(2020-12-27, 09:31)ralfonat Wrote: https://dotnetfiddle.net/ywYwvW
Thank you. I don't had a problem to parse it, the problem was to download the file. But sometimes the solution is too easy (I'm feeling a little stupid right now)... it will work if i replace https:// with http:// in the video link Rofl
(2020-12-27, 12:57)DanCooper Wrote:
(2020-12-27, 09:31)ralfonat Wrote: https://dotnetfiddle.net/ywYwvW
Thank you. I don't had a problem to parse it, the problem was to download the file. But sometimes the solution is too easy (I'm feeling a little stupid right now)... it will work if i replace https:// with http:// in the video link Rofl
We have all been there Big Grin

For me the https:// links are working though  Huh
Dan : Is there any way to save the extra fanart from being deleted when rescraping. I have plenty of obscure films that I had to do my custom artwork including fanarts. when ever I have to rescrpae even a single filed like NFO it just delete's the extra fanart folder.
I have enabled the option to "keep existing " but that does not seem to do it ?
Can you help ?
Hi @DanCooper 
I installed the latest version of Ember on a new laptop. I then copied my profiles folder over to the new laptop.
Everything scrapes beautifully, except for the following problems:
Image
The release date on my movies not being scraped. I use TMDB for this.
Image
Premiered on my TV shows not being scraped. I use TVDB for this.
Image


Image
Wrong posters being scraped. It scrapes the posters from TMDB & not TVDB. As you can see I've set it to use TVDB for my posters.
When I scrape these shows on my old laptop, it scrapes it 100%. I don't think there's any problems on the websites.
Can you maybe advise me what the problem could be?
Thanks
Kodi v18.9 (Aeon MQ8 Multi-Mod) running on Windows 10
Windows 10 64 the installer seems to install but makes no desktop icon nothing in install folder
this work like yadis? you map youre media shares and it scans them? if so how? ive been looking
  • 1
  • 26
  • 27
  • 28(current)
  • 29
  • 30
  • 45

Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.9.x - Download & Discussion Thread2
This forum uses Lukasz Tkacz MyBB addons.