•   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 9
  •   
WIP Ember Media Manager 1.5.x - Discussion Thread
#31
(2020-02-22, 03:36)noonan2678 Wrote: Thanks, Dan.  I edited my original post above with the specific error.  It happens after clicking "ok" once the image scraping is complete.  I put the Ember install folder in the exceptions my security suite, so not that.  Since it's displaying all the images, maybe the error is based on the trailer scrape?  

I'd much rather just keep the install as-is if the error itself is one you're familiar with and has a fix.

Thank you again!

EDIT - I disabled the IMDb trailer scraper and now get this error once clicking "ok" after the image scraping - "Method not found: 'System.String EmberAPI.HTTP.DownloadData(System.String)"

EDIT 2 - If I disable trailer scraping altogether, it works.  So, this is related to trailers only.
The IMDb trailer scraper has been removed in 1.4.91.x because they now only provides crappy 480p trailers. So I'm wondering it's still existing in your installation even if you've install the new version over the old one. The installer removes all modules and files exept Profiles and Temp folder to get a clean new installation.
Reply
#32
(2020-02-22, 01:05)DanCooper Wrote:
(2020-02-21, 21:57)ping182nz Wrote: Thanks very much for the update, I get the following error when trying to scrape a movie with a comma in the title.... at least i think that is the issue? i.e. Alexander and the Terrible, Horrible, No Good, Very Bad Day (2014)
Image

Any ideas?
Error log? 

Sorry, this is weird, but I tried twice this morning to scrape it with the same error, just tried 8 hours later and now working!
log here if you want to see it.
Reply
#33
WoW
Thanks so so much Love
Youtube trailer finally worked again.
Reply
#34
(2020-02-22, 03:55)DanCooper Wrote: The IMDb trailer scraper has been removed in 1.4.91.x because they now only provides crappy 480p trailers. So I'm wondering it's still existing in your installation even if you've install the new version over the old one. The installer removes all modules and files exept Profiles and Temp folder to get a clean new installation.

Hmm, Ok.  Which trailer scrapers should exist?  I did enable just HD-Trailers and it works.  Maybe IMDb and one or more others are still in there.  IMDb does still show in my list...what files should be removed to get rid of it and potentially others that shouldn't be in this version?  Thanks again!
Reply
#35
(2020-02-22, 01:18)DanCooper Wrote:
(2020-02-21, 20:49)Boulder Wrote: Many thanks for the new version Blush

I have IMDb as the first scraper and TMDb as the second one. I have some items that don't have a plot or plot outline in IMDb but all the other data is better in my opinion. Now when I scrape, I get the IMDb plot outline displayed with text "Know what this is?" or something like that because IMDb returns only that. I then empty the field and click Next, after which the TMDb plot data appears. However, it is not used when the scraping is finished and I get to preview all the scraped data but the IMDb returned "generic" plot text is there. Is this a bug?
Do you've an example of a movie? Do you use the "Settings => Movies => Data Scraper => Show scraper results in detaild view" or what do you mean with "preview"?  
I don't have that one enabled, I mean by preview that window you get after that.

So the process here is:
1) Select title to scrape and press CTRL+I to scrape it
2) The IMDb window appears, select the correct title from the list
3) IMDb fetches plot data, I clean the fields because it only says "Know what this is about?" which means IMDb does not have a plot.
4) A similar window than in 2) appears with TMDb list, select title and it shows TMDb plot data. I found this behaviour by total accident.
5) I accept the TMDb plot data by proceeding to the next phase, which is that preview window that shows all the collected data and where you can then change the art etc. if you like. However, the plot data is once again what IMDb provided.

You can test for example with tt9844298 (Deep Purple: ...To the Rising Sun in Tokyo (2015)).


EDIT: Also, is it supposed to jump to the next scraper if the title is not found? For example "The Alan Parsons Symphonic Project: Live in Colombia" is not in IMDb but can be found in TMDb. To scrape, I need to manually put TMDb as the first scraper or it won't work.
Reply
#36
(2020-02-22, 01:12)DanCooper Wrote:
(2020-02-21, 23:46)shwetkprabhat Wrote: The kodi sync is still not working Sad
Quote:2020-02-21 13:47:11.5125,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,8,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:12.5282,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,16,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:13.5437,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,8,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:14.5594,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,16,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: True,
2020-02-21 13:47:15.5754,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_55_IsScanningVideo.MoveNext,8,TRACE,[APIKodi][Kodi Headless Docker] IsScanningVideo: False,
2020-02-21 13:47:15.6062,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_32_SearchMovie.MoveNext,16,WARN,"[APIKodi][Kodi Headless Docker][SearchMovie] ""Z:\bollywood\Baazigar.1993.1080p.amazon.webdl.eac3.h264-Telly\Baazigar.1993.1080p.amazon.webdl.eac3.h264-Telly.mkv"" | NOT found in host database!",
2020-02-21 13:47:15.6062,generic.Interface.Kodi.Kodi.APIKodi,generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_39_UpdateInfo_Movie.MoveNext,16,ERROR,"[APIKodi][Kodi Headless Docker] UpdateInfo_Movie: ""Baazigar"" | NOT found on host! Abort!",
2020-02-21 13:47:15.6062,generic.Interface.Kodi.KodiInterface,generic.Interface.Kodi.KodiInterface+VB$StateMachine_74_GenericRunCallBack.MoveNext,16,WARN,[KodiInterface][Kodi Headless Docker][GenericRunCallBack] | Sync Failed:  Baazigar,
2020-02-21 13:47:15.6062,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,16,TRACE,[ModulesManager][RunGeneric][Start] <Notification>,
2020-02-21 13:47:15.6062,EmberAPI.ModulesManager,EmberAPI.ModulesManager.RunGeneric,16,TRACE,[ModulesManager][RunGeneric] Run generic module <Notifications>,
Need the full Kodi Interface part of the log, not only a part of it. 
Here you go - https://pastebin.com/B6ZbtCu8
Reply
#37
(2020-02-22, 17:10)noonan2678 Wrote:
(2020-02-22, 03:55)DanCooper Wrote: The IMDb trailer scraper has been removed in 1.4.91.x because they now only provides crappy 480p trailers. So I'm wondering it's still existing in your installation even if you've install the new version over the old one. The installer removes all modules and files exept Profiles and Temp folder to get a clean new installation.

Hmm, Ok.  Which trailer scrapers should exist?  I did enable just HD-Trailers and it works.  Maybe IMDb and one or more others are still in there.  IMDb does still show in my list...what files should be removed to get rid of it and potentially others that shouldn't be in this version?  Thanks again! 

Please just use the installer and let him clean your existing installation.
Reply
#38
(2020-02-22, 21:28)shwetkprabhat Wrote:
(2020-02-22, 01:12)DanCooper Wrote:
(2020-02-21, 23:46)shwetkprabhat Wrote: The kodi sync is still not working Sad
Need the full Kodi Interface part of the log, not only a part of it.  
Here you go - https://pastebin.com/B6ZbtCu8 
First: How do you installed the latest version? You still have modules installed they no longer are part of the installer package.

Then:
Your Kodi needs nearly 2 min (10:38:27 to 10:40:09) to scan one single folder (smb://10.10.10.10/movies/bollywood/Good.Newwz.2019.1080p.AMZN.WEB-DL.DD+5.1.x264-Telly/). Is that normal? My Kodi needs 1 second for a task like this.
Do you've enabled NFO saving under "File Names" in the settings and Ember also creates an NFO in that movie folder? Otherwise (depends on Kodi scraper settings, scraper "Local Info Only" needs a NFO) Kodi can't find the movie.
Reply
#39
(2020-02-22, 18:34)Boulder Wrote:
(2020-02-22, 01:18)DanCooper Wrote:
(2020-02-21, 20:49)Boulder Wrote: Many thanks for the new version Blush

I have IMDb as the first scraper and TMDb as the second one. I have some items that don't have a plot or plot outline in IMDb but all the other data is better in my opinion. Now when I scrape, I get the IMDb plot outline displayed with text "Know what this is?" or something like that because IMDb returns only that. I then empty the field and click Next, after which the TMDb plot data appears. However, it is not used when the scraping is finished and I get to preview all the scraped data but the IMDb returned "generic" plot text is there. Is this a bug?
Do you've an example of a movie? Do you use the "Settings => Movies => Data Scraper => Show scraper results in detaild view" or what do you mean with "preview"?   
I don't have that one enabled, I mean by preview that window you get after that.

So the process here is:
1) Select title to scrape and press CTRL+I to scrape it
2) The IMDb window appears, select the correct title from the list
3) IMDb fetches plot data, I clean the fields because it only says "Know what this is about?" which means IMDb does not have a plot.
4) A similar window than in 2) appears with TMDb list, select title and it shows TMDb plot data. I found this behaviour by total accident.
5) I accept the TMDb plot data by proceeding to the next phase, which is that preview window that shows all the collected data and where you can then change the art etc. if you like. However, the plot data is once again what IMDb provided.

You can test for example with tt9844298 (Deep Purple: ...To the Rising Sun in Tokyo (2015)).


EDIT: Also, is it supposed to jump to the next scraper if the title is not found? For example "The Alan Parsons Symphonic Project: Live in Colombia" is not in IMDb but can be found in TMDb. To scrape, I need to manually put TMDb as the first scraper or it won't work. 
You cant overwrite the plot or plot outline in the search result dialog, because it's a search results dialog, only that fields for the dialog has been scraped (to save time) and the full information will be rescraped after you've selected the correct movie.

Never saw "Know what this is about?" as result, so I've to add that as text to ignore in the IMDb scraper.

Scraper ordering: yes, that's how it works. It's not perfect if a movie don't has been found on all scrapers but i can't change that in this release. That's something that will be changed in the real "new" Ember version.
Reply
#40
(2020-02-22, 18:34)Boulder Wrote: You can test for example with tt9844298 (Deep Purple: ...To the Rising Sun in Tokyo (2015)).

This movie don't have an IMDb ID entry on TMDb, so that movie can't be scraped properly or without manually user input. But TMDb is an open source database! Create a TMDb account and add the IMDb ID to this movie so that other user not run into the same issue like you ;-)
Reply
#41
(2020-02-22, 22:15)DanCooper Wrote:
(2020-02-22, 21:28)shwetkprabhat Wrote:
(2020-02-22, 01:12)DanCooper Wrote: Need the full Kodi Interface part of the log, not only a part of it.  
Here you go - https://pastebin.com/B6ZbtCu8  
First: How do you installed the latest version? You still have modules installed they no longer are part of the installer package.

Then:
Your Kodi needs nearly 2 min (10:38:27 to 10:40:09) to scan one single folder (smb://10.10.10.10/movies/bollywood/Good.Newwz.2019.1080p.AMZN.WEB-DL.DD+5.1.x264-Telly/). Is that normal? My Kodi needs 1 second for a task like this.
Do you've enabled NFO saving under "File Names" in the settings and Ember also creates an NFO in that movie folder? Otherwise (depends on Kodi scraper settings, scraper "Local Info Only" needs a NFO) Kodi can't find the movie. 
I selected the old folder during installation, let me know if its not the right way to do it...
You are right when it worked, it used to take couple of seconds to work, now it takes several mins and then it fails. Yes I have save NFO in the movie folder and use frodo/helix naming standard.
Reply
#42
(2020-02-22, 22:47)shwetkprabhat Wrote: I selected the old folder during installation, let me know if its not the right way to do it...
To select the old folder is the right way. The installer removes all files in the installation directory and all folders exept profiles and temp during the installation. Where do you've installed Ember? C:\Program Files is a problem because you need special access rights to add, remove or change files inside this folder... and Ember and the installer has to save and change files in the installation folder.
If you don't find the rease why Ember can't clean up your installation then do a backup of the folders "Profiles" and "Temp", delete the installation directory and do a new install. Then copy the two folder back to the installation directory.

(2020-02-22, 22:47)shwetkprabhat Wrote: You are right when it worked, it used to take couple of seconds to work, now it takes several mins and then it fails. Yes I have save NFO in the movie folder and use frodo/helix naming standard.
If the KI is done, is the movie listed in Kodi? If not you've the enable the debug log with JSON RPC logging in Kodi and to check the log what Kodi is exactly do while and after the sync process.
Reply
#43
(2020-02-22, 22:59)DanCooper Wrote:
(2020-02-22, 22:47)shwetkprabhat Wrote: I selected the old folder during installation, let me know if its not the right way to do it...
To select the old folder is the right way. The installer removes all files in the installation directory and all folders exept profiles and temp during the installation. Where do you've installed Ember? C:\Program Files is a problem because you need special access rights to add, remove or change files inside this folder... and Ember and the installer has to save and change files in the installation folder.
If you don't find the rease why Ember can't clean up your installation then do a backup of the folders "Profiles" and "Temp", delete the installation directory and do a new install. Then copy the two folder back to the installation directory.
(2020-02-22, 22:47)shwetkprabhat Wrote: You are right when it worked, it used to take couple of seconds to work, now it takes several mins and then it fails. Yes I have save NFO in the movie folder and use frodo/helix naming standard.
If the KI is done, is the movie listed in Kodi? If not you've the enable the debug log with JSON RPC logging in Kodi and to check the log what Kodi is exactly do while and after the sync process. 
Ok - looks like i found the installation issue, look at the fresh logs - https://pastebin.com/fD7TXZ03

No after KI is done Kodi Db is not updated, for clarity I am running Headless Docker image and a mysqldb that I am trying to update. I am trying to get the debug logs, not sure how yet.
Reply
#44
(2020-02-22, 23:44)shwetkprabhat Wrote: Ok - looks like i found the installation issue
Looks good now.

(2020-02-22, 23:44)shwetkprabhat Wrote: No after KI is done Kodi Db is not updated, for clarity I am running Headless Docker image and a mysqldb that I am trying to update. I am trying to get the debug logs, not sure how yet.
You can enable debug logging in the GUI. I don't know how to enable it if you don't have access to the GUI.
Reply
#45
(2020-02-22, 23:58)DanCooper Wrote:
(2020-02-22, 23:44)shwetkprabhat Wrote: Ok - looks like i found the installation issue
Looks good now.
(2020-02-22, 23:44)shwetkprabhat Wrote: No after KI is done Kodi Db is not updated, for clarity I am running Headless Docker image and a mysqldb that I am trying to update. I am trying to get the debug logs, not sure how yet.
You can enable debug logging in the GUI. I don't know how to enable it if you don't have access to the GUI.  
I have enabled it via the web interface, trying to find out where the docker is storing the logs. Image
Reply
  •   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 9
  •   
 
Thread Rating:
  • 1 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.5.x - Discussion Thread41
This forum uses Lukasz Tkacz MyBB addons.