Updating error?
#1
When I go into add-ons and run update recently there are two add-ons with updates waiting but when I try to update I get this error:

"The dependency on xbmc.python 3.0.0 could not be satisfied"

I have been researching off and on for a couple of days and can't find an answer.........

Anyone have a solution?

Thanks!
Reply
#2
Probably related to this... https://forum.kodi.tv/showthread.php?tid=351745
and this... https://kodi.tv/article/kodi-19-python-3-goes-live
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
(2020-03-04, 00:22)Karellen Wrote: Probably related to this... https://forum.kodi.tv/showthread.php?tid=351745
and this... https://kodi.tv/article/kodi-19-python-3-goes-live
I guess I just don't understand......I get the above mentioned errors in KODI 18.6 and a portable install of (last nights nightly) of KODI 19.
Should I get the error in KODI 19 as well?

Thanks
Reply
#4
(2020-03-04, 04:08)melons2 Wrote: I get the above mentioned errors in KODI 18.6
You did not mention that in your first post. At least tell us which three addons are causing you problems and provide a Debug Log of you trying to update them.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#5
Since 29 Feb, addons intended to be used in Kodi 19 Matrix nightly must specify in their addon.xml a dependency on Python 3.0.0.  Addons which specify any Python 2.x.x will not install/update/run (even if they are compatible with both python versions).  Python 2 addons should work in 18.6, and currently the plan is to have addons in the Kodi repo provide versions in the Leia (or "lower") repo and also in the Matrix repo (if updated to Python 3).

Update:  I don't see any problem here on 18.6 installed on top of 18.5 (only had one addon to update which happened to be youtube alpha 2 and it updated with no issues).  I installed the 0303 19 nightly over an older 19 nightly and a bunch of addons were disabled after first running the new nightly.  I edited the addon.xml files for all the disabled ones (I've been doing some local updating of addons to Python 3 so I think they work) and re-enabled them all in Kodi 19.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix see: Aeon MQ5 Mod Martix release thread
Leia see: Aeon MQ5 Mod Leia release thread
Reply
#6
(2020-03-04, 18:10)scott967 Wrote: Since 29 Feb, addons intended to be used in Kodi 19 Matrix nightly must specify in their addon.xml a dependency on Python 3.0.0.  Addons which specify any Python 2.x.x will not install/update/run (even if they are compatible with both python versions).  Python 2 addons should work in 18.6, and currently the plan is to have addons in the Kodi repo provide versions in the Leia (or "lower") repo and also in the Matrix repo (if updated to Python 3).

Update:  I don't see any problem here on 18.6 installed on top of 18.5 (only had one addon to update which happened to be youtube alpha 2 and it updated with no issues).  I installed the 0303 19 nightly over an older 19 nightly and a bunch of addons were disabled after first running the new nightly.  I edited the addon.xml files for all the disabled ones (I've been doing some local updating of addons to Python 3 so I think they work) and re-enabled them all in Kodi 19.

scott s.
.
I understand now......

The two, not three, were really meant for Matrix with python 3.

Just for my own education:
How old is python 2.xxx?
How old is python 3.xxxx already?

Thanks!
Reply
#7
Python 2 was released in the Year 2000 (16th October to be exact) and was EOL'd at the start of this year.

Python 3 was released in 2008 (3rd December) and is the currently active and supported one. Current stand-alone release version is 3.8.2 (released a couple of weeks ago), although various other versions are around and supported.

More details etc at https://www.python.org/
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#8
(2020-03-04, 18:10)scott967 Wrote: I edited the addon.xml files for all the disabled ones
If I can ask, what changes need to be made to the addon.xml files? I'm also using a few addons with the latest Milhouse builds which auto-disabled and I'd like to try and get them working again.

I'm by no means a coder, but I've got a copy of Notepad++ installed on my Windows box and I'm not afraid to use it... :-)

Note: I'm talking about an addon or two that I believe are Python 2/3 compatible (Roosterteeth video addon for example).
Matrix 19.x (LE), Aeon Nox SiLVO, NUC8i5BEK (i5-8259U, Intel Iris Plus Graphics 655, 16 GB ram, 128 GB M.2 SSD)
Samsung F6300 46" LED LCD TV, SMSL Q5 Pro amplifier, Pioneer HPM-100 speakers
Synology DS215j NAS fileserver (WD Gold 10TB x 2)
Reply
#9
From my understanding, changing <import addon="xbmc.python" version="2.x.x" /> (where 2.x.x is whatever version of Python 2 the addon requires) to <import addon="xbmc.python" version="3.0.0" /> in the <requires> tag pair should do the trick, at least for any addon which is actually Python 2/3 compatible.

It won't of course magically make a Python2 only addon work with v19.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#10
(2020-03-07, 09:54)DarrenHill Wrote: From my understanding, changing...
Thank you! I hoped that might be it, but wasn't sure. I'll try it this weekend.
Matrix 19.x (LE), Aeon Nox SiLVO, NUC8i5BEK (i5-8259U, Intel Iris Plus Graphics 655, 16 GB ram, 128 GB M.2 SSD)
Samsung F6300 46" LED LCD TV, SMSL Q5 Pro amplifier, Pioneer HPM-100 speakers
Synology DS215j NAS fileserver (WD Gold 10TB x 2)
Reply
#11
(2020-03-05, 16:38)DarrenHill Wrote: Python 2 was released in the Year 2000 (16th October to be exact) and was EOL'd at the start of this year.

Python 3 was released in 2008 (3rd December) and is the currently active and supported one. Current stand-alone release version is 3.8.2 (released a couple of weeks ago), although various other versions are around and supported.

More details etc at https://www.python.org/

Hey. I have an nvidia shield with the latest kodi 19 matrix installed and I am trying to install the latest titan binji mod skin by achillespunks that is made for the 19 version. It keeps telling me the error that python 2.1.0 is not satisfied.. I really don't understand why can you help me with that please. Thanks
Reply
#12
The section for the Titan skin and it's various mods is here.

You're best off asking there, as obviously either it or more likely one of its dependencies is still using Python 2 and needs updating (or the correct version installing).
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply



Logout Mark Read Team Forum Stats Members Help
Updating error?0
This forum uses Lukasz Tkacz MyBB addons.