Horrible Ghosting problem in Xiaomi Mi TV Box S
#1
Hello everyone. Recently I have ben experiencing ghosting problems in 2D movies. I didn´t notice it before, I think it has appeared after the update to android 9.0 released recently by xiaomi.
Well, After doing a thounsand tests, changing the cables, settings, everything, it seems that I have found the solution, but it is not a very definitive solution for me:

I have disabled the option "Hardware acceleration mediacodec surface". With it enabled the ghosting is horrible, with it disabled the ghosting disappeares. It is curious, because the ghosting also appeares in VLC app, so I assume that the problem has to do with the hardware or the system of Xiaomi. Disabling hardware acceleration in VLC makes the ghosting less noticeable, but it is still there, it does not dissapear completly as it does in Kodi....

Anyway, by disabling the option in Kodi, another problem comes with the 3D movies. The control panel is not welll located and the 3d movies are not correctly detected... It is weird, I don´t seem to notice any ghost with the option enabled playing 3D movies. so what I will need to do is to let the option disabled for most movies (2D), and only enable it when playing 3D movies.

Then, what is the cause of this problem?. I have tried the same movie a thousand times, with another devices with kodi, Xbox one, android TV sticks.... and all play the movie perfectly fine with hardware acceleration on, why does xiaomi behave so bad?... I have never had problems with the hardware acceleration options in the past during the whole life of kodi, even when it was XBMC.....

I guess that with the update, Xiaomi has broken something regarding their hardware decoding  and so, if you enable kodi option, kodi tries to use the decoding of the Xiaomi system, and as it is broken, the movie plays with the ghosting problems.... can it be so?....

Well, here is my story, lets hope some expert can solve my doubts and give me a definitive solution in order not to be changing the option anytime I want to see 3D movies.....


Best regards and thank you in advance.
Reply
#2
(2020-03-09, 08:51)DrJ Wrote: Hello everyone. Recently I have ben experiencing ghosting problems in 2D movies. I didn´t notice it before, I think it has appeared after the update to android 9.0 released recently by xiaomi.
Well, After doing a thounsand tests, changing the cables, settings, everything, it seems that I have found the solution, but it is not a very definitive solution for me:

I have disabled the option "Hardware acceleration mediacodec surface". With it enabled the ghosting is horrible, with it disabled the ghosting disappeares. It is curious, because the ghosting also appeares in VLC app, so I assume that the problem has to do with the hardware or the system of Xiaomi. Disabling hardware acceleration in VLC makes the ghosting less noticeable, but it is still there, it does not dissapear completly as it does in Kodi....

Anyway, by disabling the option in Kodi, another problem comes with the 3D movies. The control panel is not welll located and the 3d movies are not correctly detected... It is weird, I don´t seem to notice any ghost with the option enabled playing 3D movies. so what I will need to do is to let the option disabled for most movies (2D), and only enable it when playing 3D movies.

Then, what is the cause of this problem?. I have tried the same movie a thousand times, with another devices with kodi, Xbox one, android TV sticks.... and all play the movie perfectly fine with hardware acceleration on, why does xiaomi behave so bad?... I have never had problems with the hardware acceleration options in the past during the whole life of kodi, even when it was XBMC.....

I guess that with the update, Xiaomi has broken something regarding their hardware decoding  and so, if you enable kodi option, kodi tries to use the decoding of the Xiaomi system, and as it is broken, the movie plays with the ghosting problems.... can it be so?....

Well, here is my story, lets hope some expert can solve my doubts and give me a definitive solution in order not to be changing the option anytime I want to see 3D movies.....


Best regards and thank you in advance.
With the option "Hardware acceleration mediacodec surface" disabled, Kodi HDR playback is also disabled.
Kodi 19.1 Android/Google(TV) [ Shield TV Pro [64b] / Mi Box S [32b] / Mi Projector / Fire 4k TV stick / CC with Google TV ]
Kodi 19 [3D MVC build] Shuttle DH270 [Kaby Lake i3-7300/HD630 graphics - W10-1903]
Reply
#3
I have the same issue with Mi Box S, and today figured the same - If I set Hardware acceleration mediacodec surface to disabled, ghosting is gone. But as you mentioned the problem is wide, not only related to Kodi as it seems since in Plex I had exactly same issue. 

Mi Box S (EU) / OS / Android 9 / PI.2231 build / latest Android TV Kodi build
Reply
#4
Hi all
My name is Stefan, i am glad to be an member of this forum
I am having some image problems with xiaomi mi box 3s connected on my 4k Samsung series 6
The icons shows pinkish, in the kodi menu all the images shows ok but when playing movies the colors are bad, I've tried also on YouTube app from mi box 3s and also i don't get good colors like the Samsung tv YouTube app
Any suggestions
Thank you
Reply
#5
(2020-03-24, 02:38)froxic Wrote: I have the same issue with Mi Box S, and today figured the same - If I set Hardware acceleration mediacodec surface to disabled, ghosting is gone. But as you mentioned the problem is wide, not only related to Kodi as it seems since in Plex I had exactly same issue. 

Mi Box S (EU) / OS / Android 9 / PI.2231 build / latest Android TV Kodi build
I have 2 Mi Box S devices, one is still on 8.1 and doesn't have that issues at all. I will flash the ATV9 one back to 8.1 as soon I have the special USB cable that is needed.

@scufutz, you can check if the HDMI cable is 100% or you can check if the HDMI port on your TV is set on "deep" or "high" color, or what that is named on your TV, and disabling that.
Kodi 19.1 Android/Google(TV) [ Shield TV Pro [64b] / Mi Box S [32b] / Mi Projector / Fire 4k TV stick / CC with Google TV ]
Kodi 19 [3D MVC build] Shuttle DH270 [Kaby Lake i3-7300/HD630 graphics - W10-1903]
Reply
#6
I've managed to get the image right by turning sdr to hdr off
Thank you for advice
And with an simple 5€ USB 3.0 hub I've managed to connect lan via xiaomi mi box s usb
Also I've attached two Xbox controllers to test some multi-player games for mi kids
Stay safe
Reply
#7
I'm using the recent PI.2582 OTA2 Beta1 on one of my Mi Boxes sins several days, it is so much better then the "Final" ATV 9 build that gives those horrible ghosting and black issues (on my Oled). There is already an even newer 2582 build (Beta2) but that seems to be no so great, so sticking with 2582 Beta1.
Kodi 19.1 Android/Google(TV) [ Shield TV Pro [64b] / Mi Box S [32b] / Mi Projector / Fire 4k TV stick / CC with Google TV ]
Kodi 19 [3D MVC build] Shuttle DH270 [Kaby Lake i3-7300/HD630 graphics - W10-1903]
Reply
#8
(2020-04-09, 12:17)p750mmx Wrote: I'm using the recent PI.2582 OTA2 Beta1 on one of my Mi Boxes sins several days, it is so much better then the "Final" ATV 9 build that gives those horrible ghosting and black issues (on my Oled). There is already an even newer 2582 build (Beta2) but that seems to be no so great, so sticking with 2582 Beta1.

Sounds like a solution. Ill try to revert to beta build and check the ghosting. What is bad that I already reported this to Xiaomi and in new Android version, second stable ATV 9 release it wasnt fixed, and also HDMI audio dropouts are still present :-(( I ordered Shiled TV PRO 2019 already, but Im on waiting line still...
Reply
#9
So its not possible to do such rollback via recovery Undecided/
Reply
#10
(2020-03-09, 08:51)DrJ Wrote: Hello everyone. Recently I have ben experiencing ghosting problems in 2D movies. I didn´t notice it before, I think it has appeared after the update to android 9.0 released recently by xiaomi.
Well, After doing a thounsand tests, changing the cables, settings, everything, it seems that I have found the solution, but it is not a very definitive solution for me:

I have disabled the option "Hardware acceleration mediacodec surface". With it enabled the ghosting is horrible, with it disabled the ghosting disappeares. It is curious, because the ghosting also appeares in VLC app, so I assume that the problem has to do with the hardware or the system of Xiaomi. Disabling hardware acceleration in VLC makes the ghosting less noticeable, but it is still there, it does not dissapear completly as it does in Kodi....

Anyway, by disabling the option in Kodi, another problem comes with the 3D movies. The control panel is not welll located and the 3d movies are not correctly detected... It is weird, I don´t seem to notice any ghost with the option enabled playing 3D movies. so what I will need to do is to let the option disabled for most movies (2D), and only enable it when playing 3D movies.

Then, what is the cause of this problem?. I have tried the same movie a thousand times, with another devices with kodi, Xbox one, android TV sticks.... and all play the movie perfectly fine with hardware acceleration on, why does xiaomi behave so bad?... I have never had problems with the hardware acceleration options in the past during the whole life of kodi, even when it was XBMC.....

I guess that with the update, Xiaomi has broken something regarding their hardware decoding  and so, if you enable kodi option, kodi tries to use the decoding of the Xiaomi system, and as it is broken, the movie plays with the ghosting problems.... can it be so?....

Well, here is my story, lets hope some expert can solve my doubts and give me a definitive solution in order not to be changing the option anytime I want to see 3D movies.....


Best regards and thank you in advance.

Thanks for the tip, I was going through the same problem, I thought it was an HDMI cable problem, buy a 2.0.

Xiaomi Tv Box is a great but unstable device, Nvidia TV Shield is the best option but also the most expensive.

Regards.
Reply
#11
(2020-06-18, 03:45)fidelioh Wrote:
(2020-03-09, 08:51)DrJ Wrote: Hello everyone. Recently I have ben experiencing ghosting problems in 2D movies. I didn´t notice it before, I think it has appeared after the update to android 9.0 released recently by xiaomi.
Well, After doing a thounsand tests, changing the cables, settings, everything, it seems that I have found the solution, but it is not a very definitive solution for me:

I have disabled the option "Hardware acceleration mediacodec surface". With it enabled the ghosting is horrible, with it disabled the ghosting disappeares. It is curious, because the ghosting also appeares in VLC app, so I assume that the problem has to do with the hardware or the system of Xiaomi. Disabling hardware acceleration in VLC makes the ghosting less noticeable, but it is still there, it does not dissapear completly as it does in Kodi....

Anyway, by disabling the option in Kodi, another problem comes with the 3D movies. The control panel is not welll located and the 3d movies are not correctly detected... It is weird, I don´t seem to notice any ghost with the option enabled playing 3D movies. so what I will need to do is to let the option disabled for most movies (2D), and only enable it when playing 3D movies.

Then, what is the cause of this problem?. I have tried the same movie a thousand times, with another devices with kodi, Xbox one, android TV sticks.... and all play the movie perfectly fine with hardware acceleration on, why does xiaomi behave so bad?... I have never had problems with the hardware acceleration options in the past during the whole life of kodi, even when it was XBMC.....

I guess that with the update, Xiaomi has broken something regarding their hardware decoding  and so, if you enable kodi option, kodi tries to use the decoding of the Xiaomi system, and as it is broken, the movie plays with the ghosting problems.... can it be so?....

Well, here is my story, lets hope some expert can solve my doubts and give me a definitive solution in order not to be changing the option anytime I want to see 3D movies.....


Best regards and thank you in advance.

Thanks for the tip, I was going through the same problem, I thought it was an HDMI cable problem, buy a 2.0.

Xiaomi Tv Box is a great but unstable device, Nvidia TV Shield is the best option but also the most expensive.

Regards.
Picture quality with ATV9 isn't as great as that of a Shield (Pro), that's correct, with ATV8.1 it seems somewhat better. Unstable though, I can't agree on that. There are very few issues when using it as a streaming only device, with various apps. You can't expect the same level, compared with the 2019 Shield, there are both in a different spectrum as an AndroidTV device. Price-wise also Wink
Kodi 19.1 Android/Google(TV) [ Shield TV Pro [64b] / Mi Box S [32b] / Mi Projector / Fire 4k TV stick / CC with Google TV ]
Kodi 19 [3D MVC build] Shuttle DH270 [Kaby Lake i3-7300/HD630 graphics - W10-1903]
Reply
#12
(2020-06-18, 13:51)p750mmx Wrote:
(2020-06-18, 03:45)fidelioh Wrote:
(2020-03-09, 08:51)DrJ Wrote: Hello everyone. Recently I have ben experiencing ghosting problems in 2D movies. I didn´t notice it before, I think it has appeared after the update to android 9.0 released recently by xiaomi.
Well, After doing a thounsand tests, changing the cables, settings, everything, it seems that I have found the solution, but it is not a very definitive solution for me:

I have disabled the option "Hardware acceleration mediacodec surface". With it enabled the ghosting is horrible, with it disabled the ghosting disappeares. It is curious, because the ghosting also appeares in VLC app, so I assume that the problem has to do with the hardware or the system of Xiaomi. Disabling hardware acceleration in VLC makes the ghosting less noticeable, but it is still there, it does not dissapear completly as it does in Kodi....

Anyway, by disabling the option in Kodi, another problem comes with the 3D movies. The control panel is not welll located and the 3d movies are not correctly detected... It is weird, I don´t seem to notice any ghost with the option enabled playing 3D movies. so what I will need to do is to let the option disabled for most movies (2D), and only enable it when playing 3D movies.

Then, what is the cause of this problem?. I have tried the same movie a thousand times, with another devices with kodi, Xbox one, android TV sticks.... and all play the movie perfectly fine with hardware acceleration on, why does xiaomi behave so bad?... I have never had problems with the hardware acceleration options in the past during the whole life of kodi, even when it was XBMC.....

I guess that with the update, Xiaomi has broken something regarding their hardware decoding  and so, if you enable kodi option, kodi tries to use the decoding of the Xiaomi system, and as it is broken, the movie plays with the ghosting problems.... can it be so?....

Well, here is my story, lets hope some expert can solve my doubts and give me a definitive solution in order not to be changing the option anytime I want to see 3D movies.....


Best regards and thank you in advance.

Thanks for the tip, I was going through the same problem, I thought it was an HDMI cable problem, buy a 2.0.

Xiaomi Tv Box is a great but unstable device, Nvidia TV Shield is the best option but also the most expensive.

Regards.
Picture quality with ATV9 isn't as great as that of a Shield (Pro), that's correct, with ATV8.1 it seems somewhat better. Unstable though, I can't agree on that. There are very few issues when using it as a streaming only device, with various apps. You can't expect the same level, compared with the 2019 Shield, there are both in a different spectrum as an AndroidTV device. Price-wise also Wink
Instead of going for the nvidia shield tv I decided to go for a TCL 4K TV with built-in Android, in my country the cost is almost similar, I hope I don't have any ghosting problems with the TV, the problem seems to be only from Xiaomi.
Reply
#13
Hello to everybody! I Have some short of the same problem here. I have a Mi Box S and I had installed Kodi from the beginning and I updated it to the latest Kodi. I noticed a very strange behavior and I couldn't find a way to handle.
1. I noticed that somehow there was a audio shift from the picture of 225msec.
2. There was a shadow left from the last image onto a black scene that comes after.
3. There was a trailing edge of every lighted scene around the picture.
The steps I took in order to fix the problem were
1. Shifted the audio 225msecs for all videos. That fixed number one.
2. Tried to disengage the surface hardware acceleration and that fixed the whole of problems 2 and 3, and I had a perfect pitch black with no shadows and very sharp images running around the screen... but It' wasn't over...

That was 2 weeks ago.
Yesterday I tried to play a movie with the usual way - through my network- via Ethernet cable installed to Mibox with use of Tp Links USB3 to Ethernet (a configuration that was working) and I had a black screen, with sound and subtitles!!!
By searching the internet all suggesting that i had to disengage the hardware accelerator ... and after that the problems 2 and 3 came back and I can't find any solution at all.
By disengaging both the accelerations Surface and Straight one I have choppy video image and shadows.... 
I tried to install a previous version o f Kodi and tried to keep the earliest 18.7 version but the whole problem remains....
Does anyone have any suggestion that we could make use of it trying to fix this problem?
I think I described the problem in whole, and as I see there is more people having the same or quite similar problems, so we might hope for a solution by Kodi team.
Thank you in advance.
Reply
#14
@Gpaparig did you install the latest Android build? There were some issues with the final 18.7 build, so now you should be on 18.7.200; https://kodi.tv/article/kodi-leia-187-android
Kodi 19.1 Android/Google(TV) [ Shield TV Pro [64b] / Mi Box S [32b] / Mi Projector / Fire 4k TV stick / CC with Google TV ]
Kodi 19 [3D MVC build] Shuttle DH270 [Kaby Lake i3-7300/HD630 graphics - W10-1903]
Reply
#15
(2020-06-22, 09:40)Gpaparig Wrote: Hello to everybody! I Have some short of the same problem here. I have a Mi Box S and I had installed Kodi from the beginning and I updated it to the latest Kodi. I noticed a very strange behavior and I couldn't find a way to handle.
1. I noticed that somehow there was a audio shift from the picture of 225msec.
2. There was a shadow left from the last image onto a black scene that comes after.
3. There was a trailing edge of every lighted scene around the picture.
The steps I took in order to fix the problem were
1. Shifted the audio 225msecs for all videos. That fixed number one.
2. Tried to disengage the surface hardware acceleration and that fixed the whole of problems 2 and 3, and I had a perfect pitch black with no shadows and very sharp images running around the screen... but It' wasn't over...

That was 2 weeks ago.
Yesterday I tried to play a movie with the usual way - through my network- via Ethernet cable installed to Mibox with use of Tp Links USB3 to Ethernet (a configuration that was working) and I had a black screen, with sound and subtitles!!!
By searching the internet all suggesting that i had to disengage the hardware accelerator ... and after that the problems 2 and 3 came back and I can't find any solution at all.
By disengaging both the accelerations Surface and Straight one I have choppy video image and shadows.... 
I tried to install a previous version o f Kodi and tried to keep the earliest 18.7 version but the whole problem remains....
Does anyone have any suggestion that we could make use of it trying to fix this problem?
I think I described the problem in whole, and as I see there is more people having the same or quite similar problems, so we might hope for a solution by Kodi team.
Thank you in advance.
Apparently it is a problem of Xiaomi and not of Kodi, with VLC the same thing that you describe happens, Until Xiaomi updates to Android tv 10 it can take years, months or never.
Reply



Logout Mark Read Team Forum Stats Members Help
Horrible Ghosting problem in Xiaomi Mi TV Box S0
This forum uses Lukasz Tkacz MyBB addons.