Trying to install my first plugin failed with no explicit error on what's wrong
#1
Hi all,
I'm new to the world of writing plugins and I'm developing a video add-ons.
I've reached an initial draft of my plugin, I've zipped and tried to install on Kodi 18 and it failed.
I can't find any logs that can tell me exactly why it failed.
I've looked into kodi.logs and in the event logs in the interface and apart from saying that it failed to install no other clue about what went wrong.

Any suggestion on how I can debug further?

Thanks,
Gianluca.
Reply
#2
Turn on debugging in Kodi  settings->system->logging->enable debug logging.  Exit Kodi and re-start it. Note. This is important as once an addon has failed to install Kodi will never install it (even if the problem is fixed) until it has been restarted.

Try and install your addon from the zip file (I presume you have 'unknown sources' enabled?).

Look in the debug log file for the error(s).  It should be reasonably straightforward to see what is going wrong.
Learning Linux the hard way !!
Reply
#3
Enabled from unknown sources.
Enabled debug log and restarted kodi.
In the log there is only this:

2020-03-19 21:55:45.182 T:4692833728   DEBUG: CAddonInstaller: installing from zip '/Users/gianluca/Downloads/plugin.video.curiositystream.zip'
2020-03-19 21:55:45.198 T:4692833728   DEBUG: ------ Window Init (DialogNotification.xml) ------

and no errors at all logged.

In the event log in the UI of Kodi there is a truncated error message ending with "failed due to an invalid"

Do you know what could be and where to find the rest of the message?

Thanks,
Gianluca
Reply
#4
hmm.. could you upload your zip somewhere so we can check what's wrong?
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#5
I've pushed my current work in progress code in my fork: https://github.com/GMaxera/repo-plugins/...sitystream

Let me know if there is something wrong.

Thanks,
Gianluca.
Reply
#6
thx. i have checked the code and there's nothing wrong with it.

i suspect there's a problem with the zipfile you've created.
a few common pitfalls are:
- you need to add the plugin.video.curiositystream folder itself to the zipfile, and not just the files inside that folder
- make sure your OS isn't adding any files/folders to your zipfile, things like .DS_Store or thumbs.db

if all else fails.. see my previous reply ;-)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#7
Thank you very much ... it worked ... I didn't notice that I was zipping with ".idea" project folder of my IDE plus ".DS_Store" files :-D
Reply



Logout Mark Read Team Forum Stats Members Help
Trying to install my first plugin failed with no explicit error on what's wrong0
This forum uses Lukasz Tkacz MyBB addons.