Solved LG TV and CEC - Key pressed not detected
#1
Hi,

I'm trying to setup Kodi on Raspberry Pi 4 with Raspbian, and more particularly CEC to control Kodi with ma TV Remote. The TV is the LG 55SM9010
CEC seems to be working ok from console, as i can send basic command to the TV from RPI

Code:

[email protected]:~ $ echo volup 0 | cec-client -s -d 1
opening a connection to the CEC adapter...
volume up: 7F

Code:

[email protected]:~ $ echo scan | cec-client -s -d 1
opening a connection to the CEC adapter...
requesting CEC bus information ...
CEC bus information
===================
device #0: TV
address:       0.0.0.0
active source: no
vendor:        LG
osd string:    TV
CEC version:   1.3a
power status:  on
language:      eng


device #1: Recorder 1
address:       4.0.0.0
active source: no
vendor:        LG
osd string:    CECTester
CEC version:   1.3a
power status:  in transition from standby to on
language:      eng


currently active source: unknown (-1)

Turning ON and OFF the TV also works fine. Same with "as" command to switch on the RPI Source.

My problem is the other way around : the raspberry does not detect the key pressed on the remote.

I tried :
  • Raspbian + Kodi
  • OSMC
  • Librelec
  • on a Raspberry Pi 3 B+, with a HDMI cable that worked well with my previous TV

Other informations :
  • The remote with the XBox works fine
  • Simplink (CEC) is activated
Code:

[email protected]:~ $ cec-client -l
libCEC version: 4.0.4, compiled on Linux-4.15.0-48-generic ... , features: P8_USB, DRM, P8_detect, randr, RPi, Exynos, AOCEC
Found devices: 1

device:              1
com port:            RPI
vendor id:           2708
product id:          1001
firmware version:    1
type:                Raspberry Pi



Code:

[email protected]:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

[email protected]:~ $ uname -a
Linux raspberrypi 4.19.97-v7l+ #1294 SMP Thu Jan 30 13:21:14 GMT 2020 armv7l GNU/Linux


And some logs : cojulekadi.kodi (paste)

Any idea what I could do to make this working ?

Thank you
Reply
#2
I found the solution.
In the parameters, I had to go to Network > Device Connector > Home Theatre and unlink the RPI. Then, I linked it in the "Other Box" category, and it worked automatically
Reply
#3
Thread marked solved.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
LG TV and CEC - Key pressed not detected00
This forum uses Lukasz Tkacz MyBB addons.