Linux RPI: CEC-Bug - CEC only works with powered pc
#1
Hello,

My setup: PC and Rpi (3b+) are both connected via hdmi to the tv.

Problem: CEC between rpi and the tv works only when the pc is powered on. 

Why is in my case the running pc crucial for CEC? (Additionaly the TV is connected to a NVIDIA-GPU which dont support CEC at all)
Is there a way that the TV and RPI work standalone with CEC?


Any ideas? 


LG
Dschogo
Reply
#2
Forgot to mention that the TV CEC discovery only lists the RPI (as KODI) when the pc is connected. If the pc is off the discoery list is empty.
Reply
#3
If you disconnect everything but the Pi from the TV and fully power down (at the wall, not just via power switches) both then restart the TV then the Pi, does it work then?
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#4
(2020-04-04, 12:19)DarrenHill Wrote: If you disconnect everything but the Pi from the TV and fully power down (at the wall, not just via power switches) both then restart the TV then the Pi, does it work then?
That worked. (Didnt get any CEC notification that the TV is connected but works)

Hmm but how is the pc affecting the CEC signal? I mean the pc isnt able to sent something other the cec protocol.
Reply
#5
Which OS/kodi are you running on the Pi? (Raspbian, LibreElec, OSMC or something else)?

I run LE on my Pi's, and when I first boot them I get notifications of both searching for CEC connection and achieving it.

Personally I don't know HDMI protocols in great depth so I can't say what the PC might be doing. All I can think of is to connect each item back in turn and confirm if it's the PC or the NVIDIA which is causing the issue (even if it doesn't have CEC), and whether swapping the connection ports on the TV around helps or not.

But others may be able to jump in here with more technical details or recommendations. But at least the Pi itself is working correctly.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#6
All right.

Connected everything back together (one at a time) and its still working Smile . Gonna have a look how long is survives.

I run Rasphian on the rpi 3b+. KOdi is the latest. think 18.6.
Reply
#7
(2020-04-04, 12:12)Dschogo Wrote: Is there a way that the TV and RPI work standalone with CEC?

One thing you also may have to do is change the device name in the CEC settings. Right now, it's probably 'Kodi' by default. Giving each Kodi client its own CEC name could avoid confusion for your TV / Avr.

Also, CEC via the PC goes via a Pulse-Eight adapter? Those things need power via USB. So if the PC is off, the USB port might also not get any juice.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
RPI: CEC-Bug - CEC only works with powered pc0
This forum uses Lukasz Tkacz MyBB addons.