•   
  • 1
  • 16
  • 17
  • 18
  • 19(current)
  • 20
  •   
Release Disney+ Add-on
I'm having an issue with the D+ addon, and I'm not sure what else to try.

I started with Leia 18.7 over last weekend, followed the instructions (Windows 10), and everything worked really well.  I watched a few shows.  Now, three days later, the streams mostly won't play.  I'm getting sound, but either no video or very scrambled video.  It feels like a codec problem.  I can't imagine what changed in those three days.  Unless Disney changed something in their format?

As a test, I went back and tried to replay some of the shows I watched, and they wouldn't work.  This is happening on two separate computers, with similar setups.  Windows 10, Leia 18.7, Most recent IA for Leia, which I think is 4.5?  I've tried all of the "quality" settings, and while I sometimes get a different version of broken, it generally doesn't play correctly.  Some shorter shows/movies will play, but most won't.

I tried upgrading a bunch of things (actually went so far as to update one of the machines to the current Matrix nightly), but nothing changed how the video wasn't coming through.  Really, I'm just looking for more ideas on things that I can try at this point.  I'm grateful for any helpful suggestions.
Reply
Disney+ V. 0.3.0
Series "The Simpsons"

script.module.slyguy-0.7.4 = broken
script.module.slyguy-0.7.0 = OK
Reply
(2020-07-02, 19:20)Ronny3 Wrote: Disney+ V. 0.3.0
Series "The Simpsons"

script.module.slyguy-0.7.4 = broken
script.module.slyguy-0.7.0 = OK

How does one pin a version of a dependent library in Kodi?
Reply
I'll get a fix out shortly Smile

UPDATE:
Just pushed 0.7.5 of SlyGuy Common that fixes the issue
Reply
Where do I enable Widevine L1 secure device? I only see an option to install Widevine CDM.
Reply
@PizzaPino
L1 Secure Device option only shows on Android
Reply
(2020-07-02, 20:44)matthuisman Wrote: I'll get a fix out shortly Smile

UPDATE:
Just pushed 0.7.5 of SlyGuy Common that fixes the issue

It took me a while to figure out how to force the update.  I ended up downloading the zip and loading it directly from the FS.  It now appears to be working again.  I'd love to know just what broke in the first place. Smile

Thank you so much for the fix!
Reply
the disney+ playback requests get routed through a proxy in the common module.
This allows it to modify the playlist so correct audio streams are picked by Kodi etc.

This proxy was updated yesterday to try a "hack" to let streams with x-discontinuity play by just removing the x-discontinuity from the playlist.
But this seems to have broken Disney+, so probably it was removing something it shouldn't.

IA is getting updated shortly with support for x-discontinuity so just removed it and will wait for that.
Reply
(2020-07-02, 22:38)matthuisman Wrote: @PizzaPino
L1 Secure Device option only shows on Android

Thanks! Using the Android version now and it works fine.
Reply
Thanks for the quick fix 0.7.5 ... matthuisman. Smile

Windows 10 Pro = OK
Android 9 = OK
Reply
Hi matthuisman,

im working on a Video Addon based on Justwatch API that will act as a global frontend for all Services services that JustWatch supports. Therefore I would need an extension of your disney plus addon since I use this for playback. Justwatch only provides familyIds for playback urls. I've created an extension and i would like that you add it into your official build

My playbackUrl looks like this:
Quote: plugin://slyguy.disney.plus/?_=playWithFamilyId&family_id=12fVeZxD2fWJ

The code i've used for this is the following:
Quote:@plugin.route()
def playWithFamilyId(family_id=None, **kwargs):

if family_id:
data = api.video_bundle(family_id)

rows = []
rows.append(data['video'])
items = _process_rows(rows)
return items[0]
Reply
(2020-07-09, 13:36)Hioctane Wrote: Hi matthuisman,

im working on a Video Addon based on Justwatch API that will act as a global frontend for all Services services that JustWatch supports. Therefore I would need an extension of your disney plus addon since I use this for playback. Justwatch only provides familyIds for playback urls. I've created an extension and i would like that you add it into your official build
Would you mind talking about the plans a bit more in the corresponding request topic https://forum.kodi.tv/showthread.php?tid=352722 ?
Reply
@Hioctane
just pushed version 0.3.2

The play route now accepts "content_id" OR "family_id"
eg. plugin://slyguy.disney.plus/?_=play&family_id=12fVeZxD2fWJ
Reply
is the addon still working? i am getting no picture anymore and i found this in the kodi log

AddOnLog: InputStream Adaptive: Unknown encryption method: SAMPLE-AES-CTR with keyformat com.microsoft.playready
AddOnLog: InputStream Adaptive: Unknown encryption method: SAMPLE-AES-CTR with keyformat PRMNAGRA

Nvidia shield, kodi 18.7

/edit: i could fix it, its working now. the PR test build i have used, seems to missing some files. 
Reply
Can you link me to any info on that build? It maybe a sign that there is a bug in current code that will show up on next version
Reply
  •   
  • 1
  • 16
  • 17
  • 18
  • 19(current)
  • 20
  •   



Logout Mark Read Team Forum Stats Members Help
Disney+ Add-on13
This forum uses Lukasz Tkacz MyBB addons.