Linux MCE Remote, RPI4, Rasbian Buster, Kodi 18.6 - cant get it to work
#1
CEC is nice, but my experience has been that it only works about 40% of the time. (Samsung UHDTV), on my old pi3 build.  This required me to use the old MCE remote that I have been using on XBMC and then kodi for like 10+ years.  It's good to have an alternative remote anyways in case I plug into another system without CEC.

I have found the recent builds don't seem to support the MCE remote despite the wiki claiming it does.  The arrow keys are the only thing on the remote that work.  I can't even use the ok button or the back button.

I tried downloading the key mapper, and for General-> Navigation -> Select Item I programmed it to use the "OK" button on the MCE remote, it shows a number next to the mapping.  However it still does not work when I actually try to use it Sad

I have installed LIRC after some difficulty but that does not seem to work either.

Has MCE remote support been dropped?  If not how do I get it to work!?
Reply
#2
I have tried the simple method here and it does not work (Even after you get past the install issues).
https://kodi.wiki/view/HOW-TO:Set_up_an_...l_in_Linux

I have tried this tutorial and irw never registers the keys.
https://raspberrypi.stackexchange.com/qu...t-from-irw

I found this: https://www.raspberrypi.org/forums/viewt...6&t=121650
And I have the MCERemote.zip but It's for a different version of rasbian (Jessie I think is what my retropi was running, and the remote works over there just fine).
Reply
#3
Ok so I wasted WAY too long on this, but if anyone finds this post maybe this will be helpful.

reconfigure the /etc/lirc/lirc_options.conf 

change: 
driver = default
device = /dev/lirc0

then 

create /etc/lirc/lircd.conf 
add the lines

Code:
#Configuration for the Windows Media Center Transceivers/Remotes (all) remote:
include "/usr/share/lirc/remotes/mceusb/lircd.conf.mceusb"

sudo systemctl restart lircd
Reply



Logout Mark Read Team Forum Stats Members Help
MCE Remote, RPI4, Rasbian Buster, Kodi 18.6 - cant get it to work0
This forum uses Lukasz Tkacz MyBB addons.