Win How to: get SMB sharing to work on Windows 10 version 20H2
#1
1) Make sure SMBv1 support is disabled in Settings > Programs and Features  > Turn Windows Features on or off.
2) Pick a folder to share and right click it to go to the sharing properties tab.
3) Click the "Share" button to open the "Network Access" window and make sure "Everyone" is added to the list with "Read" permissions level along with the owner. Press "share" and then "Done" to apply these settings.
4) Click the "Advanced Sharing" button and make sure the "Share this folder" checkbox is checked. Press Ok to close the window.
5) In the "Password Protection" section, click the "Network and Sharing Center" link and go to your current profile (Mine is Private)

   a) Select "turn on network discovery" and check the "turn on automatic setup of network connected devices" checkbox.
   b) Make sure "turn on file and printer sharing" is selected.
  
Go to "All Networks" and make sure all 3 options are selected:

   a) "Turn off Public Folder sharing" (This option doesn't matter so leave it off)
   b) "Use 128 bit encryption to help protect file sharing connections (recommended)
   c) "Turn OFF password protected sharing"  <---- Note: updating to Windows 20H2 turned this back ON for me. Turn it OFF after you update.

This is all you have to do on your Windows 10 machine to share the folder you want.

On your Kodi client machine, simply connect to the Windows 10 machine by using the name-only address format rather than the IP address format.

It should look like "smb://MYSERVER/Path" where "MYSERVER" in the network name of your Windows 10 machine and "Path" is the folder you're sharing. It is the same as the "Network Path" in your shared folder's sharing properties window.

Image

For example, from this window, you get: smb://MON-NOTEBOOK/imon's E

Put that into the path field when connecting to your share from Kodi by clicking "None" in the "Add Video Source" window.

Image

That's it! You should now be able to connect to your Windows 10 20H2 machine without issue from Kodi 18.9.

EDIT: NUJAK posted a workaround for v19

Using any character like "a" in both the username and password field from the SMB setup page in v19 allows you to log in to your non-passworded SMB share described above!

https://forum.kodi.tv/showthread.php?tid...pid3019012
Reply
#2
(2020-04-15, 13:19)Kodroid Wrote: 1) Make sure SMBv1 support is disabled in Settings > Programs and Features  > Turn Windows Features on or off.
2) Pick a folder to share and right click it to go to the sharing properties tab.
3) Press the "Share" button and make sure "Everyone" and "Guest" are added. Press "share" to apply these settings.
4) Click the "Advanced Sharing" button and make sure the "Share this folder" checkbox is checked. Press Ok to close the window.
5) In the "Password Protection" section, click the "Network and Sharing Center" link and go to your current profile (Mine is Private)

   a) Select "turn on network discovery" and check the "turn on automatic setup of network connected devices" checkbox.
   b) Make sure "turn on file and printer sharing" is selected.
  
Go to "All Networks" and make sure all 3 options are selected:

   a) "Turn on sharing so anyone with network access can read and write files in the public folders"
   b) "Use 128 bit encryption to help protect file sharing connections (recommended)
   c) "Turn OFF password protected sharing"

This is all you have to do on your Windows 10 machine to share the folder you want.

On your Kodi client machine, simply connect to the Windows 10 machine by using the name-only address format rather than the IP address format.

It should look like "smb://MYSERVER/Path" where "MYSERVER" in the network name of your Windows 10 machine and "Path" is the folder you're sharing. It is the same as the "Network Path" in your shared folder's sharing properties window.

That's it! You should now be able to connect to your Window 10 1909 machine without issue from Kodi 18.6.

This guide will be updated if needed.
On your "client machine" can you elaborate on the steps?

"On your Kodi client machine, simply connect to the Windows 10 machine by using the name-only address format rather than the IP address format.

It should look like "smb://MYSERVER/Path" where "MYSERVER" in the network name of your Windows 10 machine and "Path" is the folder you're sharing. It is the same as the "Network Path" in your shared folder's sharing properties window."

Change what? Where in settings?

I can always see my client machine from my Windows 10 machine but I get an access error when trying to look at (with explorer) my Windows machine from the client. Both are Windows 10 Pro with the same settings as yours above.

Thanks
Reply
#3
(2020-04-15, 23:33)melons2 Wrote: Change what? Where in settings?

I can always see my client machine from my Windows 10 machine but I get an access error when trying to look at (with explorer) my Windows machine from the client. Both are Windows 10 Pro with the same settings as yours above.

Thanks 
Click "none" when adding a new video source and enter the address of your shared folder as smb://PCNAME/FolderName

Image

You can find the network path in your shared folder's properties > sharing window.

Image

From this you get: smb://MON-NOTEBOOK/imon's E

Just put that into the path after you click "None" in Kodi and click Ok and you will now be able to browse your share without needing a password.
Reply
#4
Thank you............
Do you also know how to remedy the windows explorer problem?
So that it is easier to move things between my 2 KODI setups.
Reply
#5
(2020-04-17, 01:17)melons2 Wrote: Do you also know how to remedy the windows explorer problem?
I don't know what that is.
Reply
#6
Kodroid I have a working setup sharing from a 1903 machine. Are you saing that 1909 would make that non-working?
For troubleshooting and bug reporting please make sure you read this first.
Reply
#7
(2020-04-18, 01:31)ashlar Wrote: Kodroid I have a working setup sharing from a 1903 machine. Are you saing that 1909 would make that non-working?
No. I am just saying that is what works for me on the latest version of Windows 10, which is 1909.
Reply
#8
I updated to Windows 10 version 2004 yesterday and I can say these settings still work great with Kodi 18.7
Reply
#9
Isn't SMBv1 old and deprecated at this point due to security issues?

Do we have any way of supporting newer SMB versions?
Reply
#10
(2020-05-31, 19:19)Admiral_Asshat Wrote: Isn't SMBv1 old and deprecated at this point due to security issues?

Do we have any way of supporting newer SMB versions?
I explicitly told users to disable SMBv1 in the first post. This guide uses SMBv2 and v3.
Reply
#11
(2020-05-31, 20:58)Kodroid Wrote:
(2020-05-31, 19:19)Admiral_Asshat Wrote: Isn't SMBv1 old and deprecated at this point due to security issues?

Do we have any way of supporting newer SMB versions?
I explicitly told users to disable SMBv1 in the first post. This guide uses SMBv2 and v3.

So sorry! I misread disable as enable!
Reply
#12
(2020-04-15, 13:19)Kodroid Wrote: have
Thank you for the posting. I have followed your instructions explicitly but cannot get it to work. I have tried it with two different Windowss 10 2004 computers and two different Android devices - Huawei MediaPad M5 and Android TV T95.  I can see the files using Andoid File Manager but Kodi will not connect.
Any suggestions please?
Reply
#13
Thank you for your help.

Using your instructions I have managed to connect Kodi with the C: drive folders on my PC. However I cannot connect to the D:Drive. It has the same sharing attributes as the C: drive. Any ideas please?
Reply
#14
(2020-08-25, 16:11)fengureek Wrote:
(2020-04-15, 13:19)Kodroid Wrote: have
Thank you for the posting. I have followed your instructions explicitly but cannot get it to work. I have tried it with two different Windowss 10 2004 computers and two different Android devices - Huawei MediaPad M5 and Android TV T95.  I can see the files using Andoid File Manager but Kodi will not connect.
Any suggestions please?
Hi, set up the Windows 10 PC again step by step and make sure this part is done perfectly. From the network path highlighted below, your entered path in Kodi should be:

smb://MON-NOTEBOOK/imon's E

Image
Reply
#15
(2020-08-26, 03:31)Kodroid Wrote:
(2020-08-25, 16:11)fengureek Wrote:
(2020-04-15, 13:19)Kodroid Wrote: have
Thank you for the posting. I have followed your instructions explicitly but cannot get it to work. I have tried it with two different Windowss 10 2004 computers and two different Android devices - Huawei MediaPad M5 and Android TV T95.  I can see the files using Andoid File Manager but Kodi will not connect.
Any suggestions please?
Hi, set up the Windows 10 PC again step by step and make sure this part is done perfectly. From the network path highlighted below, your entered path in Kodi should be:m

smb://MON-NOTEBOOK/imon's E

Image
Thank you. I have found what the problem was. It was all around the "My Music" folder I was sharing between the PCs. I determined that other folders could be accessed but not this one - even though it had the same sharing attributes. I simply moved all my music to a different folder and hey presto! Thanks again for your support.
Reply



Logout Mark Read Team Forum Stats Members Help
How to: get SMB sharing to work on Windows 10 version 20H21
This forum uses Lukasz Tkacz MyBB addons.