Pi4b 4k
#1
Having issues with 4k
I made a thread here at raspberry pi forums

https://www.raspberrypi.org/forums/viewt...8#p1649698
​​​​​
There's a link how to configure your pi, but it seems I need a fix from within kodi? Either that or kodi cannot play 4k?
Also i still don't even know how to configure those parameters from Linux / android etc. Possibly using juicessh
Reply
#2
Giving a link with hxxps:..?? Such links do not work here. Let me edit that for ya.

"RPi 4B, 4K, flickering". That's not a whole lot to work with.
Could be your HDMI cable, could be your OS.

What OS are you running on the RPi4 anyway?
LibreELEC, Raspbian, Ubuntu, something else...?

We prefer to have proper information on a possible problem, there is no crystal ball here that can help us.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#3
Thread moved to the pi support section
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#4
Libreelec 9.2
I can't say any better than flickering. 
It's supposed to be 4k 60hz on only one hdmi port according to the raspberry pi forum. And you have to enable it. But they directed me here for how to do that in kodi
Reply
#5
(2020-04-26, 23:53)redkoatz Wrote: Libreelec 9.2
I can't say any better than flickering. 
It's supposed to be 4k 60hz on only one hdmi port according to the raspberry pi forum. And you have to enable it. But they directed me here for how to do that in kodi


There's nothing Kodi specific about enabling 4K 60Hz output on a Pi - you edit the config.txt file in the BOOT partition just as you would on other Pi OSs.

You can either remove the uSD card and edit on a suitable text editor on a separate PC or Mac (I think Notepad++ rather than Notepad is recommended for PC editing because of a CR/LF issue?) - or SSH into your Pi running LibreElec following the guide here : https://wiki.libreelec.tv/config.txt

You need to add the line hdmi_enable_4kp60=1 to the config.txt file.

However there are a couple of reasons that this may also cause you some issues.

1. The  Pi4B doesn't output 2160p50 or 2160p60 (aka 4K 60Hz) in a 4:2:0 format.  For some UHD TVs, particularly earlier models (or cheaper models) this is the only format that they support for 2160p50/60Hz inputs - so they will stick to 30Hz.  Similarly some TVs have different supported formats on different HDMI inputs.  On my Sony HDMI 1 and 4 are low-bandwidth inputs and only support 2160p50/60 in 4:2:0, but HDMI 2 and 3 can have 4:2:2/4:4:4/RGB 2160p50/60 support enabled (which the Pi 4B does support)

2. The 2160p50/60Hz modes that the Pi 4B supports are 'high bandwidth' HDMI 2.0 modes - which means the HDMI cables have to carry data at a higher pixel rate - which some cheaper, older cables don't support reliably.  In this case you may see frequent drop outs to black, your TV report 'unsupported format', flashes to green, lots of green or white sparkly dots etc.

Also - you should always use the Micro HDMI connector closest to the USB Type-C power port on the Pi 4B.
Reply
#6
(2020-04-27, 15:58)noggin Wrote:
(2020-04-26, 23:53)redkoatz Wrote: Libreelec 9.2
I can't say any better than flickering. 
It's supposed to be 4k 60hz on only one hdmi port according to the raspberry pi forum. And you have to enable it. But they directed me here for how to do that in kodi


There's nothing Kodi specific about enabling 4K 60Hz output on a Pi - you edit the config.txt file in the BOOT partition just as you would on other Pi OSs.

You can either remove the uSD card and edit on a suitable text editor on a separate PC or Mac (I think Notepad++ rather than Notepad is recommended for PC editing because of a CR/LF issue?) - or SSH into your Pi running LibreElec following the guide here : https://wiki.libreelec.tv/config.txt

You need to add the line hdmi_enable_4kp60=1 to the config.txt file.

However there are a couple of reasons that this may also cause you some issues.

1. The  Pi4B doesn't output 2160p50 or 2160p60 (aka 4K 60Hz) in a 4:2:0 format.  For some UHD TVs, particularly earlier models (or cheaper models) this is the only format that they support for 2160p50/60Hz inputs - so they will stick to 30Hz.  Similarly some TVs have different supported formats on different HDMI inputs.  On my Sony HDMI 1 and 4 are low-bandwidth inputs and only support 2160p50/60 in 4:2:0, but HDMI 2 and 3 can have 4:2:2/4:4:4/RGB 2160p50/60 support enabled (which the Pi 4B does support)

2. The 2160p50/60Hz modes that the Pi 4B supports are 'high bandwidth' HDMI 2.0 modes - which means the HDMI cables have to carry data at a higher pixel rate - which some cheaper, older cables don't support reliably.  In this case you may see frequent drop outs to black, your TV report 'unsupported format', flashes to green, lots of green or white sparkly dots etc.

Also - you should always use the Micro HDMI connector closest to the USB Type-C power port on the Pi 4B.

No idea what my TV supports and which ports but do I put #before hdmi_enable_4kp60=1 and where do I put this line? 
Is there any way of verifying video playback info? 
Reply
#7
(2020-04-27, 22:04)redkoatz Wrote: do I put #before

No.
(2020-04-27, 22:04)redkoatz Wrote: where do I put this line? 

It doesn't matter.  Just put it at the bottom.
Reply
#8
(2020-04-27, 22:04)redkoatz Wrote: No idea what my TV supports and which ports but do I put #before hdmi_enable_4kp60=1 and where do I put this line? 
No - you shouldn't add the # sign before hdmi_enable_4kp60=1

For info - the # sign means 'ignore the rest of this line' in config.txt - it's known as a comment symbol - so you often see a lot of #-ed lines there as comments or examples.

Most people just add their own options like hdmi_enable_4kp60=1 to the end of the config.txt file, but you may see a version of it with the # before it already there in the file. If so - just delete the # and save the file.
Quote:Is there any way of verifying video playback info? 

What kind of info? Pressing O during playback will tell you what the properties of the file being played are, and how the Pi is playing it. If you want to find out what the current video mode is - then I think if you SSH into your box and enter
vgencmd hdmi_timings
at the command line it will return the current HDMI mode - with more details to be found here https://www.raspberrypi.org/documentatio...cgencmd.md with more details of the information returned here : https://www.raspberrypi.org/documentatio...t/video.md
Reply
#9
Hi, 

I have quite similar issue with my PI4b and Kodi 18.6 but not with 4K video but with Netflix video.
I can watch TV or Movie from NFS shared without any issue, but when I watch Netflix videos, it's flickering (video + sound, my tv shows No signal from hdmi), I the Raspbian ways (https://www.raspberrypi.org/documentatio...t/video.md) my conf seems to be ok. I tried to play with some kodi config from Expert view but without success.

Any ideas ?
Reply
#10
(2020-04-28, 23:43)noggin Wrote:
(2020-04-27, 22:04)redkoatz Wrote: No idea what my TV supports and which ports but do I put #before hdmi_enable_4kp60=1 and where do I put this line? 
No - you shouldn't add the # sign before hdmi_enable_4kp60=1

For info - the # sign means 'ignore the rest of this line' in config.txt - it's known as a comment symbol - so you often see a lot of #-ed lines there as comments or examples.

Most people just add their own options like hdmi_enable_4kp60=1 to the end of the config.txt file, but you may see a version of it with the # before it already there in the file. If so - just delete the # and save the file.
Quote:Is there any way of verifying video playback info? 

What kind of info? Pressing O during playback will tell you what the properties of the file being played are, and how the Pi is playing it. If you want to find out what the current video mode is - then I think if you SSH into your box and enter
vgencmd hdmi_timings
at the command line it will return the current HDMI mode - with more details to be found here https://www.raspberrypi.org/documentatio...cgencmd.md with more details of the information returned here : https://www.raspberrypi.org/documentatio...t/video.md 

Thanks great post
Reply



Logout Mark Read Team Forum Stats Members Help
Pi4b 4k0
This forum uses Lukasz Tkacz MyBB addons.