"Update Library" issues
#1
I'm running version 1.5.0 x64 and after adding media to one of the source folders, I click on "Update Library" and it takes a long time to add the new media to the database/list. Yesterday morning at 6:12 AM I clicked on "Update Library" at around 1:30 PM (roughly) it had only added about 8 titles out of a handful of new media files that was added to the source folder. 

I had a previous version installed (version 1.4.7.2x86) and noted there was an updated version notification in the top right of the screen. I clicked that and BETA 1.4.90-alpha  from 2018-12-09 as that looked to be the latest from the list. After installing the newer version, I clicked on "Update Library" (after adding my sources in the settings) and noted it was taking an extremely long time. Thinking it was because I installed the update on top of the older version, I uninstalled Ember and re-downloaded the program (this time downloading the Ember Media Manager 1.5.0 x64 - Build from 2020-02-29. After adding my source locations, I clicked on "Update Library" again and had the same results of it being extremely slow. No settings was changed (unless they were changed automatically when installing the newer version) except for checking the "Boxee" box to activate (as that's what I'm using for streaming) and no file path, etc. was changed (the file paths were added exactly the same way it was on the older version) and no hardware was changed on the NAS that I have (& had) the media sources on. 

I have 2 computers that have Ember on them ... both are running Windows 7 64 bit and both on a wired network connection

The desktop (i7 2.00 GHz with 6 GB of RAM) had version 1.4.7.2x86, but was update as explained above

A laptop (i7 1.73 GHz with 6 GB of RAM) with version 1.4.7.2x86

Clicking on "Update Library" on the version on my laptop updated the library from 82 items to 1,981 (with 45 of the total being new and not scraped at all) within 1 1/2 hours... within that same 1 1/2 hours the desktop (newer) version only did 1 item.

What could be causing my desktop (upgraded) version of Ember to take so long to update the library? Scraping, etc. works fine (as far as I can tell), it's just the updating the library.
Reply
#2
(2020-05-01, 12:13)jthorpe Wrote: I'm running version 1.5.0 x64 and after adding media to one of the source folders, I click on "Update Library" and it takes a long time to add the new media to the database/list. Yesterday morning at 6:12 AM I clicked on "Update Library" at around 1:30 PM (roughly) it had only added about 8 titles out of a handful of new media files that was added to the source folder. 

I had a previous version installed (version 1.4.7.2x86) and noted there was an updated version notification in the top right of the screen. I clicked that and BETA 1.4.90-alpha  from 2018-12-09 as that looked to be the latest from the list. After installing the newer version, I clicked on "Update Library" (after adding my sources in the settings) and noted it was taking an extremely long time. Thinking it was because I installed the update on top of the older version, I uninstalled Ember and re-downloaded the program (this time downloading the Ember Media Manager 1.5.0 x64 - Build from 2020-02-29. After adding my source locations, I clicked on "Update Library" again and had the same results of it being extremely slow. No settings was changed (unless they were changed automatically when installing the newer version) except for checking the "Boxee" box to activate (as that's what I'm using for streaming) and no file path, etc. was changed (the file paths were added exactly the same way it was on the older version) and no hardware was changed on the NAS that I have (& had) the media sources on. 

I have 2 computers that have Ember on them ... both are running Windows 7 64 bit and both on a wired network connection

The desktop (i7 2.00 GHz with 6 GB of RAM) had version 1.4.7.2x86, but was update as explained above

A laptop (i7 1.73 GHz with 6 GB of RAM) with version 1.4.7.2x86

Clicking on "Update Library" on the version on my laptop updated the library from 82 items to 1,981 (with 45 of the total being new and not scraped at all) within 1 1/2 hours... within that same 1 1/2 hours the desktop (newer) version only did 1 item.

What could be causing my desktop (upgraded) version of Ember to take so long to update the library? Scraping, etc. works fine (as far as I can tell), it's just the updating the library.
Reply
#3
I have the same problem with update library
Reply
#4
I need the logs to check that.
Reply
#5
(2020-05-07, 11:43)DanCooper Wrote: I need the logs to check that.

How do you create a log or pull up the log?? I'm still a newbie on some things.
Reply
#6
.\Ember Media Manager\Logs\*.csv
Please upload it to https://pastebin.com/ (don't paste full log files in the forum).
Reply
#7
(2020-05-08, 17:01)DanCooper Wrote: .\Ember Media Manager\Logs\*.csv
Please upload it to https://pastebin.com/ (don't paste full log files in the forum).

I tried uploading it to pastebin, but it said it was too large. I have the ones in my C:\Ember Media Manager\Log folder to my Google Drive and created a shareable link (listed below). The 2020-05-08 one is the "Update Library" one I started today at 4:48 PM (it is now 5:06 PM and it has just started to add the new files).

https://drive.google.com/open?id=1BOr_sc...R4-QfljmDi
Reply
#8
(2020-05-08, 17:01)DanCooper Wrote: .\Ember Media Manager\Logs\*.csv
Please upload it to https://pastebin.com/ (don't paste full log files in the forum).

Were you able to view the logs that I uploaded to Google Drive??
Reply
#9
(2020-05-08, 17:01)DanCooper Wrote: .\Ember Media Manager\Logs\*.csv
Please upload it to https://pastebin.com/ (don't paste full log files in the forum).

I just uploaded the logs from the version that is on my laptop/notebook running Ember Media BETA version 1.4.7.2x86 to the same link as above in a folder named: Ember Media BETA version 1.4.7.2x86
Reply
#10
Please try to disable the module "Notification" in "Settings => Modules". Looks like that needs a lot of time to be running.
Reply
#11
(2020-05-10, 17:04)DanCooper Wrote: Please try to disable the module "Notification" in "Settings => Modules". Looks like that needs a lot of time to be running.

What is the purpose of the "Notification" module? I have added 4 new (DVD rips) to the library folder(s):

- Homefront (2013)
- IT (2017)
- Zombieland: Double Tap (2019)
(these were added to the DVD Movies source folder
and
Degrassi: The Next Generation S05D02
(this was added to the DVD TV Shows source folder).

I started a new "Update Library" on 05-11-2020 at 12:35 PM (after turning off the Notifications Module as suggested). Will update the log file on Google Drive for viewing and updating with the time of completion.

One thing I do note when using Ember on my notebook, when I click on "Update Library" the list goes blank and the bar at the bottom right has a green color that goes from left to right, then back left to right. The (updated) version on my desktop does not do this (don't know if this is from a version change or a setting).

Here's a short video of the start portion of "Updating Library" - both videos are between 1 to 1 1/2 mins in length, but shows the differences between the two when "Update Library" is clicked on.

For Notebook: https://youtu.be/sU5vRprOLXM

For Desktop: https://youtu.be/ytmA2S0S7kw
Reply
#12
(2020-05-10, 17:04)DanCooper Wrote: Please try to disable the module "Notification" in "Settings => Modules". Looks like that needs a lot of time to be running.

Disabling the Notification module seems to have no effect or worse makes it slower. I started an "Update Library" at 12:35 PM to add just 4 movies (3 movies & 1 TV series on DVD), it's now 9:35 PM and it's still stuck on "Scanning Source: DVD Movies (Z:\Active Files\DVD Movies" ... it hasn't even added 1 yet. 

I ran an "Update Library" on the version that's on my Notebook, I started that at 12:52 PM and it completed at 3:27 PM (or before) for the same 4 items.
Reply
#13
(2020-05-10, 17:04)DanCooper Wrote: Please try to disable the module "Notification" in "Settings => Modules". Looks like that needs a lot of time to be running.

There was no changes (other than maybe making it slower, not sure). I turned off the "Notification" module and ran a "Update Library" on my desktop. I started that on 05-11-2020 at around 12:35 PM, it finally finished adding the 4 items some time in the early morning hours on 05-13-2020.

Here is the link to the updated logs: https://drive.google.com/open?id=11ZZtcT...BIQbzc5RY1
Reply
#14
(2020-05-10, 17:04)DanCooper Wrote: Please try to disable the module "Notification" in "Settings => Modules". Looks like that needs a lot of time to be running.

I just did a screenshot of all the settings screens and uploaded them to the Google Drive (https://drive.google.com/open?id=1BCvao_...g3WbJjbJX5) not sure if this would be of any help or not.
Reply
#15
I'll check your files tonight. I still don't know why the scanning is so slow on your PC (I can scan a source with 5'000 movies and another with over 13'000 episodes in 5-10min).
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
"Update Library" issues00
This forum uses Lukasz Tkacz MyBB addons.