C64 / VICE Keyboard Problems
#1
Hi,

Running Leia on LibreElec and RPi 4, I've installed the SNES and C64 emulators. SNES is working perfectly with my SNES controllers, but I can't play games on C64 using VICE due to keyboard map issues.

Most games I've tried via IAGL and RCB load to the crack screen, but require pressing the Run/Stop key to start the game. This is variously documented as the Escape or Up or Caps-Lock keys, none of which work for me (Escape being used by Kodi, and Up being Up). Nowhere in the Controls or Advanced Settings can I find how to remap it, and I have tried *every* key combination to try trigger it and multiple different keyboards.

I've also tried to use the VICE virtual keyboard, documented as being F11, and showing in Advanced Settings as mapped to F11, but it never appears. I've tried remapping in Advanced Settings to an unused key (right shift) but it still doesn't appear.

Has anyone succeeded with getting either the physical keys remapped, or getting the virtual keyboard to display?

For bonus points: has anyone got their SNES controllers working in VICE?

Thanks!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
C64 / VICE Keyboard Problems00
This forum uses Lukasz Tkacz MyBB addons.