Retroplayer Amiga P-UAE Model Problems
#1
Hi,

I'm running Leia on LibreElec and RPi 4, and SNES Retroplayer works great, but I having issues now with Amiga P-UAE. I have the various Kickstart ROMS installed and the default Amiga 500 emulation runs fine. Setting the Model in Advanced Settings to Amiga 1200 and trying to run an AGA game however only runs the A500 1.3 rom, causing the newer games to refuse to load. I've checked the names and md5 of the kickstart files and they are correct, it just appears that libretro is not getting the right model set. I've tried various combinations of models, roms and adf games files named according to the docs, but P-UAE persists in only running A500.

Any suggestions on fixes, or debugging steps / logging, etc to figure this out gratefully received!

Cheers!
Reply
#2
Some progress, debug logging shows the following error:

ERROR: AddOnLog: Commodore - Amiga (P-UAE): Setting puae_model: invalid value "A1200" (values are: Model; A500|A500|A500OG|A500PLUS|A600|A1200|A1200OG)

Note that I set the Model to A1200 using the Kodi Advanced Settings, so the value set is as set by Kodi, and appears to be the correct value. I've also tried manually editing the value in the settings.xml and same result. Not sure if this error is coming from Kodi itself, libretro, or P-UAE?

Cheers!
Reply
#3
Further update, LibreElec just updated their addons to the latest versions, the problem persists albeit with more options now available:

ERROR: AddOnLog: Commodore - Amiga (P-UAE): Setting puae_model: invalid value "A1200" (values are: Model; auto|auto|A500OG|A500|A500PLUS|A600|A1200OG|A1200|A4030|A4040|CD32|CD32FR)

Still perplexing...

John.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Retroplayer Amiga P-UAE Model Problems00
This forum uses Lukasz Tkacz MyBB addons.