Solved Fallback on internal subtitle if external subtitle is missing?
#1
Hi all,

Tried the search but couldn't find anything related to my question.

Case: I have video files with internal subtitles (mostly MKV) and I have video files with external subtitles (all SRT). I have setup KODI to show the external files automatically. However... if I play a video file without external subtitles but which has internal subtitles, I have to grab the remote and activate the internal subtitle.

Question: Is it possible to have KODI configured in such a way that if I play a video file without external subtitles it automatically falls back to the internal subs?

Thanks!

Greetz,

[email protected]_
oDroid C2 - 8GB eMMC -Running LibreELEC (latest stable)
Synology DS215+ - 8+6 TB | Synology DS211 - 4+4 TB - No RAID | Homebrew server OpenMediaVault - 10 TB - LVM | Ubuntu Server 18.04.01 -10 TB - RAID5
Philips 50PFK5300 | Sony HT-XT100 Soundplate
Scanning my media with MediaElch
Reply
#2
(2020-05-04, 18:28)[email protected]_ Wrote: Is it possible to have KODI configured in such a way that if I play a video file without external subtitles it automatically falls back to the internal subs?
You could mark the internal subtitle stream as a forced track, then Kodi will automatically play it.

FYI- How to name external subtitles... https://forum.kodi.tv/showthread.php?tid...pid2861861
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
Excellent idea that put me on the right track. I found a somewhat different solution that works for me.

Almost all my videos have English language as default and the subs (internal or external) are all in English as well. So I modified below settings:

Player -> Language -> Preferred audio language: English
Player -> Language -> Preferred subtitle language: English

Now KODI displays the external subs as default and when they are missing falls back to the internal subs.

Note that I didn't have to change the tracks inside the MKV to achieve this.

So happy camper! Smile

Thanks for your support!

Greetz,

[email protected]_
oDroid C2 - 8GB eMMC -Running LibreELEC (latest stable)
Synology DS215+ - 8+6 TB | Synology DS211 - 4+4 TB - No RAID | Homebrew server OpenMediaVault - 10 TB - LVM | Ubuntu Server 18.04.01 -10 TB - RAID5
Philips 50PFK5300 | Sony HT-XT100 Soundplate
Scanning my media with MediaElch
Reply
#4
Thread marked solved.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
Fallback on internal subtitle if external subtitle is missing?0
This forum uses Lukasz Tkacz MyBB addons.