Bug Kodi hangs on network operations when allowing remote control from other systems
#1
System info: running Kodi 18.6 on a 2010 Mac Mini under Mac OS High Sierra (OS X 10.13.6).

The issue: When I enable "Allow remote control from applications on other systems", Kodi hangs for minutes at a time on most network operations, e.g. when just trying to fetch the weather info. The network operations eventually complete, but it takes minutes to get the result. Everything works fine if I turn remote control off.

It doesn't matter whether a remote control client is actually connected, just having the option enabled creates the issue. 

Not sure which network operations have the problem, but I tried with Yahoo Weather and Disney+ add-ons, which all stop working (long hangs) when remote control is enabled. Maybe python related (I think both add-ons run in Python)?

The easiest way to reproduce is to just enable the remote control option in the settings and then try to setup a new location in Yahoo Weather. After entering the city name, it normally pops up a selection box with the list of cities to choose from. If remote control is on, the selection box will pop up several minutes later. Also, if one exits Kodi while it still waits for the response from the network, Kodi just hangs until the response is received before exiting.

Debug log of a session doing exactly that (start Kodi, add weather location, wait for popup, and exit): ululocusid.kodi (paste) 

I didn't see anything obvious in the log, but one can see the minutes of delay between initiating a network fetch and the response, both when fetching locations (22:09:36-22:14:23) and then when trying to fetch the weather after setting the location (22:14:51), which subsequently leads to a hang on exiting waiting for the result (22:14:59-22:19:52). 

Anybody seen this before or any ideas what's happening?!

P.S.: I have already tried to reinstall Kodi, same problem. The debug log above was collected on a fresh and clean Kodi install with only the Yahoo Weather add-on installed.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi hangs on network operations when allowing remote control from other systems00
This forum uses Lukasz Tkacz MyBB addons.