v18 audio issues only on TV playback
#1
I'm running Kodi 18.6 on Raspbian Buster on a RPi4. My audio is via the 3.5mm jack connected to an AV receiver.

Audio is great on VLC on local m4a files.
Audio is great on Kodi on local m4a and m4v files
Audio is great on Chromium from the Sirius XM site.

Only problem is when playing a Recorded TV or Live TV from a V31 mythtv backend.  Those recordings are fine when played on any other frontend including Kodi on Nvidia Shield TV. 

This seems odd to me. Usually audio has problems on more than one app. I'd love to avoid the 3.5mm jack, but the monitor I'm using is DVI only.

Any ideas, I'm hoping it's a setting issue.

Jim A
Reply
#2
Is the 3.5mm jack being used for an 'analog' or 'digital' audio output ?

There 'is' an issue with Odroid C2 units, that if the 'digital' device is selected, a similar issue occurs, but if the 'analog' device is used, the issue disappears...
Reply
#3
(2020-05-12, 21:01)Yubby Wrote: Is the 3.5mm jack being used for an 'analog' or 'digital' audio output ?

There 'is' an issue with Odroid C2 units, that if the 'digital' device is selected, a similar issue occurs, but if the 'analog' device is used, the issue disappears...
I thought I'd replied yesterday, but don't see it this morning.

I wouldn't know how to use it as a digital output.  It's just a mini jack to RCA cable from the RPi4 3.5mm jack to the AVR receiver. Kodi settings -> System -> audio is PI:Analogue. Also tried ALSA:default.

I tried 2 more test:

- Kodi from the console only. All sound functions work, except kodi-pvr-mythtv audio is popping and cracking.
- Mythtv v31 from console only. sound and picture is great.

Very odd how just the Audio part of Kodi has the problem on just kodi-pvr-mythtv content. I don't see any settings
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
audio issues only on TV playback00
This forum uses Lukasz Tkacz MyBB addons.