New Albums Have "MISSING" Artist
#1
I have been using Kodi for several years now.  I have Kodi 18.6 on a dedicated Ubuntu 18.04 LTS 64 bit pc.  I tag all of my music with MusicBrainz Picard.  Several years, no problem.  But now, all of a sudden, any new music I add does not have an artist.  In the artist view, there is an artist named "Missing" (no thumb or fanart) and all of the new albums I scan end up there.

If I right-click the album and select "information,"  the title of the album appears, along with the cover art, correct release year, correct themes and moods, but if I click on "Artist Information" it just says missing.

If navigate into the album, right-click a song and select "Information," the UI shows correctly shows the artist fanart and clearlogo, the artist name appears underneath the song title at the top of the page, and the information section of the UI scrolls the biography for that artits.  But if I click on "Artist Informaion", I get a blank screen that says "Missing."

When I scan and save these albums using Picard, they appear to have all of the correct tags.

Anyone else having this problem?
Reply
#2
See 329378 (thread)
Reply
#3
Quote:  But now, all of a sudden, any new music I add does not have an artist.
Can you expand on that - have you updated Kodi from an older version since you last added new music? Have you added a new music source? Is it that the album(s) you recently added have multiple album artists (and there is a tagging problem as in the thread @jjd_uk pointed you towards)? It does sound like the latter, but if not then please give more details.
Reply
#4
(2020-05-15, 12:10)DaveBlake Wrote:
Quote:  But now, all of a sudden, any new music I add does not have an artist.
Can you expand on that - have you updated Kodi from an older version since you last added new music? Have you added a new music source? Is it that the album(s) you recently added have multiple album artists (and there is a tagging problem as in the thread @jjd_uk pointed you towards)? It does sound like the latter, but if not then please give more details. 
As it turns out, this is the first music that I added music since updating to Kodi 18.6.  I have Kodi set update automatically.  So it probably updated to 18.6 in March. I have not added a new music source.  The problem exists regardless of whether an album has multiple album artists.  I first noticed this problem when I tried to add Gigaton by Pearl Jam (no multiple album artists).

I have over 300 albums in my music library, many of which have multiple artists, and have never had a problem before.  So the tagging issue pointed out by @jjd_uk is not the problem (I reviewed that post prior to creating a new thread).

In a further attempt to diagnose the problem, I re-scanned and re-saved a Led Zeppelin album with Picard that I had previously tagged and successfully added over a year ago.  Prior to saving, I carefully looked at each tag value.  There were no differences.  For each tag, the original value was the same as the new value.  But after I hit save in Picard and then updated my music library the Led Zeppelin album was now in in the "Missing" section with no artist.
Reply
#5
Well this is very odd. The only thing remotely similar happened with a user on a RPi that had a faulty SD card, again that does not apply to you on PC.  Can you paste a debug log created while scanning an item into the library. Also I guess a copy of your MyMysic72.db could help (assuming you are using SQLite and don't have MySQL in client/server setup).
Reply
#6
(2020-05-17, 08:10)DaveBlake Wrote: Well this is very odd. The only thing remotely similar happened with a user on a RPi that had a faulty SD card, again that does not apply to you on PC.  Can you paste a debug log created while scanning an item into the library. Also I guess a copy of your MyMysic72.db could help (assuming you are using SQLite and don't have MySQL in client/server setup).

Here is the debug log.  This log was created while scanning the album Gordon by Barenaked Ladies.  The source is MUSIC_A_J.

The MyMymusic72.db file can be downloaded here: https://filebin.ca/5MrPqseUjeRI
Reply
#7
(2020-05-17, 21:02)SoCalMichael Wrote:
(2020-05-17, 08:10)DaveBlake Wrote: Well this is very odd. The only thing remotely similar happened with a user on a RPi that had a faulty SD card, again that does not apply to you on PC.  Can you paste a debug log created while scanning an item into the library. Also I guess a copy of your MyMysic72.db could help (assuming you are using SQLite and don't have MySQL in client/server setup).

Here is the debug log.  This log was created while scanning the album Gordon by Barenaked Ladies.  The source is MUSIC_A_J.

The MyMymusic72.db file can be downloaded here: https://filebin.ca/5MrPqseUjeRI 

What I notice is that your songs are linked to idArtist 512 (Bare Naked Ladies) has no sortname but album is linked to idArtist 1 (missing) and in the album table it has null (album) artist name but does have artist sortname?  Not sure what's up with that.  Same thing for your other bad albums.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix
Leia see: 304472
Reply
#8
(2020-05-17, 23:54)scott967 Wrote:
(2020-05-17, 21:02)SoCalMichael Wrote:
(2020-05-17, 08:10)DaveBlake Wrote: Well this is very odd. The only thing remotely similar happened with a user on a RPi that had a faulty SD card, again that does not apply to you on PC.  Can you paste a debug log created while scanning an item into the library. Also I guess a copy of your MyMysic72.db could help (assuming you are using SQLite and don't have MySQL in client/server setup).

Here is the debug log.  This log was created while scanning the album Gordon by Barenaked Ladies.  The source is MUSIC_A_J.

The MyMymusic72.db file can be downloaded here: https://filebin.ca/5MrPqseUjeRI 

What I notice is that your songs are linked to idArtist 512 (Bare Naked Ladies) has no sortname but album is linked to idArtist 1 (missing) and in the album table it has null (album) artist name but does have artist sortname?  Not sure what's up with that.  Same thing for your other bad albums.

scott s.
Also, at lines 4453 and 4455 of the debug log, there are "unable to parse web site" errors.  But the web sites listed in the previous lines (which I presume is the site kodi is unable to parse) are:

https://musicbrainz.org/ws/2/release/38e...ls+ratings

But this is a valid url containing an xml file with the metadata for the album.  Since this is the correct info and a valid url, why is kodi unable to parse it?
Reply
#9
Yes I suspect this problem is somehow album scraper related, but so far have been unable to reproduce it. What setting are you using @SoCalMichael for System>Settings>Media>Music "Prefer online information" - enabled or disabled?

EDIT:
Ah ha, reproduced. With "Prefer online information" enabled and v3.1.3 of the Universal Album Scraper, on scraping albums the album artist is getting wiped and therefore replaced with "[Missing]".

Immediate workaround for users is to disable  "Prefer online information".

That would be my recommendation anyway. Meanwhile I will persue why this is happening, the scraper has been recently updated which could be contributing but core code should be more robust too.

To repair the broken albums that are currently under [missing]: change that setting and then navigate in file view to the folder of for each of those albums in turn  choose "Scan to library" from the context menu and say "yes" to scan even if tags have not changed. You only need to force rescan the broken albums not your whole library.
Reply
#10
Brilliant!!  That did the trick.

Many thanks!  Smile
Reply
#11
(2020-05-18, 17:12)SoCalMichael Wrote: Brilliant!!  That did the trick.

Many thanks!  Smile
Dave has a PR up with a pretty straight-forward change that should prevent a scraper from wiping the name in the future.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix
Leia see: 304472
Reply
#12
Yes I have fix in v19 nightly and backported to 18.7 that makes merging scaped album data more robust, so if a scraper does fail to return artist Kodi won't wipe it. The scraper is being fixed too (Musicbrainz xml results had changed making the pasring miss returning artist).

Meanwhile users of other Kodi releaes and scraper versions simply disable  "Prefer online information".

Actually I want to review that setting in v19, what it was originally intended for (auto sync with edits on the  Musicbrainz site) was never fully implemented, then it got adjusted to do something different (without clear understanding of the original intent), then "fixed" (adjusted again by me to stop it breaking things). In one sense I would just like to remove it and draw a line under the history of confusion, however I need to take care I am not removing some functionality people are using.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
New Albums Have "MISSING" Artist00
This forum uses Lukasz Tkacz MyBB addons.