Bug 5.1 Surround issue after pausing Raspberry Pi 4
#16
(2020-05-24, 17:02)curiousnoob Wrote:
(2020-05-23, 15:03)Axionkt Wrote: This doesn't seem to be related to Kodi as the same issue occurs for every sound output regardless of the program used. Even speaker-test displays the same problem.
It could be the AVR, I'm not sure as the same setup works fine with a Pi2, only the Pi4 seems to have this issue.
I posted the problem with more detail on the raspberrypi forums: https://www.raspberrypi.org/forums/viewt...8&t=273949

I also tried to patch the kernel with the following thinking it could be related but I was wrong. https://github.com/raspberrypi/linux/com...e57464497e
Thank you for the repost.
I am afraid I wasn't very precise:
I do occasionally use the mentioned formats, however it seems to happen most notably during AAC (PCM) with or without passthrough as far as I can tell. I have not observed it in DTS yet. As Puck says it is hard to reproduce. Please excuse my inexperience, I am trying my best.
I have used AAC-Videos with passthrough via HDMI with multiple devices (Blu-ray Player, Win7/Win10 Laptops) and I never encountered this phenomenon. As far as I understand, it is not very likely to be an issue of the AVR.   
AAC and PCM are not 'passthrough' formats (*) - so they can't be passed through. AAC is decoded to PCM, and PCM is carried as PCM - which is a baseband format that is treated differently to a bit streamed format that is just passed through untouched.  So the passthrough response was a red herring - as you aren't playing formats that could be expected to be passed through. 

I'm going to guess you don't get it with DD/AC-3 or DTS content that can actually be passed through.

So the issue is likely to be to do with the way the Pi 4B handles multichannel PCM output.
Reply
#17
A workaround would be to set number of channels to 2.0, enable passthrough (DTS and AC3) and enable AC3 transcode.
This is unlikely to suffer from channels switching, but is limited to 5.1 channels.

You could also check the milhouse nightly build which uses an arm side (rather than firmware side) hdmi audio driver, so may not have the same issue.
Note: This is a Kodi 19 (Krypton) build which has moved to python 3 for add-ons, so some may not work yet, if they haven't been updated.
Backup first or test on a fresh sdcard in case there are issues there.
Reply
#18
(2020-05-25, 13:16)popcornmix Wrote: A workaround would be to set number of channels to 2.0, enable passthrough (DTS and AC3) and enable AC3 transcode.
This is unlikely to suffer from channels switching, but is limited to 5.1 channels.

You could also check the milhouse nightly build which uses an arm side (rather than firmware side) hdmi audio driver, so may not have the same issue.
Note: This is a Kodi 19 (Krypton) build which has moved to python 3 for add-ons, so some may not work yet, if they haven't been updated.
Backup first or test on a fresh sdcard in case there are issues there.
Thanks for the suggestions.
Just to let you know that I tried with Milhouse's latest nightly build with the arm side driver as well as with this new driver on Raspbian and the issue persists. The other thing that happens on the new driver is that there is sometimes no sound at all and switching audio track back and forth a few times fixes/causes it with no error in the Kodi log.
Reply
#19
I have a test firmware here that may help with the mixed channel issue.
If you are affected can you test it? Use the files from the zip file to replace start.elf/fixup.dat on the boot partition of sdcard.
Let me know if it helps.

Note: On Libreelec you need to rename start4.elf to start.elf and fixup4.dat to fixup.dat (i.e. replace existing files).
Reply
#20
(2020-06-22, 22:04)popcornmix Wrote: I have a test firmware here that may help with the mixed channel issue.
If you are affected can you test it? Use the files from the zip file to replace start.elf/fixup.dat on the boot partition of sdcard.
Let me know if it helps.

Note: On Libreelec you need to rename start4.elf to start.elf and fixup4.dat to fixup.dat (i.e. replace existing files).

I still need to do more testing but so far it didn't occur once in the past 8 hours with maybe 50 tries (I set a playlist in the background). I think the issue is fixed or I have been extremely lucky.

I wanted to check if this was fixed before reporting but I haven't had the chance to yet 352055 (thread)
It wasn't a deal breaker for my usage like the channel swapping but if it helps I'll do more testing and let you know.

By the way, I had to replace fixup4.dat and start4.elf on Raspbian buster or it didn't fix the issue on a Pi4.
Thanks a lot for your help, thanks to you I can finally, after close to a year, use this Pi4 with Kodi and relocate my Pi2!
Reply
#21
Thanks for reporting back.
Reply
#22
(2020-06-24, 11:41)popcornmix Wrote: Thanks for reporting back.

Of course.
After spending more time testing, I didn't have the channel swap problem, even once so I think it's safe to say that you fixed it.

However the issue I linked in my previous post still happens and, as it occurs in the same conditions and disappears in the same conditions, is it possible that those 2 issues might be related?
Reply
#23
(2020-06-22, 22:04)popcornmix Wrote: I have a test firmware here that may help with the mixed channel issue.
If you are affected can you test it? Use the files from the zip file to replace start.elf/fixup.dat on the boot partition of sdcard.
Let me know if it helps.

Note: On Libreelec you need to rename start4.elf to start.elf and fixup4.dat to fixup.dat (i.e. replace existing files).
Thanks for the updated firmware! It has completely resolved the problem for me!

Before installing your updated firmware, the audio channels were coming out of the wrong speakers when playing content with 5.1 channel audio on my system. The mix-up of audio channels wasn't consistent and seemed to change each time I played a movie.

Since installing the firmware I've noticed that a few movies bypass Kodi's volume control and their audio channels come out at maximum volume no matter what setting volume I have in Kodi. However, this only affects a few movies and may have been present before I updated the firmware. One of these problematic movies is the "Living World of Audio 1" DTS demo file available at https://thedigitaltheater.com/dts-trailers/.

I have Kodi running on a Raspberry Pi 4 via Librelec which is connected via HDMI to a Yamaha RX V375 reciever.
Reply
#24
(2020-06-30, 05:41)andypea Wrote: Since installing the firmware I've noticed that a few movies bypass Kodi's volume control and their audio channels come out at maximum volume no matter what setting volume I have in Kodi. However, this only affects a few movies and may have been present before I updated the firmware. One of these problematic movies is the "Living World of Audio 1" DTS demo file available at https://thedigitaltheater.com/dts-trailers/.

You almost certainly have DTS passthrough enabled. That means your receiver is decoding the audo (at full volume).
You should ideally set kodi to max volume and then reduce the volume through the receiver. That will mean passthrough and non-passthrough formats will have the same volume.

If you can't do that (e.g. no convenient remote for receiver), then you must disable passthrough in settings/system/audio.
Reply
#25
(2020-06-22, 22:04)popcornmix Wrote: I have a test firmware here that may help with the mixed channel issue.
If you are affected can you test it? Use the files from the zip file to replace start.elf/fixup.dat on the boot partition of sdcard.
Let me know if it helps.

Note: On Libreelec you need to rename start4.elf to start.elf and fixup4.dat to fixup.dat (i.e. replace existing files).

Hi,

I'm having the same issue with the audio channels getting mixed up. I have a Pi4, and I'm using LibreeElec. 

I'd love to try your firmware update, but I really could use step by step instructions to find the location of them on the SD card and the copy commands to get them there.

Can you help? 

Many, many thanks!
Reply
#26
(2020-07-12, 05:04)dasacco Wrote: I'd love to try your firmware update, but I really could use step by step instructions to find the location of them on the SD card and the copy commands to get them there.

 Probably easiest to insert the scdard into a windows (or linux) machine. The FAT partition should show up and you'll find the start.elf/fixup.dat that need to be replaced.
Reply
#27
(2020-07-13, 12:58)popcornmix Wrote:
(2020-07-12, 05:04)dasacco Wrote: I'd love to try your firmware update, but I really could use step by step instructions to find the location of them on the SD card and the copy commands to get them there.

 Probably easiest to insert the scdard into a windows (or linux) machine. The FAT partition should show up and you'll find the start.elf/fixup.dat that need to be replaced.
Of course, yes, thank you!

And I did just that, and threw about 50 files at it in stereo, mono and multi channel, starting and stopping at will, and ALL of them decoded properly. No issues whatsoever after your update.

Many nany thanks for this!
Reply
#28
Do you guys get large audio gaps on resume after pause?  I recently built a new kodi machine on a raspberry pi 4 - raspbian buster with Kodi 18.7, and now when resuming after pause I'll get sometimes up to 5 seconds of lost audio.  It's quite annoying - because of this issue the wife wants me to go back to my old install, which did not have this issue (openelec Krypton on a pi 3b)...but I really don't want to...
Reply
#29
(2020-07-24, 00:44)redec Wrote: Do you guys get large audio gaps on resume after pause?  I recently built a new kodi machine on a raspberry pi 4 - raspbian buster with Kodi 18.7, and now when resuming after pause I'll get sometimes up to 5 seconds of lost audio.  It's quite annoying - because of this issue the wife wants me to go back to my old install, which did not have this issue (openelec Krypton on a pi 3b)...but I really don't want to...

Which kernel version do you have currently installed?
Reply
#30
(2020-07-24, 06:02)rascas Wrote:
(2020-07-24, 00:44)redec Wrote: Do you guys get large audio gaps on resume after pause?  I recently built a new kodi machine on a raspberry pi 4 - raspbian buster with Kodi 18.7, and now when resuming after pause I'll get sometimes up to 5 seconds of lost audio.  It's quite annoying - because of this issue the wife wants me to go back to my old install, which did not have this issue (openelec Krypton on a pi 3b)...but I really don't want to...

Which kernel version do you have currently installed?

Linux raspberrypi 4.19.118-v7l+ #1311 SMP Mon Apr 27 14:26:42 BST 2020 armv7l GNU/Linux
Reply



Logout Mark Read Team Forum Stats Members Help
5.1 Surround issue after pausing Raspberry Pi 40
This forum uses Lukasz Tkacz MyBB addons.