v18 MySQL 5.5 update to 5.6/5.7?
#1
On a Win10 computer, I have been running MySQL 5.5 for a couple of years, and wonder if I should be updating? If yes, 5.6? 5.7? other? Also can you update from one level to another easily or should you delete 5.5 and start from scratch.
Reply
#2
You should update.  MySQL 5.5 is a bit too old now (https://kodi.wiki/view/MySQL/Setting_up_MySQL)

In the past I've just upgraded the Mysql server to a newer version, you should be able to do that without breaking things, but I would suggest taking a offline copy of the databases first, if you run into issues, it should be straightforward to restore them.
Reply
#3
(2020-07-01, 01:01)clones Wrote: If yes, 5.6? 5.7? other? Also can you update from one level to another easily or should you delete 5.5 and start from scratch.

MySQL 5.7 is the last series before 8.0 started, and is the preferred version.
Make sure to make a SQL dump/backup first.

I don't have any experience in updating MySQL applications myself.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#4
(Yesterday, 11:00)jools5000 Wrote: You should update.  MySQL 5.5 is a bit too old now (https://kodi.wiki/view/MySQL/Setting_up_MySQL)

In the past I've just upgraded the Mysql server to a newer version, you should be able to do that without breaking things, but I would suggest taking a offline copy of the databases first, if you run into issues, it should be straightforward to restore them.

@"jools5000 @"Klojum" thank you for your feedback. @"jools5000, what level are you on now? I have seen if I go to 5.7 (the password willl expire in 365 days, so i should make sure to change  the setting to have it never expire)
Reply



Logout Mark Read Team Forum Stats Members Help
MySQL 5.5 update to 5.6/5.7?0
This forum uses Lukasz Tkacz MyBB addons.