v18 Don't seem to be able to add new music source once nodes exist
#1
Hi,

So I've got various music nodes created to do various things but the problem is once these exist it doesn't seem possible to add another music source. I have my main source but want to add another one and the 'Add' option simply isn't there no matter the skin? I've even removed the existing source and now I have no music sources at all?

I've gone into Settings > Manage Sources > Music and all I get listed is the nodes, nothing else? I've changed to estuary to confirm and it's exactly the same. The 'files' option no longer works for music in V18 so how do i add another source and is the option missing because of the nodes or something else?

Thanks,

Mike.
SKIN: Aeon Madnox
RIP Schimi2k, we miss you.
When I grow up I want to be a skilled skinner
Thank me by ⬇ adding to my + reputation
Reply
#2
You have custom nodes, hence Kodi is using the node layout defined in userdata/library/music (for all skins, although I think some add nodes of their own). It sounds like you deleted or simply didn't create a copy of the node for file view. Either copy Kodi/system/library/muisc/files.xml into userdata/library/music or create a node with contents

<?xml version='1.0' encoding='UTF-8'?>
<node order="1" type="folder">
    <label>744</label>
    <icon>DefaultFolder.png</icon>
    <path>sources://music</path>
</node>
Reply
#3
Hi Dave,

Thanks for that, seems to have done the job. I never created it as it seems I didn't know it's needed once you create custom nodes. Just a question but shouldn't kodi core commands still persist even if you do create custom nodes or is it that custom nodes replaces all kodi commands in this instance?

Mike.
SKIN: Aeon Madnox
RIP Schimi2k, we miss you.
When I grow up I want to be a skilled skinner
Thank me by ⬇ adding to my + reputation
Reply
#4
Kodi only loads the system nodes if there are no nodes defined in userdata/library/music.  If it finds even one node in there, it skips loading the system ones.  That's so that the system ones don't override your custom node changes.  It does mean however that it only loads the ones that have been defined in userdata/library/music so if you want to keep the original nodes you have to copy them into place first, otherwise you can end up like you did with things missing.

Best way I find is to copy all the system nodes into the correct place first and then start modifying or adding them.
Learning Linux the hard way !!
Reply
#5
This why the wiki states to copy across the system path node structure https://kodi.wiki/view/Music_nodes#Manua...ustom_node
Reply



Logout Mark Read Team Forum Stats Members Help
Don't seem to be able to add new music source once nodes exist0
This forum uses Lukasz Tkacz MyBB addons.