v18 widgets and setting to enable play when play button is pressed (ie is playable??)
#1
I have recently been making some modifications to my preferred skin (titan bingie) and have managed to fix some things, move some things and generally do what i have been trying to do (eg only show the new episode overlay or the tag overlay but not both, or to use tmdbhelper instead of openmeta to open the next episode, to not show a bunch of overlays which darken the fanart etc)

However I am unable to figure out how to enable the widgets so that when you click play on the remote they open the episode or movie, currently I click play and nothing happens. When i click ok on the items it will open tmdbhelper (from my library widgets or whatever other widget) or the info screen and openinfo, that all works fine. Or it does now anyway.

But the widget items are just not playable with the "HandleKey: homepage (0xea) pressed, action is PlayPause".  Ive tried searching for stuff but its hard to search for stuff like "click play","playable" etc because so much non specific stuff comes back.

Ive tried looking at some other skins to see if I can see anything obvious, the widgets are totally presenting playable items, eg an XSP episodes playlist, or an addon trakt list. So im figuring its the actual widget setup.

Ive seen some stuff in unfussy:

<!-- Widget -->
<include name="widget_mainmenu">
<param name="id"></param>
<param name="visible">true</param>
<param name="header"></param>
<param name="type">movies</param>
<param name="height">250</param>
<param name="itemwidth">260</param>
<param name="path"></param>
<param name="static_content">false</param>
<param name="target">video</param>
<param name="sortby"></param>
<param name="sortorder">ascending</param>
<param name="onclick"></param>
<param name="useonclick">false</param>
<param name="limit"></param>
<param name="showplaystatus">false</param>


So stuff like type,target,showplaystatus and potentially onclick seem like they might have some relevance but ive added these to the widget includes for the types of widgets i have setup and it didnt make any difference, click play and nothing happens.
I had added static content false and the widgets reloaded when they normally wouldn't, so i'm pretty certain my additions to the widgets includes were having some effect.


So can anyone tell me how you setup a widget so when you click play on the remote it plays the widget item, in addition to being able to click on the item and play it or play it from the context menu (which works fine)?
Reply
#2
(2020-07-07, 15:33)henryjfry Wrote: c s

So mapping that button to simply "Enter" doesn't work either? I don't think its skin related, its mapping the button to the correct action. You can view all the default shortcuts by viewing C:\Program Files\Kodi\system\keymaps\keyboard.xml
Reply
#3
(2020-07-07, 17:10)ohhwee Wrote:
(2020-07-07, 15:33)henryjfry Wrote: c s

So mapping that button to simply "Enter" doesn't work either? I don't think its skin related, its mapping the button to the correct action. You can view all the default shortcuts by viewing C:\Program Files\Kodi\system\keymaps\keyboard.xml

No play works, ok works, enter works on these entries when they are loaded from a different screen.
But the widgets which contain video items do not play from the widgets when you click play on the remote when you are attempting to play it from the widget on the home screen.

The debug log shows "HandleKey: homepage (0xea) pressed, action is PlayPause" but no action is performed despite the container showing the DBTYPE to be a video, or episode or movie.
I could presumably map the play button to enter on the home screen but the debug log shows a play request and the items its referencing play from the addon,playlist,whatever so they should play from a widget too shouldnt they?

I dont want to change the function of a button just to make one thing work when it should work by the play method.
Reply
#4
(2020-07-07, 17:16)henryjfry Wrote:
(2020-07-07, 17:10)ohhwee Wrote:
(2020-07-07, 15:33)henryjfry Wrote: c s

So mapping that button to simply "Enter" doesn't work either? I don't think its skin related, its mapping the button to the correct action. You can view all the default shortcuts by viewing C:\Program Files\Kodi\system\keymaps\keyboard.xml

No play works, ok works, enter works on these entries when they are loaded from a different screen.
But the widgets which contain video items do not play from the widgets when you click play on the remote when you are attempting to play it from the widget on the home screen.

The debug log shows "HandleKey: homepage (0xea) pressed, action is PlayPause" but no action is performed despite the container showing the DBTYPE to be a video, or episode or movie.
I could presumably map the play button to enter on the home screen but the debug log shows a play request and the items its referencing play from the addon,playlist,whatever so they should play from a widget too shouldnt they?

I dont want to change the function of a button just to make one thing work when it should work by the play method.

If youd of looked quickly you'd see you can set actions globally, on home window, pvr etc. Its an easy solution vs banging your head
Reply
#5
(2020-07-07, 17:27)ohhwee Wrote:
(2020-07-07, 17:16)henryjfry Wrote:
(2020-07-07, 17:10)ohhwee Wrote: So mapping that button to simply "Enter" doesn't work either? I don't think its skin related, its mapping the button to the correct action. You can view all the default shortcuts by viewing C:\Program Files\Kodi\system\keymaps\keyboard.xml

No play works, ok works, enter works on these entries when they are loaded from a different screen.
But the widgets which contain video items do not play from the widgets when you click play on the remote when you are attempting to play it from the widget on the home screen.

The debug log shows "HandleKey: homepage (0xea) pressed, action is PlayPause" but no action is performed despite the container showing the DBTYPE to be a video, or episode or movie.
I could presumably map the play button to enter on the home screen but the debug log shows a play request and the items its referencing play from the addon,playlist,whatever so they should play from a widget too shouldnt they?

I dont want to change the function of a button just to make one thing work when it should work by the play method.

If youd of looked quickly you'd see you can set actions globally, on home window, pvr etc. Its an easy solution vs banging your head

Yeah ive just tried Artic Horizon and its not playing from widgets either so maybe kodi just cant do that?
So ill maybe have to change the home play mapping.
Reply
#6
Don'tknow whether this helps or not , but I had this exact issue in bingie recently and solved it by going to , "skin settings-homescreen layout-Widgets section and disable , set default "select" action to Show Information ( only applies to widgets).
Reply
#7
(2020-07-07, 17:57)ontap Wrote: Don'tknow whether this helps or not , but I had this exact issue in bingie recently and solved it by going to , "skin settings-homescreen layout-Widgets section and disable , set default "select" action to Show Information ( only applies to widgets).

That setting was already disabled.

Ive just mapped my play and pause button to be select. It was a bit tricky as the keymapper wouldn't show me the ID for the play button.
Im on a Harmony 650 remote, setup with the Xbox360 mapping, pause was 230 and was shown readily by keymapper but when i clicked play it kept on going back to the menu in keymapper but I was able to figure out it should be ID 234 for the play key.

<home><keyboard><key id="234">select</key><key id="230">select</key></keyboard></home>

Not ideal as i'd prefer if there were a more context specific solution like widget includes but it'll do.
Reply
#8
(2020-07-07, 18:55)henryjfry Wrote:
(2020-07-07, 17:57)ontap Wrote: Don'tknow whether this helps or not , but I had this exact issue in bingie recently and solved it by going to , "skin settings-homescreen layout-Widgets section and disable , set default "select" action to Show Information ( only applies to widgets).

That setting was already disabled.

Ive just mapped my play and pause button to be select. It was a bit tricky as the keymapper wouldn't show me the ID for the play button.
Im on a Harmony 650 remote, setup with the Xbox360 mapping, pause was 230 and was shown readily by keymapper but when i clicked play it kept on going back to the menu in keymapper but I was able to figure out it should be ID 234 for the play key.

<home><keyboard><key id="234">select</key><key id="230">select</key></keyboard></home>

Not ideal as i'd prefer if there were a more context specific solution like widget includes but it'll do.

Can you try enabling that setting i mentioned , its a while since I had that issue , I might have it the wrong way around ?
EDIT :  Sorry , yes if its all working after you mapped a key on your remote , the issue was not kodi related then.
Reply
#9
(2020-07-07, 17:30)henryjfry Wrote:
(2020-07-07, 17:27)ohhwee Wrote:
(2020-07-07, 17:16)henryjfry Wrote: No play works, ok works, enter works on these entries when they are loaded from a different screen.
But the widgets which contain video items do not play from the widgets when you click play on the remote when you are attempting to play it from the widget on the home screen.

The debug log shows "HandleKey: homepage (0xea) pressed, action is PlayPause" but no action is performed despite the container showing the DBTYPE to be a video, or episode or movie.
I could presumably map the play button to enter on the home screen but the debug log shows a play request and the items its referencing play from the addon,playlist,whatever so they should play from a widget too shouldnt they?

I dont want to change the function of a button just to make one thing work when it should work by the play method.

If youd of looked quickly you'd see you can set actions globally, on home window, pvr etc. Its an easy solution vs banging your head

Yeah ive just tried Artic Horizon and its not playing from widgets either so maybe kodi just cant do that?
So ill maybe have to change the home play mapping.

"PlayPause" only works to play an item in a Media window (i.e. MyVideoNav / MyMusicNav). Using it to play a listitem is a relic from the xbmc days before dynamic widget lists were even possible.

You need to use the "Select" action to trigger onclick for listitems and buttons.
Reply



Logout Mark Read Team Forum Stats Members Help
widgets and setting to enable play when play button is pressed (ie is playable??)0
This forum uses Lukasz Tkacz MyBB addons.