Confluence for Kodi 19
#1
Will there be a version on Confluence for Kodi 19 ?

I have just updated to a recent Kodi 19 Alpha and Confluence is now marked as incompatible but nothing in  the log explains why

I'm running on a raspberry pi 3 using the latest Millhouse build.
Reply
#2
I personally haven't felt up to coding during the pandemic as I'm a key worker and my workload actually increased but hopefully someone else will look at it soon.
Reply
#3
It's only really now suddenly marked as incompatible due to the recent addon.xml GUI version bump - it seemed otherwise OK in practise (although clearly not getting new features currently - e.g. the tempo one looks interesting... https://github.com/xbmc/xbmc/pull/18182 ) - but in my testing there's no major breakage to be worried about really.

What's the general idea with branches etc - is master supposed to track current Kodi, and the branches be the 'locked in time' older version (with, I suppose, back ports possible)?

I personally can't live with Estuary and all its half off screen elements and general font randomness, so I suppose - if no one else does before me - I'll be porting Confluence along to 19 at some point...at least to a point where it functionally works as it does now.  Not sure I will have the time to get into new features necessarily, though.
Addons I wrote &/or maintain:
OzWeather (Australian BOM weather) | Check Previous Episode | Playback Resumer | Unpause Jumpback | XSqueezeDisplay | (Legacy - XSqueeze & XZen)
Sorry, no help w/out a *full debug log*.
Reply
#4
@bossanova808 

Regarding the branches, my thought by creating them at some point was somewhat similar to what Kodi itself does. Everything should be PRd to the master branch if the addition will work on both (for the actual release for the actual Kodi version and for Kodi master/nightly) and can for sure be backported to let's say Leia. As there's no "Matrix"-branch for Kodi yet, everything for Kodi 19 alpha releases can go into master. We will create a new branch once Kodi 19 is released as a stable version ("stable" in meaning of "non alpha/beta/RC"). 

If you have a fix for Kodi 18 and that fix will conflict with the design, layout or technical stuff (let's say reverted built in functions which still work for Kodi 18 but not for Kodi 19), it's fine to PR against a specific branch.

We haven't talked about what PRs against specific already released version should/can be. If those PRs should be fixes only or also new skin features. I'm fine in either way but I would recommend to add new features to master first and then backport them to the specific branch. As the next Confluence version should also have a benefit from that new feature.
Reply
#5
As @Hitcher currently doesn't have the time @Gade has kindly said he'll take a look, no promises for now however so please be patient. However to get Confluence working on v19 just requires doing what I detail here https://forum.kodi.tv/showthread.php?tid...pid2960873 and as the standard version of Confluence doesn't rely on any Python scripts there shouldn't be any major issues, however Confluence won't be up to date with all the latest skin changes so there maybe oddities observed.
Reply
#6
(2020-07-21, 06:45)bossanova808 Wrote: the tempo one looks interesting... https://github.com/xbmc/xbmc/pull/18182 ) - but in my testing there's no major breakage to be worried about really.

Tempo support has been in Kodi for quite a while now and been supported in Confluence for some time as well https://github.com/xbmc/skin.confluence/...1a534ea072
Reply
#7
Just PR'd some minor changes:  https://github.com/xbmc/skin.confluence/pull/81
This will get Confluence working in Kodi 19.

I'll probably do some more over the next week or so.
A lot for v19 is optional, although it would be great to include in the skin.
Reply
#8
@jjd-uk  Ah right - missed that because I use passthrough audio and don't have sync playback to display enabled ... thanks for pointing that out, might have a play with it.

And much better that someone competent has stepped in Smile
Addons I wrote &/or maintain:
OzWeather (Australian BOM weather) | Check Previous Episode | Playback Resumer | Unpause Jumpback | XSqueezeDisplay | (Legacy - XSqueeze & XZen)
Sorry, no help w/out a *full debug log*.
Reply
#9
(2020-07-21, 15:59)jjd-uk Wrote: As @Hitcher currently doesn't have the time @Gade has kindly said he'll take a look, no promises for now however so please be patient. However to get Confluence working on v19 just requires doing what I detail here https://forum.kodi.tv/showthread.php?tid...pid2960873 and as the standard version of Confluence doesn't rely on any Python scripts there shouldn't be any major issues, however Confluence won't be up to date with all the latest skin changes so there maybe oddities observed.

Thanks editing the xbmc.gui version number in addons.xml worked a treat
Reply
#10
(2020-07-22, 00:25)Gade Wrote: Just PR'd some minor changes:  https://github.com/xbmc/skin.confluence/pull/81
This will get Confluence working in Kodi 19.

I'll probably do some more over the next week or so.
A lot for v19 is optional, although it would be great to include in the skin.
Thanks @Gade , works great.
 On thing, I am seeing a new "search" dialogue in the home view. Can this be removed or made optional? Is it another plug-in that may have added this?
Reply
#11
You probably have Global Search installed.
Reply
#12
(2020-07-20, 19:12)tkgafs Wrote: Will there be a version on Confluence for Kodi 19 ?

I have just updated to a recent Kodi 19 Alpha and Confluence is now marked as incompatible but nothing in  the log explains why
Same for me

From the first days of kodi i am using confluence on windows.
I dont need that cover hiphop superduper picture bang colorful artist stuff.

all i need is a pure and clean gui with previews of pics and videos for my drives like confluence gave me

And for the last 2 years i am using all nightly build alphas and betas
and now i cant use confluence on all kodi 19.xHuh

i said to myself, get up now test some new skins .. maybe ..
i did,but all i can say is : i hate them!

sorry guys and skinmakers ... i maybe have just not found the right one

does anyone know of a "confluence like" puristic skin what is working on kodi19?
If not .. i will stick to kodi 18 until i die Wink
Reply
#13
Can you not read the previous posts? as Confluence works just fine with v19. I said what needs to be done in Post #5 to get Confluence working until a newer version is available from the repo.
Reply



Logout Mark Read Team Forum Stats Members Help
Confluence for Kodi 190
This forum uses Lukasz Tkacz MyBB addons.