Solved Leia 18.7 On Ubuntu - Crossfade between songs doesn't work properly.
#1
Tongue 
Hi,

Kodi is may main and only mediaplayer since many years now and I'm very happy with it.
I use to listen to my music in flac files, and I prefer to crossfade 15sec playing songs with the amazing Party mode playlist Big Grin .
But, there's a little problem with my setup : During the playback, when kodi start loading the next song (15s before the end of the song), playback stop 0.5 sec then continue playing  Music Confused .
All my song are store on an internal drive mounted a the start of the system Ubuntu 20.

Can you help me ? buffering issue ?? I'm pretty sure that it is not the problem, but If someone had this kind of issue maybe it would help to resolve it Cool .

Thx in advance
Reply
#2
https://paste.kodi.tv/tilivobaxe.kodi
Reply
#3
Well for one, that's not a proper debug log (wiki) Smile  Enable debugging in Kodi, exit it, restart it and play the first two songs in your party mode playlist (so as to grab the crossfade) and then upload and link that log please.  Also, does it work properly if you don't use pulseaudio and use alsa instead ?  I ask because I don't use pulseaudio and I can't reproduce that with v19 and alsa.
Learning Linux the hard way !!
Reply
#4
Hi,
I solved the problem : simply changing the audio pilot in kodi system config menu by removing pulseaudio and select High Definition Audio Controller (hdmi), and everething go fine.
Reply
#5
So, it was pulse then!!  Thanks for confirming that.
Learning Linux the hard way !!
Reply
#6
Thread marked solved.
Learning Linux the hard way !!
Reply
#7
Huh!!!! Come back to pulseaudio device to reproduce the issue, and miracle, ther's no problem anymore. But to be complete transparent, I had made an advanced setting xml file to give more cache. Maybe it is THE solution
Reply
#8
I change the extension of advanced setting xml to bak, to try to go back to the initial cache, I restart kodi without advanced setting xml file, but the issue is gone, even with pulseaudio ??!!??
So, I'II mark threat as solved Huh .
Reply
#9
Thx
Reply
#10
(2020-07-23, 18:53)Michkaa Wrote: I change the extension of advanced setting xml to bak, to try to go back to the initial cache, I restart kodi without advanced setting xml file, but the issue is gone, even with pulseaudio ??!!??

That is indeed food for thought. @black_eagle
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#11
(2020-07-23, 19:09)Klojum Wrote: That is indeed food for thought.

Cache setting is for network isn't it, unless you specifically tell it to buffer all file systems ? Also, I wasn't aware it affected PAPlayer, just video Huh
Learning Linux the hard way !!
Reply



Logout Mark Read Team Forum Stats Members Help
Leia 18.7 On Ubuntu - Crossfade between songs doesn't work properly.0
This forum uses Lukasz Tkacz MyBB addons.