Bug Music Videos -- GUI Update Problem
#1
Hi! I've experienced strange behavior of the "back button" for years (mostly with tv shows and profiles) and can present one reproducible example now :-) I have first encountered these two problems with the Arctic Zephyr skin (see https://forum.kodi.tv/showthread.php?tid...pid2965966 ), but I was also able to reproduce everything with Estuary on my Master profile.

Debug-Log: https://pastebin.ubuntu.com/p/XXk5brQRHF/

Case 1: Trying to play something that does no longer exist.

1) Go to Music Videos - Titles. Notice, how every music video is displayed with an Artist and a Title, separated with a dash.
2) Try to start a music video that you have deleted (e.g. because you figured out that Raspberry PIs don't like webm files and you're replacing them with mp4s). Notice, how in the background still the format "Artist - Title" is used
2) Confirm with Yes and magically, instead of "Artist - Title", the music videos are only shown with "Title" now. (go up one level and down again to fix)

Image


Case 2: Changing meta-data.

1) Go to Artists - Albums, e.g. Gzuz, but any Gangster-Rap should do. Notice, how the album is shown as "Ebbe und Flut".
2) After changing something in the corresponding NFO, e.g. add a genre, go to the Context menu of CL500 and Refresh. Notice the new genre "Flower Power".
3) Now Escape the dialog. And again -- magic -- Gzuz is gone for now. Instead, we can only see "411" where once was his album. But fear not, one level further upwards, everything is fine again.

Image
Reply
#2
(2020-07-27, 22:27)annomatik Wrote: Hi! I've experienced strange behavior of the "back button" for years (mostly with tv shows and profiles) and can present one reproducible example now :-) I have first encountered these two problems with the Arctic Zephyr skin (see https://forum.kodi.tv/showthread.php?tid...pid2965966 ), but I was also able to reproduce everything with Estuary on my Master profile.

Debug-Log: https://pastebin.ubuntu.com/p/XXk5brQRHF/

Case 1: Trying to play something that does no longer exist.
 Well, at least in case1 I see that in one screenshot the sort is name and in the second it is title and that's why you see different information in the list (Estuary provides the item's "label" which is set by Kodi).  Why the different sorts I don't know.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix
Leia see: 304472
Reply
#3
Did you try to Clean the Library, I would think that would fix these issues.
Reply
#4
Hmmm... The "Clean Library" of Videos or the "Clean Library" of Music? The Video one I use often, there doesn't seem to be a different behavior when I use it.
Reply
#5
(2020-07-28, 20:17)annomatik Wrote: Hmmm... The "Clean Library" of Videos or the "Clean Library" of Music? The Video one I use often, there doesn't seem to be a different behavior when I use it.
 It's videos, but for a while now it is possible to limit video cleaning to specific content, though I think most skins default to "video" which cleans all video content types.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix
Leia see: 304472
Reply



Logout Mark Read Team Forum Stats Members Help
Music Videos -- GUI Update Problem0
This forum uses Lukasz Tkacz MyBB addons.