Creating mariadb issue
#1
I getting the following error when trying to create Mariadb

Failed to enable unit: Unit file connman-wait-for-network.service does not exist

Followed the guide
These are my steps

https://pastebin.com/LwbHSHCE

Nothing comes up on my second device
I tried the following command
Sudo service Mariadb status and it says its running
https://pastebin.com/Q8KiwK64

Am I doing something wrong

Ubuntu 20.04
Kodi 18.8
Reply
#2
What guide did you follow?  That connman service is specific to OSMC AFAIK.
Learning Linux the hard way !!
Reply
#3
I've used MySQL databases on from Ubuntu 14.04 till 20.04 .
I never need to use something like a wait-for-network option.

Why do you need it?
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#4
(2020-07-31, 23:54)black_eagle Wrote: What guide did you follow?  That connman service is specific to OSMC AFAIK.

I followed
https://kodi.wiki/view/MySQL

my pastebin is each step I did and then copied the Advancedsettings.xml (in pastebin also) to both devices
But nothing comes up on the second device.
Both fresh installs
Reply
#5
(2020-08-01, 00:05)Klojum Wrote: I've used MySQL databases on from Ubuntu 14.04 till 20.04 .
I never need to use something like a wait-for-network option.

Why do you need it?

Maybe I'm missing something
I've copied the same Advancedsettings.xml in the pastebin in each device but no media is shown on my second device.
Reply
#6
(2020-08-01, 03:26)Yoshifriend Wrote: Maybe I'm missing something

Maybe you're just overthinking things.

(2020-08-01, 03:26)Yoshifriend Wrote: I've copied the same Advancedsettings.xml in the pastebin in each device but no media is shown on my second device.

"No media" is a bit vague to me. I see it as 3 separate things: creating a database, accessing a database locally, using the database with Kodi.
Perhaps that Failed to enable unit: Unit file connman-wait-for-network.service does not exist is a MariaDB thing, I just haven't encountered it before.

You could try to do:
systemctl disable systemd-networkd-wait-online.service
to disable the wait-online service to prevent the system from waiting on a network connection, and use
systemctl mask systemd-networkd-wait-online.service
to prevent the service from starting if requested by another service (the service is symlinked to /dev/null).

But again, I never have such network troubles with Ubuntu, including 20.04.
If you reboot your Ubuntu pc, and open a terminal and type mysql, what happens? It should get you into the mysql console.
You should also be able to log in with Kodi's credentials, using tools like MySQL Workbench or PHPMyAdmin.
Thirdly, there is the filling up of the Kodi database with data.

Quote:I've copied the same Advancedsettings.xml in the pastebin in each device but no media is shown on my second device.
So where exactly is the message "no media" coming from?
Also provide a full kodi.log the problematic device.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#7
Quote:"No media" is a bit vague to me. I see it as 3 separate things: creating a database, accessing a database locally, using the database with Kodi.

Apologies I mean I can see the movies on computer with Mariadb installed on it but can't see movies on the second device.
I installed Mariadb first then added a movie source. Also tried removing source and adding it again

Quote:You could try to do:
systemctl disable systemd-networkd-wait-online.service
to disable the wait-online service to prevent the system from waiting on a network connection, and use
systemctl mask systemd-networkd-wait-online.service
to prevent the service from starting if requested by another service (the service is symlinked to /dev/null).

But again, I never have such network troubles with Ubuntu, including 20.04.
If you reboot your Ubuntu pc, and open a terminal and type mysql, what happens? It should get you into the mysql console.
You should also be able to log in with Kodi's credentials, using tools like MySQL Workbench or PHPMyAdmin.
Thirdly, there is the filling up of the Kodi database with data.

I input those 2 commands in then opened kodi on both devices but still can't see movies on 2nd device

When I type mysql in command I get
Error 1045 (28000):access denied for user 'user'@localhost' (using password: NO)

Edit:
I removed everything and started from start and did the following steps
https://pastebin.com/LwbHSHCE
Put new movie source
I haven't got any errors but again I can't see the movie source on my second device.
Are my step in the pastebin correct?
Reply
#8
@Yoshifriend Please post a link to a debug log (wiki) from the second device.  Please make sure you follow all the instructions in this link -> debug log (wiki)
Learning Linux the hard way !!
Reply
#9
(2020-08-01, 19:15)black_eagle Wrote: @Yoshifriend Please post a link to a debug log (wiki) from the second device.  Please make sure you follow all the instructions in this link -> debug log (wiki)

My host computer ip is 192.168.1.162
https://pastebin.com/hPgxb5Fg

Thanks
Reply
#10
Quote:<advancedsettings version="1.0">
<videodatabase>
<type>mysql</type>
<host>192.168.1.162</host>
<port>3306</port>
<user>kodi</user>
<pass>*****</pass>
</videodatabase>

vs.
Quote:bind-address = 192.168.1.10

Are you sure you know what you are doing? You have to place the server IP into the setting, not the client one, your kodi config is wrong.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#11
(2020-08-02, 09:09)fritsch Wrote:
Quote:<advancedsettings version="1.0">
<videodatabase>
<type>mysql</type>
<host>192.168.1.162</host>
<port>3306</port>
<user>kodi</user>
<pass>*****</pass>
</videodatabase>

vs.
Quote:bind-address = 192.168.1.10

Are you sure you know what you are doing? You have to place the server IP into the setting, not the client one, your kodi config is wrong.

No I've tried another pc to test thats why I wrote the pc running kodi is 192.168.1.162.
Disregard 192.168.4.10
Reply
#12
According to your log, your device does connect to mariadb.
Quote: 
2020-08-02 09:33:12.989 T:4559 NOTICE: MYSQL: Connected to version 10.3.22-MariaDB-1ubuntu1

But then I noticed
Quote:2020-08-02 09:33:13.864 T:4445 NOTICE: UpdateLibraries: Starting video library startup scan

Unless you have copied the sources.xml file (and possibly mediasources.xml) to that device, I doubt that updating the library with it on startup is a good idea.
 
(2020-08-03, 14:13)Yoshifriend Wrote: No I've tried another pc to test thats why I wrote the pc running kodi is 192.168.1.162.

The address needs to be the address of the PC or device running mariadb, although the log does show it connecting.

If you do mysql -u kodi -p and then enter the password from your advancedsettings,xml file then that should log you into mariadb as the kodi user.  Then do show databases; to check that the db's exist.

Then you could try use MyVideos116; followed by select * from movie where idMovie = 1; and ensure it returns some data.
Learning Linux the hard way !!
Reply



Logout Mark Read Team Forum Stats Members Help
Creating mariadb issue0
This forum uses Lukasz Tkacz MyBB addons.