Android Android TV since firmware update has Audio Passthrough issues.
#1
I'm running Kodi on a couple Sony Android TVs (XBR-..X850C).  In the past month Sony updated the firmware changing from Marshmallow directly to Oreo.
One of the benefits is that DTS passthrough now works.
On the down side, audio passthrough is now garbage.

For DD videos (I haven't tested with DTS files), pausing, FF/REW, or skipping forward/back and then resuming playback will result in audio drops outs every few seconds, out of sync audio, or both.  If I play the video straight through, there are no issues.

If I allow set up (as I had before) with Number if Channels 2, Allow Passthrough, Dolby Capable Receiver and Enable DD Transcoding, then the transcoded Dolby playback has the same issues as a native DD track described above.

If I disable allow passthrough, and output everything as downmixed stereo, everything is fine.  Audio passthrough worked flawlessly before the update.

I hope someone can help... and do NOT say use a better device to run Kodi.

Here is a log in which I ran a DD video, skipped forward a minute and resumed playback.  The audio was out of sync after skipping ahead: ihakukijuh.kodi (paste)
Reply
#2
Backup your stuff and try a nightly. The kodi nightlies implement the newest Sync technologies available on Android.
If issue still persists, please ask them to fix their firmware.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
(2020-08-02, 10:37)fritsch Wrote: If issue still persists, please ask them to fix their firmware.
LOL.

Edit: Tried the nightly build with no success.  Uninstall Kodi completely and did a clean install, also no luck.
Edit 2: Huh.  SPMC works fine.  I don't want to be running a version of something that old.
Reply
#4
So I tried an old custom build of v18.2 and the audio sync thing still happens.  I tried a file with a USB stick to rule out a network issue.  Same problem.

It's definitely something to do with Oreo and possibly a change made between SPMC's fork of Krypton and Leia.
I'd really like to understand what's gone wrong here because nothing substantial seems to have changed with the TV besides the OS.  I can't be the only one experiencing this.
I'm going to try Krypton 17.6 next.
Reply
#5
SPMC is from back when developers used to bend over backwards to accommodate all kinds of different Android firmware, but those days are gone. If Sony aren't following agreed standards with their firmware then that's their call.
Reply
#6
Are you saying that Kodi attempted to accommodate Android as well as SPMC at that time?
I tested a Krypton build of SPMC and it also had the stuttering & sync issue.  Only the Jarvis version plays cleanly.

I was thinking of testing a Jarvis build of Kodi to see if it also played without issue, but your post makes it sound like it probably would and there'd be nothing to be learned from that.

I also want to mention this is unique to audio passthrough.  With that off, everything plays fine.  With audio passthrough on, after navigation and the stutter/sync problem starts, I see my tuner keep re-initializing the audio and the dialog normalization level re-displaying after each stutter.
Reply
#7
Jarvis might still have the old libstagefright private API for hw acceleration - I don't remember anymore. Also I cannot see a single issue in your Debug Log :-(
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply



Logout Mark Read Team Forum Stats Members Help
Android TV since firmware update has Audio Passthrough issues.0
This forum uses Lukasz Tkacz MyBB addons.