Solved TMM keeps crashing when trying to open application on mac os
#1
So I was doing a bulk edit movie set rename on like 1000 movies, and then it seemed to have frozen and said application not responding, So I did force quit, and then when trying to relaunch it makes it 90% and crashes every time (10 times I tried). I tried logging out and restarting too. WHELP!
Reply
#2
if you have a large database the Java memory might be running out (512mb per default). Maybe this helps: https://www.tinymediamanager.org/help/fa...ace-errors
tinyMediaManager - THE media manager of your choice - available for Windows, macOS and Linux
Help us translate tinyMediaManager at Weblate
Found a bug or want to submit a feature request? Contact us at GitLab
Image
Reply
#3
(2020-08-05, 20:20)mlaggner Wrote: if you have a large database the Java memory might be running out (512mb per default). Maybe this helps: https://www.tinymediamanager.org/help/fa...ace-errors

I have 1700 titles, It was working fine, I shouldn't have force quit it so soon, I think I corrupted something when I did that. I don't think its ram related, I have 24 GB /1TB SSD, and have nothing else running right now and it won't even open anymore.  I looked for that txt, I don't have it. So do I just create that txt file and put that one single phrase into it? hat folder exactly? I don't think this is the issue and will work but will try it anyways.

If I wanted to do a fresh install, and then move my DB file info into it would that work?

it crashes when it says loading ui
Reply
#4
sure, just copy the whole /data/ folder.
(and maybe the /cache/ folder for already cached images)

Can you pleast post the /logs/*.log to some pastbin site?
tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
Image
Reply
#5
(2020-08-05, 22:39)myron Wrote: sure, just copy the whole /data/ folder.
(and maybe the /cache/ folder for already cached images)

Can you pleast post the /logs/*.log to some pastbin site?

https://pastebin.com/zHg47UK1

Some of the recent text that was in the tmm.log

THX ;/
Reply
#6
okay, looks like the set filter causes an issue; could you send us your settings? (either directly here via pastebin, or via pm if want to keep them confidential).
After you have sent us the settings for analysis, edit the file "data/movies.json" and delete the whole line of 

Code:

  "movieSetUiFilters" : [ ... ],

this should make a restart able again
tinyMediaManager - THE media manager of your choice - available for Windows, macOS and Linux
Help us translate tinyMediaManager at Weblate
Found a bug or want to submit a feature request? Contact us at GitLab
Image
Reply
#7
I've just been digging a bit deeper in the code and it does not look like you have a strange filter setting, but it looks like that the force quit let a inconsistent database behind (where a movieset has a reference to movie x, but movie x does not have a reference to the movie set)...
hard to solve without building you a special build which repairs such a constellation - or you delete your database and reimport all data (you should have almost everything identically to this database, because we try to save as much as possible into the NFO)
tinyMediaManager - THE media manager of your choice - available for Windows, macOS and Linux
Help us translate tinyMediaManager at Weblate
Found a bug or want to submit a feature request? Contact us at GitLab
Image
Reply
#8
(2020-08-06, 07:45)mlaggner Wrote: So iI've just been digging a bit deeper in the code and it does not look like you have a strange filter setting, but it looks like that the force quit let a inconsistent database behind (where a movieset has a reference to movie x, but movie x does not have a reference to the movie set)...
hard to solve without building you a special build which repairs such a constellation - or you delete your database and reimport all data (you should have almost everything identically to this database, because we try to save as much as possible into the NFO)

So I removed the data/cache folder, deleted tmm, and re installed. Loaded the data/cache back in, and it crashed again.

I then removed the data/cache, and relaunched and it loaded fine. Although no movies of course ;(

If I add one of my previouse drives as new source, and update from source, will it load all the movies in just like before? I don't mind having to rebuild the poster artwork cache, or adjusting some preference settings, as long as all the movie data that has been scraped and manually edited, like artwork,fanart,subtitles,movie set,watched, metacritic rating, imdb links etc. It sounds like if that's all in the folder with artwork and nfo, then it should be ok. If its just a matter of the computer having to rescan for an hour or so thats no problem.
Reply
#9
I just re-added all the sources, and it loaded everything just as it was and fairly quickly, so consider this matter closed.  Will not be force closing, since I find that if it gets bogged down, it gets out of it, and doesn't permanently freeze or crash. In its defense when it happens is when I change the Movie Set for a few a thousand movies at a time, but realized I should be using tags to mark movies, which changes  a thousand at a time no problem.

I notice though, TMM changes the Languages from full names to lowercase abbreviations when adding movies that have been scraped and stored in folders with all artwork and nfos etc. Rescraping them for language only puts them back in full names with first letter uppercase. I'm not sure how kodi displays it, if this matters.
Reply



Logout Mark Read Team Forum Stats Members Help
TMM keeps crashing when trying to open application on mac os0
This forum uses Lukasz Tkacz MyBB addons.