•   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 8
  •   
Release Twitch.tv
#31
(2020-11-09, 06:31)neo_ Wrote: Anytime I get a mid-roll add, it keeps looping over and over again forever. It forces me to stop the stream and reopen it. If a dev wants the log, I can share. Though mid-roll adds haven't been occurring too often (luckily), it still happens once every couple hours if you're watching the right stream. To be clear, by mid-roll ads I mean ads that occur in the middle of a stream.

It was made pretty clear the the maintainer is not going to address this.
Reply
#32
For those dealing with endless ads from Twitch, I can attest that paying for a Twitch Turbo subscription and following the instructions included on the GitHub will eliminate all ads within the addon and across Twitch. In my opinion will worth the $9-10/mo.
Reply
#33
(2020-10-02, 15:39)anxdpanic Wrote: There is no solution for non-paying users, out of good faith, I don't intend to block any ads. I watch 90% Twitch and deal the ads as well.
The problem is that Twitch acts like we are using adblock and gives us extra ads. Pretty shitty situation overall that makes it more or less unwatchable.
Reply
#34
Getting errors trying to access the addon today. Havent changed anything with my setup. Error in Kodi says Failed to Connect to Twitch API. Nothing loads. Logs found here: LOG
Reply
#35
(2020-11-17, 20:13)chief27 Wrote: Getting errors trying to access the addon today. Havent changed anything with my setup. Error in Kodi says Failed to Connect to Twitch API. Nothing loads. Logs found here: LOG
Same error here - was working fine up to around 17:00 GMT.  Trying to browse/view streams after this time resulted in the "status: 404, This API does not exist" error.

Updated my OAuth key and reset the function/json cache just on general troubleshooting principle, but didn't help Wink

Can't see any notices/deadlines in the Twitch dev services about some API/call being deprecated today, so maybe it's just a temporary API service outage ?

Relevant debug log entries:
2020-11-17 18:37:44.755 T:140512751982336   DEBUG: Twitch: Version: |2.5.3| Application Version: |Kodi| |18.9 (18.9.0) Git:18.9-Leia| -> |18|9|Leia|0|| (ENCODED)
2020-11-17 18:37:44.755 T:140512751982336   DEBUG: Twitch: Queries: |{'content': 'live', 'mode': 'followed'}| Args: |['plugin://plugin.video.twitch/', '1', '?content=live&mode=followed', 'resume:false']|
2020-11-17 18:37:44.755 T:140512751982336   DEBUG: Twitch: Calling cached method: |twitch_addon.addon.api.Twitch.valid_token|
2020-11-17 18:37:44.755 T:140512751982336   DEBUG: script.module.python.twitch: GET QUERY: url: |https://api.twitch.tv/kraken/|, params: |{}|, data: |{}|, headers: |{'Client-ID': u'kimne78kx3ncx6brgo4mv6wki5h1ko', 'Authorization': 'OAuth ***********', 'ACCEPT': 'application/vnd.twitchtv.v5+json'}|, target_func: |root|
2020-11-17 18:37:44.755 T:140512751982336   DEBUG: script.module.python.twitch: Downloading: |https://api.twitch.tv/kraken/|
2020-11-17 18:37:45.002 T:140512751982336   DEBUG: script.module.python.twitch: url: |https://api.twitch.tv/kraken/| parameters: |{}|
                                            {
                                                "error": "Not Found", 
                                                "message": "This API does not exist", 
                                                "status": 404
                                            }
2020-11-17 18:37:45.002 T:140512751982336   DEBUG: CSettingsManager: requested setting (mute_notifications) was not found.
2020-11-17 18:37:45.002 T:140512751982336   ERROR: Traceback (most recent call last):
2020-11-17 18:37:45.002 T:140512751982336   ERROR:   File "/storage/.kodi/addons/plugin.video.twitch/resources/lib/twitch_addon/router.py", line 290, in run
2020-11-17 18:37:45.003 T:140512751982336   ERROR:     twitch_api = api.Twitch()
2020-11-17 18:37:45.003 T:140512751982336   ERROR:   File "/storage/.kodi/addons/plugin.video.twitch/resources/lib/twitch_addon/addon/api.py", line 46, in __init__
2020-11-17 18:37:45.004 T:140512751982336   ERROR:     if not self.valid_token(self.client_id, self.access_token, self.required_scopes):
2020-11-17 18:37:45.004 T:140512751982336   ERROR:   File "/storage/.kodi/addons/plugin.video.twitch/resources/lib/twitch_addon/addon/common/cache.py", line 104, in memoizer
2020-11-17 18:37:45.004 T:140512751982336   ERROR:     result = func(*args, **kwargs)
2020-11-17 18:37:45.004 T:140512751982336   ERROR:   File "/storage/.kodi/addons/plugin.video.twitch/resources/lib/twitch_addon/addon/api.py", line 52, in valid_token
2020-11-17 18:37:45.004 T:140512751982336   ERROR:     token_check = self.root()
2020-11-17 18:37:45.004 T:140512751982336   ERROR:   File "/storage/.kodi/addons/plugin.video.twitch/resources/lib/twitch_addon/addon/error_handling.py", line 81, in wrapper
2020-11-17 18:37:45.004 T:140512751982336   ERROR:     result = func(*args, **kwargs)
2020-11-17 18:37:45.004 T:140512751982336   ERROR:   File "/storage/.kodi/addons/plugin.video.twitch/resources/lib/twitch_addon/addon/api.py", line 98, in root
2020-11-17 18:37:45.005 T:140512751982336   ERROR:     return self.error_check(results)
2020-11-17 18:37:45.005 T:140512751982336   ERROR:   File "/storage/.kodi/addons/plugin.video.twitch/resources/lib/twitch_addon/addon/api.py", line 382, in error_check
2020-11-17 18:37:45.005 T:140512751982336   ERROR:     raise TwitchException(results)
2020-11-17 18:37:45.005 T:140512751982336   ERROR: TwitchException: {u'status': 404, u'message': u'This API does not exist', u'error': u'Not Found'}
2020-11-17 18:37:45.005 T:140512751982336   ERROR: Twitch: None

Full debug log available @idonerenop.kodi (paste)
Reply
#36
(2020-11-17, 20:33)kurai Wrote:
(2020-11-17, 20:13)chief27 Wrote: Getting errors trying to access the addon today. Havent changed anything with my setup. Error in Kodi says Failed to Connect to Twitch API. Nothing loads. Logs found here: LOG
Same error here - was working fine up to around 17:00 GMT.  Trying to browse/view streams after this time resulted in the "status: 404, This API does not exist" error.

Updated my OAuth key and reset the function/json cache just on general troubleshooting principle, but didn't help Wink

Can't see any notices/deadlines in the Twitch dev services about some API/call being deprecated today, so maybe it's just a temporary API service outage ?

We're two peas in a pod. Did the same troubleshooting steps and I always check the Twitch dev forums to see if the world is exploding before posting. Smile Didn't find anything. Twitch apps are working fine. Currently using my new Chromecast with Google TV and Twitch is running fine through there.
Reply
#37
(2020-11-17, 20:45)chief27 Wrote: We're two peas in a pod. Did the same troubleshooting steps and I always check the Twitch dev forums to see if the world is exploding before posting. Smile Didn't find anything. Twitch apps are working fine. Currently using my new Chromecast with Google TV and Twitch is running fine through there.
Two peas in a pod, indeed.
I also tried on Chrome WebBrowser & Amazon FireTV stick/Android phone/Samsung TV official apps and everything was behaving normally (albeit with more of the intensely irritating ads Tongue )

Update: Bug report has been raised on Github - I'm guessing that's you by the log snippet  : https://github.com/anxdpanic/Twitch-on-Kodi/issues/537
Reply
#38
Issue Resolved

Problem seems to have resolved it self as of ~23:00GMT here in the UK.
Live streams & VODs listing and playing normally.

Some people had no problem throughout, so presumably it was only part of Twitch's distributed/load-balanced CDN infrastructure that was temporarily b0rked.
Reply
#39
yes kurai was right. and the addon worked for me too yesterday after midnight.
unfortunatly the addon cannot connect to the twitch api again this afternoon.
Reply
#40
Twitch API response confirmed as broken once again here in the UK this evening.
Hope they get around to fixing it quicker this time  Tongue
Reply
#41
Yes broken here as well in the USA. This is the 3rd consecutive day in a row that Twitch stops working with the same API error.
"We won't tell you what to do, not to do or how to use our software." -DarrenHill
Reply
#42
(2020-11-11, 05:51)cage Wrote:
(2020-11-09, 06:31)neo_ Wrote: Anytime I get a mid-roll add, it keeps looping over and over again forever. It forces me to stop the stream and reopen it. If a dev wants the log, I can share. Though mid-roll adds haven't been occurring too often (luckily), it still happens once every couple hours if you're watching the right stream. To be clear, by mid-roll ads I mean ads that occur in the middle of a stream.

It was made pretty clear the the maintainer is not going to address this.

I was NOT complaining about Ads. I mentioned a problematic behavior involving Ads which I figured out was caused by using Adaptive on InputStream. If anyone has similar issues with Ads looping and/or freezing simply change the InputStream setting. I’ve seen quite a few people complain about this.
"We won't tell you what to do, not to do or how to use our software." -DarrenHill
Reply
#43
(2020-11-18, 22:08)neo_ Wrote:
(2020-11-11, 05:51)cage Wrote:
(2020-11-09, 06:31)neo_ Wrote: Anytime I get a mid-roll add, it keeps looping over and over again forever. It forces me to stop the stream and reopen it. If a dev wants the log, I can share. Though mid-roll adds haven't been occurring too often (luckily), it still happens once every couple hours if you're watching the right stream. To be clear, by mid-roll ads I mean ads that occur in the middle of a stream.

It was made pretty clear the the maintainer is not going to address this.

I was NOT complaining about Ads. I mentioned a problematic behavior involving Ads which I figured out was caused by using Adaptive on InputStream. If anyone has similar issues with Ads looping and/or freezing simply change the InputStream setting. I’ve seen quite a few people complain about this.

Glad to hear this is working for you.  The API error that is currently being spewed makes the addon unusable at this point in time.
Reply
#44
(2020-11-19, 06:22)cage Wrote:
(2020-11-18, 22:08)neo_ Wrote:
(2020-11-11, 05:51)cage Wrote: It was made pretty clear the the maintainer is not going to address this.

I was NOT complaining about Ads. I mentioned a problematic behavior involving Ads which I figured out was caused by using Adaptive on InputStream. If anyone has similar issues with Ads looping and/or freezing simply change the InputStream setting. I’ve seen quite a few people complain about this.

Glad to hear this is working for you.  The API error that is currently being spewed makes the addon unusable at this point in time.

Well aware, see my above post (#41).
"We won't tell you what to do, not to do or how to use our software." -DarrenHill
Reply
#45
(2020-11-19, 15:00)neo_ Wrote: Well aware, see my above post (#41).

I was never referencing this but ok.
Reply
  •   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 8
  •   



Logout Mark Read Team Forum Stats Members Help
Twitch.tv0
This forum uses Lukasz Tkacz MyBB addons.