•   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 8
  •   
Release Twitch.tv
#46
I can confirm the current API key is the problem as I fixed it (possibly temporarily) by using the FireFox Web Developer tools to extract the current api_token and auth_token from my logged in Twitch.tv account. I got the idea from this post, note that the current posted API key does not work. I am not a dev sharing a fix, but this is how I currently got it to work. For all i know the API Key now changes daily, so I don't know how well of a fix it is. But, at least it currently does work.

Edit: More information on what I did is available in the first link inside this post. If you want to manually edit the file, the file location varies on which operating system and distribution you use. For me on CoreELEC it was in /storage/.kodi/userdata/addon_data/plugin.video.twitch/settings.xml (Hint: create a backup). The proper fields are `private_oauth_clientid` and `private_oauth_token` Note: read below for info on the probably optional`oauth_token`field.

If you don't want to manually edit the file, the proper fields in the Twitch Kodi Add-on are in Settongs -> Login -> "OAuth Client ID" and "OAuth Token" (the OAuth Token field at the bottom, not top). I believe the top "OAuth Token" field is optional, for subscribers VODs and etc... but I always create one just in case. Simply click on "Get OAuth Token" and follow the directions.

*Note: I found that preroll ads work as intended instead of the ad template that shows. Haven't watched long enough to test midroll ads.

@cage you seem bewildered, hopefully this post helps your API problem.
"We won't tell you what to do, not to do or how to use our software." -DarrenHill
Reply
#47
(2020-11-19, 21:34)neo_ Wrote: @cage you seem bewildered, hopefully this post helps your API problem.

Not at all friend.  Not sure why you are obsessed with responding to all my posts.  Namaste.
Reply
#48
(2020-11-19, 22:13)cage Wrote:
(2020-11-19, 21:34)neo_ Wrote: @cage you seem bewildered, hopefully this post helps your API problem.

Not at all friend.  Not sure why you are obsessed with responding to all my posts.  Namaste.
I'm only responding as you're the one who originally replied to my post. Don't take life so seriously, no one makes it alive. Have a good one Smile
"We won't tell you what to do, not to do or how to use our software." -DarrenHill
Reply
#49
(2020-11-19, 22:25)neo_ Wrote: I'm only responding as you're the one who originally replied to my post. Don't take life so seriously, no one makes it alive. Have a good one Smile

Not sure why you are making assumptions about myself now.  As I said previously, Namaste.  Hope all your Kodi issues resolve themselves in a swift manor.
Reply
#50
Is there any chance to make a chat to work with this addon? I used it for a long time and now without chat, it's not the same experience. I'm already used to type with a gamepad, which I use to control Kodi for everything. Sure I can use my phone to read chat, but then I can't really follow stream then, so without chat I'll probably have to switch to watch streams in browser. I used Kodi mostly for twitch and youtube nowadays so if I can't watch twitch streams, Kodi lost like half of the functionality for me.

I used a workaround with browser cookie auth token, however recently that stopped working, I generated a new auth token through an addon, after that chat didn't work, so I generated a new OAuth token for a chat but that didn't solve the issue. Later I found out, that with a new token IRC.chat won't work at all, and I kinda lost the old token that way since I disconnected the app in twitch settings. Of course, I don't expect that anyone updates addons just because I need it Smile I just want to know is it really over, or there is hope. Thanks in advance for the information!
Reply
#51
I have an issue were I often can't get a connection to the twitch API. I need to try it 8 or 9 times until a request goes thru. This happens only when I use my Raspberry over the wireless bridge. When it is connected to the router via LAN it is working.
It feels like the majority of request imidiatly time out and only get thre when I am lucky. Once a streams is runnung over the wireless bridge, everything is fine and I can watch the stream without issues. Other network relateded services like 
scrapping Movie title or watching youtube is working without issue over the wireless brdige.

Is there a way to incress the timeout time inside the plugin or does anyone no a swtting for the wireless bridge configuration? I'm using openWRT on the raspberry side.

EDIT: After debugging the addon and finding that the actual erroro msg is "Failed to establish a new connection: [Errno 101] Network is unreachable" I googled around and found that a common problem is 
a proxy. After finding this is disabled the ARP Spoofing Protection in openWRT and now it's working. 

Thank you for coming to my TED Talk.

EDIT2: I was too early in my judgement and my first fix in the settings was a fluke. It worked for god know what reason and then it didn't. I love it when things work SOMETIMES.
Anyway, I dug a bit deeper and found that I think my wireless bridge is a bit slow when establishing a connection so by the time it connected to the wireless router, the plugin already threw an expection with
"Network unreachable". My solution was a little Continue in the Scrapper module in script.module.python.twitch, specifically in the download method.


for _ in range(MAX_RETRIES):
    try:
        headers.update({USER_AGENT: USER_AGENT_STRING})

        if isinstance(data, list):
            json_body = data
            data = None
        else:
            json_body = None

       response = requests.request(method=method, url=url, headers=headers, json=json_body, data=data, verify=SSL_VERIFICATION)
       content = response.content
       if not content:
           content = '{{"status": {0}}}'.format(response.status_code)
       break
    except Exception as err:
       continue #Skip the errors and try again
       if not isinstance(err, URLError):
           log.debug('Error |{0}| during HTTP Request, abort'.format(repr(err)))
           raise # propagate non-URLError
       log.debug('Error |{0}| during HTTP Request, retrying'.format(repr(err)))
else:
    raise ResourceUnavailableException('Max retries exceeded')

I know it is a hack, but it was actually a bit fun to find a fix, but is working so far for me. I basically skip any errors and try until my bridge is connected.
Reply
#52
EDIT: After debugging the addon and finding that the actual erroro msg is "Failed to establish a new connection: [Errno 101] Network is unreachable" I googled around and found that a common problem is 
a proxy. After finding this is disabled the ARP Spoofing Protection in openWRT and now it's working. 

Thank you for coming to my TED Talk.
Reply
#53
Hi,
When I play a Twitch stream it will start playing a ad placeholder video. After that it crashes Kodi about 90% of the time. Is this a known problem? I used to be able to watch Twitch with this addon without a problem for many years until about half a year ago.
I think the problems started when the ad placeholder video's are shown before the actual stream.
I am running Kodi on Windows 10.
Reply
#54
(2021-01-01, 20:58)SmellyCat Wrote: Hi,
When I play a Twitch stream it will start playing a ad placeholder video. After that it crashes Kodi about 90% of the time. Is this a known problem? I used to be able to watch Twitch with this addon without a problem for many years until about half a year ago.
I think the problems started when the ad placeholder video's are shown before the actual stream.
I am running Kodi on Windows 10.

I'm having the same issue on Linux Mint.

"Commercial Break in Progress" with a countdown in the lower right, countdown finishes and it goes to a black screen, then crashes to desktop.
Reply
#55
(2021-01-03, 19:15)micolithe Wrote:
(2021-01-01, 20:58)SmellyCat Wrote: Hi,
When I play a Twitch stream it will start playing a ad placeholder video. After that it crashes Kodi about 90% of the time. Is this a known problem? I used to be able to watch Twitch with this addon without a problem for many years until about half a year ago.
I think the problems started when the ad placeholder video's are shown before the actual stream.
I am running Kodi on Windows 10.

I'm having the same issue on Linux Mint.

"Commercial Break in Progress" with a countdown in the lower right, countdown finishes and it goes to a black screen, then crashes to desktop.
Solved it... I switched it away from Source to Adaptive in the settings on the general tab (but with use inputstream adaptive toggled off, because inputstream adaptive made one of my other plugins not work properly recently and I didnt want to go down that road again)
Reply
#56
For a few days i have noticed an issue. When trying to switch the channel in the primetime (19 - 22 o'clock) i will get an error saying: not found: [404] Api does not exist
When I stay on the very same channel. I can watch it the whole day. But if I do I get the error. Although  the channels are listed correctly and I can see the thumbnails are changing. But I have to wait after primetime to watch a stream again. Really weird. I dont know how I could describe it any better.
Reply
#57
(2021-01-14, 21:37)ninjafuchs Wrote: For a few days i have noticed an issue. When trying to switch the channel in the primetime (19 - 22 o'clock) i will get an error saying: not found: [404] Api does not exist
When I stay on the very same channel. I can watch it the whole day. But if I do I get the error. Although  the channels are listed correctly and I can see the thumbnails are changing. But I have to wait after primetime to watch a stream again. Really weird. I dont know how I could describe it any better.



Had the same issue between 20:00-23:00 CET (Kodi 18.2). Manually installing the latest dev version (2.0.16-dev) of script.module.python.twitch fixed the issue for me.
For more information: https://github.com/anxdpanic/Twitch-on-K...-758930864
Reply
#58
(2021-01-14, 22:57)nyx_ Wrote: Had the same issue between 20:00-23:00 CET (Kodi 18.2). Manually installing the latest dev version (2.0.16-dev) of script.module.python.twitch fixed the issue for me.
For more information: https://github.com/anxdpanic/Twitch-on-K...-758930864

The only thing this does is display a "Commerical break in progress" that loops for 5 seconds and crashes kodi.
Reply
#59
(2021-01-14, 22:57)nyx_ Wrote:
(2021-01-14, 21:37)ninjafuchs Wrote: For a few days i have noticed an issue. When trying to switch the channel in the primetime (19 - 22 o'clock) i will get an error saying: not found: [404] Api does not exist
When I stay on the very same channel. I can watch it the whole day. But if I do I get the error. Although  the channels are listed correctly and I can see the thumbnails are changing. But I have to wait after primetime to watch a stream again. Really weird. I dont know how I could describe it any better.

Had the same issue between 20:00-23:00 CET (Kodi 18.2). Manually installing the latest dev version (2.0.16-dev) of script.module.python.twitch fixed the issue for me.
For more information: https://github.com/anxdpanic/Twitch-on-K...-758930864
This worked for me thanks!

https://github.com/anxdpanic/script.modu....beta2.zip (as I'm using Kodi 18.9)
(Included in Nyx_ link https://github.com/anxdpanic/script.modu...2.0.16-dev in previous post)

Thanks!!
Reply
#60
(2021-01-15, 05:50)cage Wrote:
(2021-01-14, 22:57)nyx_ Wrote: Had the same issue between 20:00-23:00 CET (Kodi 18.2). Manually installing the latest dev version (2.0.16-dev) of script.module.python.twitch fixed the issue for me.
For more information: https://github.com/anxdpanic/Twitch-on-K...-758930864

The only thing this does is display a "Commerical break in progress" that loops for 5 seconds and crashes kodi.
I use adaptive and get the "Commerical Break in progress" wheel of death as it just keeps resetting the timer endlessly. However, if I manually chose the quality and select "source" I get the commercial break screen but at the end of the countdown it actually plays the stream.

The commercial break happens on every single stream I start even on streams that do not run commercials.  Is this the new norm for Twitch?
Reply
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 8
  •   



Logout Mark Read Team Forum Stats Members Help
Twitch.tv0
This forum uses Lukasz Tkacz MyBB addons.