v19 Extras Addon (Kodi 18/19 and on)
#1
With permission from the original author, I have taken over maintenance for this addon.  I've updated it for Kodi 19 and submitted it to the addon repo for approval, so hopefully it'll be available in a few days.

Please see the wiki page for instructions on setting up your Extras folder and tips on some stuff to add to your advancedsettings.xml so that Kodi won't try and add any extras to your library.

https://kodi.wiki/view/Add-on:Extras

One thing to note. The old version had an option to search YouTube for extras. It appears that never worked in Kodi 18 (even if you had the YouTube addon installed and properly configured), so that option was removed for this update.  I'm still trying to see if I can add it back at some point.
Reply
#2
pkscout:

Prior version of the add on would not work properly if in the settings you selected information when in a view instead of play. It would not play the extra with these settings. Is this something you can fix?
Reply
#3
(2020-08-30, 02:19)Edworld Wrote: pkscout:

Prior version of the add on would not work properly if in the settings you selected information when in a view instead of play. It would not play the extra with these settings. Is this something you can fix?
I see from the wiki that this is a known issue, and it's basically a core behavior from Kodi. If you select INFO for the default action for videos, I don't know of anyway to override that for one addon. So you either have to change the default action to PLAY or leave the default as INFO and when in Extras you have to use the context menu to select play.
Reply
#4
(2020-08-30, 03:36)pkscout Wrote:
(2020-08-30, 02:19)Edworld Wrote: pkscout:

Prior version of the add on would not work properly if in the settings you selected information when in a view instead of play. It would not play the extra with these settings. Is this something you can fix?
I see from the wiki that this is a known issue, and it's basically a core behavior from Kodi. If you select INFO for the default action for videos, I don't know of anyway to override that for one addon. So you either have to change the default action to PLAY or leave the default as INFO and when in Extras you have to use the context menu to select play.

I don't know how much time you want to put into it, but the old videoextras addon did not have this behavior.
Reply
#5
(2020-08-30, 04:13)Edworld Wrote:
(2020-08-30, 03:36)pkscout Wrote:
(2020-08-30, 02:19)Edworld Wrote: pkscout:

Prior version of the add on would not work properly if in the settings you selected information when in a view instead of play. It would not play the extra with these settings. Is this something you can fix?
I see from the wiki that this is a known issue, and it's basically a core behavior from Kodi. If you select INFO for the default action for videos, I don't know of anyway to override that for one addon. So you either have to change the default action to PLAY or leave the default as INFO and when in Extras you have to use the context menu to select play.

I don't know how much time you want to put into it, but the old videoextras addon did not have this behavior.
I suspect the old video extras addon was using direct calls to the Kodi Player object to handle the video execution on it's own rather than asking Kodi to do it.  I know sounds like the same thing, but trust me when I say, it isn't. I'm not saying no, but it would require almost a complete rewrite of the current addon to do it that way. The priority was to get Extras into Matrix so it didn't die a horrible, lonely death, and I have some other addons that need that attention too. But if things slow down, I will at least take another look at this issue.
Reply
#6
Thanks for taking over the maintenance of the Extras addon, your work is much appreciated.

However, I've run into the following issue whilst using the addon:

If you have a movie in a folder with special characters such as ü you will get the following error when trying to access the Extras folder from the context menu

Example: Say you have scanned the following movie into your library

smb://server/somefolder/Brüno/Brüno.mkv

When you try to access the Extras folder for this movie from the context menu you will get an error:

Checking the log it says something like:

Error Type: <type 'exceptions.UnicodeDecodeError'>
Error Contents: 'ascii' codec can't decode byte 0xc3 in position 23: ordinal not in range(128)

I've have version 1.3.3 for Leia installed which I believe is the latest version available.

Repeated on both Windows and Mac OS versions of Kodi 18.8
Reply
#7
(2020-09-09, 11:47)magisterv Wrote: Thanks for taking over the maintenance of the Extras addon, your work is much appreciated.

However, I've run into the following issue whilst using the addon:

If you have a movie in a folder with special characters such as ü you will get the following error when trying to access the Extras folder from the context menu

Example: Say you have scanned the following movie into your library

smb://server/somefolder/Brüno/Brüno.mkv

When you try to access the Extras folder for this movie from the context menu you will get an error:

Checking the log it says something like:

Error Type: <type 'exceptions.UnicodeDecodeError'>
Error Contents: 'ascii' codec can't decode byte 0xc3 in position 23: ordinal not in range(128)

I've have version 1.3.3 for Leia installed which I believe is the latest version available.

Repeated on both Windows and Mac OS versions of Kodi 18.8
Let me look into this.  I swear I tested exactly that issue before release, but it's possible I missed something.
Reply
#8
@magisterv it doesn't look like there is anything I can do about that.  I've tried for the last hour to encode, decode, un-encode, re-encode that unicode name any nothing works.  It looks like when the addon passes the string with the movie title in it, it does it in some "clever" way (and by that I mean too clever for it's own good) that strips any information about what *kind* of thing it is. So while I can rewrite the addon to not crash, when I do, any movie with an extended character in it lists no extras because the name the addon passes itself can no longer be converted back to the original.  Maybe someone else who understands the black magic that is unicode in Python 2 will have some other idea, but barring that I am stuck.

That's the bad news.  The good news is that it works fine in Kodi 19 (Matrix) because we are *finally* moving to Python3, and Python3 does a much better job with unicode.
Reply
#9
This is what I use for Leia for dirs an files since a long time ago and works perfectly:

Code:
        li = ListItem(unquote_plus(name))

edit: Forget what I said. It works for webdav sources (what I use) but it crashes from a smb share.
Reply
#10
(2020-09-09, 23:59)A600 Wrote: This is what I use for Leia for dirs an files since a long time ago and works perfectly:

Code:
        li = ListItem(unquote_plus(name))

edit: Forget what I said. It works for webdav sources (what I use) but it crashes from a smb share.

Thanks for the thought though. I have some other things on my plate right now, but I may look at a more complete rewrite that uses Kodi's virtual file system (if I can). That might resolve the issues on Leia.
Reply
#11
(2020-09-09, 23:41)pkscout Wrote: @magisterv it doesn't look like there is anything I can do about that.  I've tried for the last hour to encode, decode, un-encode, re-encode that unicode name any nothing works.  It looks like when the addon passes the string with the movie title in it, it does it in some "clever" way (and by that I mean too clever for it's own good) that strips any information about what *kind* of thing it is. So while I can rewrite the addon to not crash, when I do, any movie with an extended character in it lists no extras because the name the addon passes itself can no longer be converted back to the original.  Maybe someone else who understands the black magic that is unicode in Python 2 will have some other idea, but barring that I am stuck.

That's the bad news.  The good news is that it works fine in Kodi 19 (Matrix) because we are *finally* moving to Python3, and Python3 does a much better job with unicode.

No worries thanks for looking into it. I did manage to hack the master branch to work in Leia by changing the following in addon.py

line: 36 changed to
'path': extras_dir.encode('base64'),

line 38 changed to
'title': sys.listitem.getLabel().encode('base64'),

And the following lines in plugin.py

line 41 changed to:
current_path = args['path'][0].decode('base64')

line 73 changed to:
url = plugin.url_for(youtube, q=args['title'][0].decode('base64') + ' Extras')
Reply
#12
(2020-09-10, 02:40)magisterv Wrote:
(2020-09-09, 23:41)pkscout Wrote: @magisterv it doesn't look like there is anything I can do about that.  I've tried for the last hour to encode, decode, un-encode, re-encode that unicode name any nothing works.  It looks like when the addon passes the string with the movie title in it, it does it in some "clever" way (and by that I mean too clever for it's own good) that strips any information about what *kind* of thing it is. So while I can rewrite the addon to not crash, when I do, any movie with an extended character in it lists no extras because the name the addon passes itself can no longer be converted back to the original.  Maybe someone else who understands the black magic that is unicode in Python 2 will have some other idea, but barring that I am stuck.

That's the bad news.  The good news is that it works fine in Kodi 19 (Matrix) because we are *finally* moving to Python3, and Python3 does a much better job with unicode.

No worries thanks for looking into it. I did manage to hack the master branch to work in Leia by changing the following in addon.py

line: 36 changed to
'path': extras_dir.encode('base64'),

line 38 changed to
'title': sys.listitem.getLabel().encode('base64'),

And the following lines in plugin.py

line 41 changed to:
current_path = args['path'][0].decode('base64')

line 73 changed to:
url = plugin.url_for(youtube, q=args['title'][0].decode('base64') + ' Extras')
Thanks for working on that.  I'll make some time to test this on my end and, if all goes well, push out an update for Leia.
Reply
#13
Just FYI, there is an updated version of Extras for Kodi 18 (Leia) that should fix the crash when the movie has extended characters in the name.  @magisterv's fix didn't quite work for me, but it got me far enough along that I could beat on the encodings until some combination worked. Technically the Matrix version got upgraded too, but it was just a version number bump (no code changes) because the version in the Matrix repo has to be higher than the one in the Leia repo so that upgrades happen right when Matrix comes out.
Reply
#14
Since there is a new thread now I will try to move this post over to this thread:
Quote:maniyac Wrote: 
I have been a long time user of the previously banned extras addon, I found that it had some great features this one is missing. I was wondering if we can get some of its features into this addon, as it is officially supported:

1. "E" icon (or any identifiable icon) to display on media with Extras.

2. Option to display the extras menu when the media is completed.

3. Advance settings XML update button to stop extras media from being scanned to the library.

4. Compatibility of the above with popular skins like Aeon Nox Silvo.
Quote:pkscout Wrote: 
1. Adding any kind of icon to the movie listings would be dependent on skin authors adding the support for it. I'm not sure we'd get much interest in such a niche request, but if I get enough skin authors who express interest, I can look into it.

2. If I understand correctly, you want to watch the whole movie and then (with the correct option enabled) have the extras movie popup automatically.  This would require substantial work, as I'd have to add a service component that would watch when a movie is started and then also when it ends (and probably when people stop it before the credits are over).  No promises, but I'll look into it.

3. Rewriting the advancedsettings.xml would have to be done brute force and require a Kodi restart. The likelihood that the script could properly add the needed options to the literally infinite potential advancedsettings.xml files without damaging the file is somewhere between slim and none.  Given that, unfortunately people who want to use this addon are going to have to do that manually.

4. The answer to this is probably the same as #1.
I actually gave up on someone supporting this, hence the delayed reply but thank you VERY much from myself and the wider community.

In reply to your response.

1. This directed at Confluence and Estuary - default skins for Kodi. I personally only use Confluence because it's Fanart View for movies is the best layout with a large amount of information but no other skins seem to have it ;(. Does this make it more achievable?

2. Correct, just the menu with the available extras for selection (not an auto-play). Maybe have it pop up if the file is stopped within 15 minutes of the end runtime?

3. Completely understandable, this was more for ease for new users or ones on android devices but most people using this should be able to do basic modification of the advance XML

4. Would be great if we could get at least the top 3-5 skins on-board such as @mikeSiLVO and I see @wyrm (AppTV) is open to making it work so this could open up more skins to users with an Extras library.

As mentioned previously all of these features are taken from a now banned add-on that was able to achieve these functions. So the features should be doable but of course I understand it takes effort and time on your behalf and therefore any advancement on any of these points is much appreciated from me and the wider Kodi community, thank you again for your efforts.
Reply
#15
Hello everyone, i have a problem with addon Extras.

I have the following folder structure.
\\diskstation\Filme\Fifty Shades of Grey Geheimes Verlangen (2015)\VIDEO_TS\Extras\VIDEO_TS

Inside the video_ts folder is the content of the bonus dvd.

if i click on "Extras" i get an error.

Here the logfile

Also i have the following advancedsettings.xml in the userdata folder.

advancedsettings.xml

What do i wrong?

greetings
Reply



Logout Mark Read Team Forum Stats Members Help
Extras Addon (Kodi 18/19 and on)0
This forum uses Lukasz Tkacz MyBB addons.