Two player support - Refroplayer - Sega Genesis
I can't seem to find a way to configure two controllers. Is it supported? I've got two controllers plugged in, and both work to move around Kodi. They're XBox 360 controllers, and the lights on them show they've been picked up as two different controllers ok. Running any n of the Sega Genesis games only shows one controller, so only one player.

Can somebody point me to what I suspect is something obvious I'm missing?
Oops, forgot to say...
Pi4 8Gb
LibreElec + Kodi
RetroArch doesn't work on Pi4 ... even just opening a submenu from the main screen crashes it and dumps me back into Kodi, so I think I'll have to rule that out as an option.

Is there really no two player support in RetroPlayer? :-(
Been trying to figure this out for almost 6 hours now. Trying to decipher the source code but no idea what I'm looking for.

Have I done this so wrong? Should I have avoided LibreElec and gone for RetroPie!? I've spent almost a week getting everything working and building this setup. I'm really reluctant to admit defeat.
(2020-09-30, 21:16)Strela_9 Wrote: That's good to know, I was looking into a Raspberry Pi 4 for different reasons, and knowing that it doesn't RetroArch is an important factor.

It now does RetroArch. This is a KODI issue. The default menu driver just doesn't work when launched from Kodi. If you go in manually and change it from "ozone" to "xmb" it works flawlessly.

The setting is in retroarch.cfg which is in the game.retroarch folder inside addon_dara

I have the same exact config as you, Raspberry Pi 4 / 8GB and LibreELEC, and things can be made to work. I've been playing around with LibreELEC, Kodi/Retroplayer and Retroarch for a week now and here are my insights:

* Retroplayer works well with the exception of the fact that several controllers are not supported on SOME cores. Indeed with the Genesis core, only a single controller is supported as you mention, but I've tried with SNES core and it works well. It is strange because under Retroarch, the two controllers work perfectly fine with Genesis. For me this is a blocker, 
* There does not seem to be any MAME controller profiles on Retroplayer (no addons). So on MAME core my controller is not autoconfigured, this is a pain, also does not happen in pure RA.

About Retroarch on LibreELEC here are my insights:

* You have to change default theme to xmb, not ozone in the config file else it does not work.
* In my case I had to manually change the resolution and refresh rate (in config gile), else it would use my native 4K resolution but with 30Hz refresh rate which was a big issue. There's no point in using high resolution with RA / old games so I switched this to 1080p / 60Hz and it works fine (I had to turn on real full screen mode, not windowed mode so that RA would have control over my resolution).
* There were also a nasty bug in RA controller association code, where one of my PS4 controllers would be matched to a bad profile and the buttons would be reversed. The v1 controller got a good association but not the v2 controller. I've looked at RA source for this and clearly the matching code seems extremely strange (it matches on name, not vendor id and model id!!) and I am not surprised that those kind of bugs happened. I fixed it by deleting all the controller profiles manually except the ones I needed.
* Some of the cores don't work (they have undefined symbols). For instance SCUMMVM, Pico. When removing a core (addon) from Kodi, it also does not remove everything and the left overs can make OTHER cores bug. So I had to manually remove some files.

I have a question, is it normal than from RA on LibreELEC installing anything (cores etc) does not work at all? For me the only way to install is via Kodi add-ons interface.

Logout Mark Read Team Forum Stats Members Help
Two player support - Refroplayer - Sega Genesis0
This forum uses Lukasz Tkacz MyBB addons.