Kodi version check error
#1
Kodi 18.8 on nvidia shield tv
What is causing the error? Smile
Log here: Debug log
Reply
#2
Happens on Windows install too.
Reply
#3
.kodi/addons/service.xbmc.versioncheck/resources/lib/version_check/service.py", line 50
DISTRIBUTION = platform.uname().system.lower() AttributeError: 'tuple' object has no attribute 'system'

It's being caused by the new lines they added to this version of the file that weren't in the previous version (my guess is to eventually move away from the deprecated method mentioned in the lines above it). I just commented out lines 49 and 50 with the "#" character at the beginning of each and saved the file while I wait for them to fix it. The error went away.

edit the lines to look like this:
# if not DISTRIBUTION:
#    DISTRIBUTION = platform.uname().system.lower()
Reply
#4
It's already been reported and is being worked on:

https://github.com/xbmc/repo-scripts/pul...-704612430

https://github.com/xbmc/repo-scripts/pull/1707
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#5
Suddenly today I also started getting Version Check Error every time I start Kodi.
I'm running Kodi on Amazon Fire Stick 4K with Arctic Zephyr 2 skin.
Please advise.

Here is my log:

ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.AttributeError'>
                                            Error Contents: 'tuple' object has no attribute 'system'
                                            Traceback (most recent call last):
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/service.xbmc.versioncheck/resources/lib/runner.py", line 14, in <module>
                                                from version_check import service  # pylint: disable=import-error
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/service.xbmc.versioncheck/resources/lib/version_check/service.py", line 50, in <module>
                                                DISTRIBUTION = platform.uname().system.lower()
                                            AttributeError: 'tuple' object has no attribute 'system'
                                            -->End of Python script error report<--
Reply
#6
Starting Kodi (19.0-ALPHA1 (18.9.701) Git:19.0a1-Matri). Platform: FreeBSD x86 64-bit
addon id="service.xbmc.versioncheck" name="Version Check" version="0.5.8+matrix.1"

2020-10-15 18:23:19.748 T:101015   ERROR <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                   Error Type: <class 'AttributeError'>
                                                   Error Contents: module 'xbmcvfs' has no attribute 'translatePath'
                                                   Traceback (most recent call last):
                                                     File "/home/.kodi/addons/service.xbmc.versioncheck/resources/lib/runner.py", line 14, in <module>
                                                       from version_check import service  # pylint: disable=import-error
                                                     File "/home/.kodi/addons/service.xbmc.versioncheck/resources/lib/version_check/service.py", line 22, in <module>
                                                       from .common import ADDON
                                                     File "/home/.kodi/addons/service.xbmc.versioncheck/resources/lib/version_check/common.py", line 27, in <module>
                                                       ADDON_PROFILE = xbmcvfs.translatePath(ADDON.getAddonInfo('profile'))
                                                   AttributeError: module 'xbmcvfs' has no attribute 'translatePath'
                                                   -->End of Python script error report<--
                                                  
Reply
#7
(2020-10-15, 14:33)vgmedia Wrote: *snip*

Same here.
Reply
#8
@vgmedia

I have already reported your error a few days ago... https://github.com/xbmc/repo-scripts/pul...-709941892

Just waiting for @anxdpanic to check.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#9
Hi Karellen. Thank you very much for your help.
I have now rebuilt Kodi-matrix, updated to version Alpha-2 (I missed its release, thanks @pkscout for the hint). This solved all the problems. All the errors that I wrote about (version check and scrapers) disappeared.
Regards.
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi version check error0
This forum uses Lukasz Tkacz MyBB addons.