•   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 14
  •   
Broken Kodi 18.8.0 - Kodi fails to obtain images while scraping movies
Hello,

All the updates to the scraper addons seems to have resolved the missing image issues with scraping for movies and tv shows on my devices.  But on my Linux based devices, there is still the same issue with actor images, as well as posters on the actor info pages when it comes to what I believe is the built in ExtendedInfo part of the default interface. 

I will describe what I mean to be clear; when I display the info for a movie or tv show, the actor images are displayed in the top row.  When I cursor up on the actor, it goes to the actor's info page, which I believe is the ExtendedInfo script addon.  All the images on the actor info pages no longer display, and this stopped happening at the same time as the issue being discussed in this thread.  I use Kodi both on Windows and in CoreELEC.  The Windows version of Kodi does not have this issue.  It's only occurring on CoreELEC devices.

Can the Kodi devs tell me if this is a known issue that is going to be resolved in the next bug release of Kodi?  Or should I be asking the CoreELEC devs about this, as it's only a Linux issue with the actor info pages?

Thank you.
Reply
Thanks @Carey

I have reported the problem.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-10-17, 21:46)Karellen Wrote: You have to Refresh the show to download the new artwork links.

Are you saying I need to go into each movie and refresh it manually? This would take years...

How would I refresh all the videos in order to download the new artwork links?
Reply
(2020-10-18, 23:27)ioo+kod Wrote: Are you saying I need to go into each movie and refresh it manually? This would take years...

How would I refresh all the videos in order to download the new artwork links?

(2020-10-18, 01:37)Karellen Wrote:
Quote:I have the newest version of all the addon that were updated.. however, my kodi doesnt load any of the previuos images...is it possible to modify the db (with the normal sqlite editor) and make the change so that it pulls the images from tmdb? ..and if so, what command should I write into the sqlite editor?

Due to the size of my DB it is impossible to refresh or rescan each and every file.. Ive been working with it for 10 yrs
That is one of the issues we are trying to resolve. It will most likely result in an emergency release of Kodi for v18. A bit of patience, we are getting there Smile
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-10-18, 23:36)Karellen Wrote: That is one of the issues we are trying to resolve. It will most likely result in an emergency release of Kodi for v18. A bit of patience, we are getting there Smile

Okay so the only solution at the moment is to go to the info page for each entry and manually refresh to pull in the new data or to wait for a new solution to be announced in the future?

Does Kodi have a method to remove all of the existing scrapped data and re-scrap in a batch operation or is this the solution that is being worked on?

For example, I tried to go to Videos-> Media Sources, right click on the folder and select "Scan for new content" This doesn't work, nothing is updated.

I also tried to "Change content" from this same place but again nothing happens, in the log I just get this message:

2020-10-18 17:38:47.968 T:2972675168 WARNING: CGUIWindowManager - HandleAction - ignoring action 107, because topmost modal dialog closing animation is running
2020-10-18 17:39:00.364 T:2460901584 WARNING: Previous line repeats 9 times.

I restarted and tried a few times, always get the same result. So both of these methods don't seem to work. Is there something else to try or are there no other options at the moment?
Reply
(2020-10-18, 23:49)ioo+kod Wrote: Okay so the only solution at the moment is to go to the info page for each entry and manually refresh to pull in the new data
That is one solution

(2020-10-18, 23:49)ioo+kod Wrote: or to wait for a new solution to be announced in the future?
That is another solution

(2020-10-18, 23:49)ioo+kod Wrote: Does Kodi have a method to remove all of the existing scrapped data and re-scrap in a batch operation or is this the solution that is being worked on?
Yes. Change Content to None. Answer Yes to remove everything to clean Library. Now, go and run another Clean Library from the settings menu.
Change the content back to Movies/TV Shows and let it update the library.
This method is rescraping your Source so you may lose some personalised edits if you made any.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-10-18, 08:31)olympia Wrote: I just pushed v.5.4.2. Hopefully I have got all remaining http calls and switched to https.

With UMS 5.4.2 it worked fine for me: I've updated my Movies library and I've got my two new movies.

For me everything looks fine now! Thx!

Code:
2020-10-19 00:26:59.676 T:139735804712704 NOTICE: VideoInfoScanner: Starting scan ..
2020-10-19 00:27:02.805 T:139735804712704 NOTICE: VideoInfoScanner: Finished scan. Scanning for video info took 00:03

P.S: I'm not using ExtendedInfo Script.
Reply
I scraped some new files with UMS, and everything is working fine on my Linux machines and on my Android machines.. all new files show up nicely... Now I think we just have to wait for the change on the old stuff (I think its just one command to be sent to the DB and everything should be fine, but I dont know which command is it)
Reply
(2020-10-18, 01:37)Karellen Wrote: That is one of the issues we are trying to resolve. It will most likely result in an emergency release of Kodi for v18. A bit of patience, we are getting there Smile

After taking the time to get to the bottom of the problem ( here: https://kodi.wiki/view/Artwork ) I discover that the problem is much more complicated than it seems, and almost forces you to go back to the basic questions: what defines an artwork, from scraper view? If scraper would consider the url as the key of reference, it forces you to change paradigm. When a user has manually specified a reference, has kodi kept the specified text as is ? How else will kodi find the artwork ? If you have a link on the subject, I'll take it. In any case, I wish you all the best.
Reply
For those only with how to edit the database with sqlitestudio, I found a way to correct the posters not showing.

I dont know if it fixes the whole thing or just a bit.. but this might be a temporary solution in the time this gets a final solution

Go to sqlitestudio and Open SQL Editor
write in the blank editor window:

UPDATE art
SET url = REPLACE(url,"http://image.tmdb.org",'https://image.tmdb.org');

Press the execute query button and you're done

This made my DB show all the missing thumbnails Smile

Hope this works, however I ask the mods and everyone else if they feel this solution is not good or should not be out in the wild, you are free to delete this message (so people wont get confused etc) Smile
Reply
(2020-10-19, 16:42)vtwin0001 Wrote: For those only with how to edit the database with sqlitestudio, I found a way to correct the posters not showing.

I dont know if it fixes the whole thing or just a bit.. but this might be a temporary solution in the time this gets a final solution

Go to sqlitestudio and Open SQL Editor
write in the blank editor window:

UPDATE art
SET url = REPLACE(url,"http://image.tmdb.org",'https://image.tmdb.org');

Press the execute query button and you're done

This made my DB show all the missing thumbnails Smile

Hope this works, however I ask the mods and everyone else if they feel this solution is not good or should not be out in the wild, you are free to delete this message (so people wont get confused etc) Smile


My CLI version derived from this. You can run it in a bash terminal. Test before you run it. And have a backup. Otherwise, things might get weird. Worked for me, might not work for you.

sqlite3 MyVideosXXXX.db "UPDATE art SET url = REPLACE(url,'http://image.tmdb.org','https://image.tmdb.org')";
Reply
(2020-10-19, 21:41)nicgentile Wrote:
(2020-10-19, 16:42)vtwin0001 Wrote: For those only with how to edit the database with sqlitestudio, I found a way to correct the posters not showing.

I dont know if it fixes the whole thing or just a bit.. but this might be a temporary solution in the time this gets a final solution

Go to sqlitestudio and Open SQL Editor
write in the blank editor window:

UPDATE art
SET url = REPLACE(url,"http://image.tmdb.org",'https://image.tmdb.org');

Press the execute query button and you're done

This made my DB show all the missing thumbnails Smile

Hope this works, however I ask the mods and everyone else if they feel this solution is not good or should not be out in the wild, you are free to delete this message (so people wont get confused etc) Smile


My CLI version derived from this. You can run it in a bash terminal. Test before you run it. And have a backup. Otherwise, things might get weird. Worked for me, might not work for you.

sqlite3 MyVideosXXXX.db "UPDATE art SET url = REPLACE(url,'http://image.tmdb.org','https://image.tmdb.org')";
Same change done with phpmyadmin + removing texture13.db & "Thumbnails" folder  : still few movie posters are left blank, but problem is here by me since a long time.
Reply
(2020-10-19, 15:33)sksbir Wrote: what defines an artwork, from scraper view?
I'm not really sure what you mean here. What is "scraper view"?

(2020-10-19, 15:33)sksbir Wrote: How else will kodi find the artwork ?
Assuming you are scanning a movie into the library, the order of caching artwork is :
  1. Correctly named artwork saved to your local movie and tv show folders. Kodi will find and use this first. Links in the nfo file are not used, or if there is no nfo file, the scraper will scrape artwork links but will not use them.
  2. If you don't have local artwork, then the links in the nfo file are used or the scraper will download artwork links if an nfo file is not available.

The scraped artwork links are used in the Choose Art screen to change artwork.

I hope that answers your question. Sorry, but I am not really sure what actual question you were trying to ask. I assume when you say "user has specified a reference" you mean local artwork?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-10-17, 12:44)LuxTux Wrote:
(2020-10-15, 09:55)yasief Wrote:
(2020-10-15, 08:35)shmizan Wrote: on a side note, my PVR stopped working as well - fails to grab EPG and fails tp open live tv streams, with the same CCurlFile error.

+1 on that as well.
I can confirm that my pvr iptv simple client stopped working around the same time as this issue with the image scraping started.


Code:

2020-10-17 12:35:04.060 T:1504699104  NOTICE: Creating InputStream
2020-10-17 12:35:04.175 T:1504699104   ERROR: CCurlFile::FillBuffer - Failed: Failure when receiving data from the peer(56)
2020-10-17 12:35:04.175 T:1504699104   ERROR: CCurlFile::Open failed with code 0 for http://<Hidden URL>:
2020-10-17 12:35:04.187 T:1504699104   ERROR: CCurlFile::FillBuffer - Failed: Failure when receiving data from the peer(56)
2020-10-17 12:35:04.187 T:1504699104   ERROR: CCurlFile::Open failed with code 0 for http://<Hidden URL>:
2020-10-17 12:35:04.187 T:1504699104   ERROR: Open - failed to open source <http://<Hidden URL>>
2020-10-17 12:35:04.187 T:1504699104   ERROR: CVideoPlayer::OpenInputStream - error opening [pvr://channels/tv/All channels/pvr.iptvsimple_909110346.pvr]
2020-10-17 12:35:04.187 T:1504699104  NOTICE: CVideoPlayer::OnExit()
2020-10-17 12:35:04.209 T:1916225072  NOTICE: CVideoPlayer::CloseFile()
2020-10-17 12:35:04.209 T:1916225072  NOTICE: VideoPlayer: waiting for threads to exit
2020-10-17 12:35:04.209 T:1916225072  NOTICE: VideoPlayer: finished waiting

There is now a thread for that: https://forum.kodi.tv/showthread.php?tid=357766
Reply
(2020-10-20, 03:02)Karellen Wrote:
(2020-10-19, 15:33)sksbir Wrote: what defines an artwork, from scraper view?
I'm not really sure what you mean here. What is "scraper view"?

(2020-10-19, 15:33)sksbir Wrote: How else will kodi find the artwork ?
Assuming you are scanning a movie into the library, the order of caching artwork is :
  1. Correctly named artwork saved to your local movie and tv show folders. Kodi will find and use this first. Links in the nfo file are not used, or if there is no nfo file, the scraper will scrape artwork links but will not use them.
  2. If you don't have local artwork, then the links in the nfo file are used or the scraper will download artwork links if an nfo file is not available.

The scraped artwork links are used in the Choose Art screen to change artwork.

I hope that answers your question. Sorry, but I am not really sure what actual question you were trying to ask. I assume when you say "user has specified a reference" you mean local artwork?
Sorry for my poor English. I meant 'from the scraper's point of view', and when I was talking about the user giving a reference, it's when the file is misnamed and you have to give a keyword manually. On a large library, this happens quite often, and if the url has become the reference, then the manual entry of the keyword is lost. If it turns out that the URL is also unreliable, then you have a big problem on your hands.
Reply
  •   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 14
  •   



Logout Mark Read Team Forum Stats Members Help
Kodi 18.8.0 - Kodi fails to obtain images while scraping movies0
This forum uses Lukasz Tkacz MyBB addons.