•   
  • 1
  • 10
  • 11
  • 12
  • 13(current)
  • 14
  •   
Broken Kodi 18.8.0 - Kodi fails to obtain images while scraping movies
@Puppet-head

Different error. The images you are trying to download no longer exist. eg...
https://image.tmdb.org/t/p/original/mH6x...dZYvn1.jpg
http://image.tmdb.org/t/p/original/oai3x...7D0Yg0.jpg
http://cf2.imgobject.com/t/p/original/6S...XFAZGg.jpg

Most likely due to the mass artwork purge TheMovieDB conducted earlier this year.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-10-23, 17:52)gilsonsjc Wrote: is there a planned date for this 18.9 to go officially released?
It is progressing and should be out within the next few days, taking a few days longer again to publish in Playstore and Windows Store (because of their certification process)
Reply
Notice

v18.9 special release is now available.

https://kodi.tv/download
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
Hey All,
I updated to new kodi hoping it would fix my issue but it didn't.

The problem I am having is that I am trying to create a widget that only shows elements from a source (folder) (i.e Documentaries) but those thumbnails won't load.
The default widgets work fine. See screenshot:

https://i.imgur.com/ZnLLkwz.png

Hope someone can point me in the right direction
Reply
(2020-10-25, 06:59)Karellen Wrote: Notice

v18.9 special release is now available.

https://kodi.tv/download

Hello. I have installed it in my Shield 2019 and the missing thumbnails are still missing. Am I under the wrong assumption which says that kodi would "rebuild the missing movies thumbnails" automatically in this version or do I have to do something special to force the images to rebuild?

Here is the debug: https://paste.kodi.tv/gufatutasa
Here is a picture showing missing thumbnails. I was able to manually refresh one of them going into the Information menu. https://photos.app.goo.gl/gsNy11ZVkovxyzM36 

Thanks
Reply
@gilsonsjc

Looking at the log, there are many images that do not exist. eg...

http://image.tmdb.org/t/p/original/Af6Bn...8bOJcb.jpg
http://image.tmdb.org/t/p/original/3bQHH...2E9TSw.jpg
http://image.tmdb.org/t/p/original/gCQ4e...njiUIg.jpg
http://image.tmdb.org/t/p/original/plssy...eZB0yQ.jpg

and many more.

I am pretty sure that is your problem, not the recent http2 issue.

Though that does raise another question of where these came from. Are these movies you have had in your library for a while? Or have you rebuilt your library from nfo files that were created quite a few months ago or last year?

TMDB undertook a mass purge of artwork early this year, and your errors are typical of that. You will need to Refresh those movies to download the updated artwork links.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-10-27, 08:51)Karellen Wrote: @gilsonsjc

Looking at the log, there are many images that do not exist. eg...

http://image.tmdb.org/t/p/original/Af6Bn...8bOJcb.jpg
http://image.tmdb.org/t/p/original/3bQHH...2E9TSw.jpg
http://image.tmdb.org/t/p/original/gCQ4e...njiUIg.jpg
http://image.tmdb.org/t/p/original/plssy...eZB0yQ.jpg

and many more.

I am pretty sure that is your problem, not the recent http2 issue.

Though that does raise another question of where these came from. Are these movies you have had in your library for a while? Or have you rebuilt your library from nfo files that were created quite a few months ago or last year?

TMDB undertook a mass purge of artwork early this year, and your errors are typical of that. You will need to Refresh those movies to download the updated artwork links.
Hi - Yes, I had those movies in a while. I do not use .nfo files.  
What is the best way to run a batch refresh so Kodi would do all the movies with problems in a single run?

Thanks.
Reply
(2020-10-25, 06:59)Karellen Wrote: Notice

v18.9 special release is now available.

https://kodi.tv/download

Upgraded to 18.9 last week. So far, so good. All images (or most anyways) are populating just fine. Basically, it’s working like it did prior to the http2 change that caused the issue as far as i can tell now.
Reply
(2020-10-23, 21:00)Karellen Wrote: @Puppet-head

Different error. The images you are trying to download no longer exist. eg...
https://image.tmdb.org/t/p/original/mH6x...dZYvn1.jpg
http://image.tmdb.org/t/p/original/oai3x...7D0Yg0.jpg
http://cf2.imgobject.com/t/p/original/6S...XFAZGg.jpg

Most likely due to the mass artwork purge TheMovieDB conducted earlier this year.

Hmm.  Maybe this is why many (but not all) of my thumbnail/textures have disappeared when I upgraded to Leia 18.8 from Krypton.  Looking in the log files, there are lots of "404 Not Found" errors trying to update the cache.  But I don't understand why *all* of the textures don't have this problem.  About 90% of my thumbnails are found in local cache.  Can you point me to the thread that discussing this TMDB purge?  Thanks.
I guess I will post a new question about this but since I have not found any threads complaining about it, it may not be a general problem.
Current Kodi: 18.9, Mariadb running on Unraid server.
Reply
(2020-10-27, 13:45)gilsonsjc Wrote: Hi - Yes, I had those movies in a while. I do not use .nfo files.  
Ok, that will explain it. The errors are due to the mass artwork purge conducted by TheMovieDB earlier this year. Kodi is looking for the files, but they no longer exist at TheMovieDB.

(2020-10-27, 13:45)gilsonsjc Wrote: What is the best way to run a batch refresh so Kodi would do all the movies with problems in a single run?
You could Refresh each movie individually, but if this affects a lot of movies it will be time consuming.

Best to set the Source from Movies to None. Let it clean library.
Then add the Source back as movies and rescrape the source.
The downside to this is you will lose any customisations you made to your library, like movie sets. Playcounts should remain if you don't shuffle your files around.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-10-27, 21:05)CaptainTivo Wrote: Can you point me to the thread that discussing this TMDB purge? 
https://forum.kodi.tv/showthread.php?tid=353489
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-10-27, 21:12)Karellen Wrote:
(2020-10-27, 21:05)CaptainTivo Wrote: Can you point me to the thread that discussing this TMDB purge? 
https://forum.kodi.tv/showthread.php?tid=353489
Thanks.  It seems that they purged a ton of posters and either did not replace them or replaced them with lower quality so re-scraping does not seem like a good idea.
The thing is, I *have* all of the posters in my Thumbnails cache.  I just can't get at them in a useful way.  Apparently, the database is searched for a hash to the texture in the texture cache and if it is not found, then the cached URL is used, which, of course, points nowhere now.  I always thought that "backing up" by writing all the thumbnails into the source directories was just messy.  Now I am paying for that decision.  I am surprised that there was not more of an outcry when this happened as it really affects *everyone*.  

Apparently, this happened back in April.  I did not even notice it because all my thumbnails before that were cached and any I scraped after got the new textures from TMDB.  The problem occurred when I finally got around to updating from Krypton to Leia.  For some reason which I have yet to find, about 10% of my cached textures are not loaded when I select a movie.  Of course, the URL is bad so it can't update the cache.  I have to "Refresh" using the Info window.  This takes a long time (about 20 seconds) for each movie partly because it is manual and require a takes 5 keystrokes.  For some reason, once I select Yes, I want to refresh from the Internet, it takes about 10 seconds to respond.

So maybe I would be better off just re-scraping the entire movie collection (about 2000)?  Can I do this and still retain the watched, dates, times and other data?
Current Kodi: 18.9, Mariadb running on Unraid server.
Reply
(2020-10-31, 13:44)CaptainTivo Wrote: So maybe I would be better off just re-scraping the entire movie collection (about 2000)?  Can I do this and still retain the watched, dates, times and other data?
Be careful, I think the answer is no. Not a video expert, so wait for advice from others.
Reply
(2020-10-31, 13:44)CaptainTivo Wrote: Can I do this and still retain the watched, dates, times and other data?
Nope. There is no facility for selective scraping. It is all or nothing.

For you watched status and play counts you can use WatchedList addon. It works best when the library is correctly scraped and includes IMDB ID's as one of the UniqueID's... https://kodi.tv/addon/program-add-ons-sc...atchedlist

As for "other data" that will all be lost.

FWIW, I save my artwork locally first. I do this by going to TMDB and fanart.tv, and choosing my artwork, right-click, save as. Then I scrape my movie and immediately export to nfo files, make edits to the nfo file if needed. I do all this on my test setup, then I move it across to my HTPC and scan it into the library. Sounds like a lot of work, but it takes approx 2 minutes for a movie.
Now I am completely self-sufficient. I have all my data as I want it and the artwork I chose and no longer need to rely on remote sites.

Of course, doing that now for 2000 movies + tv shows is a bit much.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
Speaking of that.. is there any tool that could just rescrape the missing posters on a database and update it to live ones?
Reply
  •   
  • 1
  • 10
  • 11
  • 12
  • 13(current)
  • 14
  •   



Logout Mark Read Team Forum Stats Members Help
Kodi 18.8.0 - Kodi fails to obtain images while scraping movies0
This forum uses Lukasz Tkacz MyBB addons.