tmm v4 constantly starting (javaw.exe respawns again and again) after upgrade von v3
#1
Hi,
on a W10 64Bit computer, I did the upgrade via the upgrade button inside tmm.
Now, the splash screen is "blinking" and the taskmanager shows javaw.exe is opening another process, closes then and is respaned again. After a long long time, an Error Popup shows up.

The logs did not seem to catch this, because the popup came up at 23:04 and the log is from 20:24 but I uploaded it just for the record.

tmm.log
https://paste.kodi.tv/raw/pariyupoka

trace.log was too long to paste Sad so I removed all lines with .jpg in it..
https://paste.kodi.tv/raw/jazocasewi

Image
Image


EDIT:
After posting, I realized, GITLAB might be the better place for this issue (as there is no KODI connection).

IF there is an quick solution, please post it here, otherwise, I will open a Ticket at GITLAB...

Thank you!
Reply
#2
looks like you suffer from this (occasional) upgrade bug in Windows: please have a look at this thread - this solution should work for you too https://forum.kodi.tv/showthread.php?tid=357674
tinyMediaManager - THE media manager of your choice - available for Windows, macOS and Linux
Help us translate tinyMediaManager at Weblate | Translations at 66%
Found a bug or want to submit a feature request? Contact us at GitLab
Reply
#3
Thanks!
Now, that I have read that linked thread, I remember.... I had this some time ago.
The solution was as easy that time, but now, it dit not work out.
All 4 .exe are about 50k and I replaced the one you told.

This is how it looks like, when I start the new .exe:
Image

and after "OK"

Image
Reply
#4
looks like the new tmm installation does not find the shipped Java which should reside in the tmm subfolder /jre - it does try to start tmm via your installed Java (which is probably Java 8). 
If your installation is really borked pleasse try to new installation and copy over the data from the borked one: https://www.tinymediamanager.org/docs/upgrade-v4
tinyMediaManager - THE media manager of your choice - available for Windows, macOS and Linux
Help us translate tinyMediaManager at Weblate | Translations at 66%
Found a bug or want to submit a feature request? Contact us at GitLab
Reply
#5
Funny, there was no /jre inside /tmm folder.

So I copied the /jre folder from the tmm_4.0.4_win.zip and it seems to work now :-)

Good catch!
Reply



Logout Mark Read Team Forum Stats Members Help
tmm v4 constantly starting (javaw.exe respawns again and again) after upgrade von v30
This forum uses Lukasz Tkacz MyBB addons.