Problems accessing folders after new router - processing 0%
#1
Hi Guys,

Yesterday I installed a new router. After assigning all the devices new static ip addresses, both Kodi's are unable do access the folders on my NAS. Both are able to import the movie database; It's showing the 'in process movies' and 'newly added movies'.  However trying to access any folder and file results in a crash. If it doesn't crash it will mention that the folder doesn't exist. I am able to access the NAS folders on the Kodi pc with explorer so privileges shouldn't be the problem.  

Setup
- Database is MariaDB on Synology DS211. I created the database 2+ years ago. IP 192.168.1.8 (Former 192.168.1.103). Wired connection.
- I have two Kodi devices: a Windows 7 SP1 - Kodi 18.5 (192.168.1.12) and a LibreElec 9.2.4. (192.168.1.13). Both wired connected.

What have I done;
- Changed the advancedsettings.xml to new IP addresses
- Changed the sources.xml to new IP addresses
- Changed the privileges on Synology to new IP addresses
- Used the clear library function on Kodi

Both are able to import the movie database; It's showing the 'in process movies' and 'newly added movies'.  However trying to access any folder or file results in a crash. If it doesn't crash it will mention that the folder doesn't exist. I am able to access the NAS folders on the Kodi pc with explorer so privileges shouldn't be the problem. I can't figure out what the problem is. Can someone help me out? I've added the log.

https://paste.kodi.tv/rareyozitu.kodi
Kodi 18.5, LibreElec 9.2.4, Synology DS211, Tesla Model 3 Black. Amsterdam, Netherlands
Reply
#2
(2020-10-18, 00:52)TyKH Wrote: - Changed the sources.xml to new IP addresses
Answering a different question, but indirectly applies to your case. See here... https://kodi.wiki/view/Incorrect_and_mis...t_a_source
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
(2020-10-18, 00:55)Karellen Wrote:
(2020-10-18, 00:52)TyKH Wrote: - Changed the sources.xml to new IP addresses
Answering a different question, but indirectly applies to your case. See here... https://kodi.wiki/view/Incorrect_and_mis...t_a_source
I've tried your solution but it didn't work unfortunatly. It still resulted in a crash. Also, I updates the xml files after I was noticing that the library was not imported.
Kodi 18.5, LibreElec 9.2.4, Synology DS211, Tesla Model 3 Black. Amsterdam, Netherlands
Reply
#4
The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#5
Banned Addons have been removed. New kodi log;
https://paste.kodi.tv/xehujewabo.kodi
Kodi 18.5, LibreElec 9.2.4, Synology DS211, Tesla Model 3 Black. Amsterdam, Netherlands
Reply
#6
You missed a couple of them. Notice the orange-colored entries in the add-ons section... It's not just about repositories.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#7
@Klojum Thanks for the help. Was able to clear them all. New log:

https://paste.kodi.tv/akufuqapeb.kodi
Kodi 18.5, LibreElec 9.2.4, Synology DS211, Tesla Model 3 Black. Amsterdam, Netherlands
Reply
#8
So why didn't you keep the IP address of the NAS the same as before?
Any decent router has that functionality, and would have saved time and effort.

Apparently your database still has stuff based on the old IP address.

You could install the Video Database Cleaner add-on. Downnload the zip file and install it in Kodi.
It can also change paths stored in the video database.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#9
(2020-10-18, 08:50)Klojum Wrote: So why didn't you keep the IP address of the NAS the same as before?
Any decent router has that functionality, and would have saved time and effort.

Apparently your database still has stuff based on the old IP address.

You could install the Video Database Cleaner add-on. Downnload the zip file and install it in Kodi.
It can also change paths stored in the video database.
The IP address numbering was all over the place so this time I wanted to structure it bit more logical. I'll try the Add-On and report back.
Kodi 18.5, LibreElec 9.2.4, Synology DS211, Tesla Model 3 Black. Amsterdam, Netherlands
Reply
#10
1. I used the Add-On and it removed 1730 items. The Movie section is now empty, the serie section is filled but no episodes to be seen. The 0% processing is still occurring and if I check the logging I still see that other sections are still referring to the old IP.
2. I think my Kodi is botched; Whenever I exit, Kodi crashes. It also crashes when I want to add a source choosing NFS from the list (It doesn't even get to the actually listing of NFS sources). Also tried to uninstall the youtube addon as I'm no longer using. While saying the uninstall was done, the add-on was still present.

I figure it's maybe the best to reinstall a clean KODI, adding sources to build the database again. And then copy the advancedsettings and sources file to the raspberry. Any advice what is the best to do and how so?

Logfile:
https://paste.kodi.tv/itexilokoq.kodi
Kodi 18.5, LibreElec 9.2.4, Synology DS211, Tesla Model 3 Black. Amsterdam, Netherlands
Reply
#11
If you don't trust the contents of your mysql database anymore, it's best to start all over. Normally, with a good working setup, I'd do a Video Library Export from time to time, and create nfo files with all metadata and watched statuses as a backup, so the re-import will go a lot smoother. But that luxury is not always available.

If you still want to do some network IP address 'moving around' stuff in your router, then do it now. Such as fixating IP addresses for certain network devices, like the Synology NAS.

Use a MySQL tool (e.g. PhpMyAdmin), and 'drop' the current database(s). It's good to do some 'spring cleaning' from time to time anyway. No need to delete or change the sources.xml file if it contains all the correct sources.

Restart Kodi, confirm the content settings for each source, and let Kodi scan your media collection.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#12
Reporting back;

Everything works fine now. The complete reinstall of Kodi, dropping the tables and rescan did the job. Kodi also no longers crashes on exit.

I only have two scanning issues; It's unable to fully scan my Series folder, it fails to scan tv show is what i see in the Event log. Also some movies aren't recognized by the scraper while before it did. I'll have to take a closer look into that, it's unrelated to the issue discussed here. Thread can be closed in my opinion.
Kodi 18.5, LibreElec 9.2.4, Synology DS211, Tesla Model 3 Black. Amsterdam, Netherlands
Reply



Logout Mark Read Team Forum Stats Members Help
Problems accessing folders after new router - processing 0%0
This forum uses Lukasz Tkacz MyBB addons.