Solved Kodi 18.8 fails to load plugin.video.youtube on Fedora 32
#1
I have activated google accound to use Youtube on kodi. It works on Windows and Linux Mint.
On Fedora 32 which is up to date and kodi from RPM Fusion repo (normal way installing) , when I try to install the plugin via gui, i get an error, seems coming from io.py log : https://paste.kodi.tv/aboxakayog.kodi.
A way to debug more or solve the issue ?
Reply
#2
403 views and no response ?
Reply
#3
You may be better asking in the YT addon support thread - https://forum.kodi.tv/showthread.php?tid=356934
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#4
I was asking on the github (I'm registered) and got response to ask Kodi. Hope the ping pong will end a day.
https://github.com/anxdpanic/plugin.vide.../issues/34
As I understand now is that nobody is motivated to respond because it's Fedora...
Reply
#5
Does it import properly from CLI or does it throw an error there too ?

python2 -c "from _io import (DEFAULT_BUFFER_SIZE, BlockingIOError, UnsupportedOperation, open, FileIO, BytesIO, StringIO, BufferedReader, BufferedWriter, BufferedRWPair, BufferedRandom, IncrementalNewlineDecoder, TextIOWrapper)"
Learning Linux the hard way !!
Reply
#6
(2020-10-23, 15:07)enigma7 Wrote: As I understand now is that nobody is motivated to respond because it's Fedora...

Well, "io" is a standard python module, it should work regardless of distro.
However in your case it does not, and backtarce points to system python installation, I'd say that this question/bug should be directed to Fedora python maintainers.

EDIT: _io is the C part of the io module that should be built into python itself, something is very wrong with Fedora packaging of python27
Reply
#7
Thanks black_eagle .
The command you provided gives no error, nor output.

About the version :
python2
Python 2.7.18 (default, Sep 30 2020, 00:00:00)
[GCC 10.2.1 20200723 (Red Hat 10.2.1-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>
Reply
#8
No more ways to debug python and the famous DEFAULT_BUFFER_SIZE ?
Reply
#9
Upgraded to fedora 33 and got Kodi alpha3 this morning. Youtube is now loading and working . Solved
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi 18.8 fails to load plugin.video.youtube on Fedora 320
This forum uses Lukasz Tkacz MyBB addons.