Xbox Series X Won't play back H265 4k content
#1
Just picked one up yesterday and everything is working fine outside of playing back H265 4k content.  The app just completely crashes when I go to play anything back.  Every other video source I've thrown at it is working fine but this has me stumped.  It appears like it could be a DX driver issue which would make some since with the new hardware only being released.

Here is my log
https://paste.kodi.tv/awicunilev.kodi

Thanks for any help
Reply
#2
I can’t help, but I have the same issue.
Reply
#3
It might be because Kodi doesn't (or isn't allowed?) access the whole system.

The specified device interface or feature level is not supported on this system.
Reply
#4
(2020-11-12, 12:24)Hitcher Wrote: It might be because Kodi doesn't (or isn't allowed?) access the whole system.

The specified device interface or feature level is not supported on this system.

As a side note I did play back the same files in VLC on the series X, so I'm thinking the access's may be there. Should I submit a bug report (and does the log have enough data in it)?
Reply
#5
(2020-11-12, 15:49)imimmortl Wrote:
(2020-11-12, 12:24)Hitcher Wrote: It might be because Kodi doesn't (or isn't allowed?) access the whole system.

The specified device interface or feature level is not supported on this system.

As a side note I did play back the same files in VLC on the series X, so I'm thinking the access's may be there. Should I submit a bug report (and does the log have enough data in it)?
I've had the same issue, moving from a One X to Series X.
Reply
#6
(2020-11-12, 15:49)imimmortl Wrote:
(2020-11-12, 12:24)Hitcher Wrote: It might be because Kodi doesn't (or isn't allowed?) access the whole system.

The specified device interface or feature level is not supported on this system.

As a side note I did play back the same files in VLC on the series X, so I'm thinking the access's may be there. Should I submit a bug report (and does the log have enough data in it)?

Disable DXVA in the settings, then you have the VLC experience. Might stutter a log, though.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#7
Another log example https://paste.kodi.tv/luruzujane
Reply
#8
(2020-11-12, 19:50)fritsch Wrote:
(2020-11-12, 15:49)imimmortl Wrote:
(2020-11-12, 12:24)Hitcher Wrote: It might be because Kodi doesn't (or isn't allowed?) access the whole system.

The specified device interface or feature level is not supported on this system.

As a side note I did play back the same files in VLC on the series X, so I'm thinking the access's may be there. Should I submit a bug report (and does the log have enough data in it)?

Disable DXVA in the settings, then you have the VLC experience. Might stutter a log, though.

Disabling dxva didn’t fix it.
Reply
#9
(2020-11-13, 12:06)Raging10 Wrote:
(2020-11-12, 19:50)fritsch Wrote:
(2020-11-12, 15:49)imimmortl Wrote: As a side note I did play back the same files in VLC on the series X, so I'm thinking the access's may be there. Should I submit a bug report (and does the log have enough data in it)?

Disable DXVA in the settings, then you have the VLC experience. Might stutter a log, though.

Disabling dxva didn’t fix it.

I have the same issue and also, disabling dxva didn't solved it for me.
Reply
#10
In my case (XBox One X though), activating "Adjusting display refresh rate" leads to video stutter and delays in starting videos, so I kept it off. I've also experienced issues with activating "Sync playback to display", so I keep it off as well. All workarounds though. I know that @jogal fixed several bugs in the Windows (UWP) implementation in recent months. As such, it is probably worthwhile to retest all this once Matrix releases.
Server: DIY NAS w/ i3-8100, 32GB RAM, 4x6 TB WD Red, DD Cine S2 + 3xDuoFlex, OMV w/ Emby, TVheadend, Oscam
Living Room: Odroid N2 w/ CE, Panasonic DP-UB9004, NAD 758v3, LG OLED 65 B7, L/R B&W CM10, B&W C S2, B&W ASW10 CM, SL/SR Elac WS 1445, HL/HR Dali Alteco C1
Library: RPi2B w/ LE, Xbox One X w/ Kodi, Nintendo Switch, Panasonic Viera TX-P50 Plasma​​
Reply
#11
(2020-11-13, 18:55)M4tt0 Wrote: In my case (XBox One X though), activating "Adjusting display refresh rate" leads to video stutter and delays in starting videos, so I kept it off. I've also experienced issues with activating "Sync playback to display", so I keep it off as well. All workarounds though. I know that @jogal fixed several bugs in the Windows (UWP) implementation in recent months. As such, it is probably worthwhile to retest all this once Matrix releases.

Kodi ran fine on my Xbox one X. Something going on with the series x.
Reply
#12
Hello, 

Same problem there. Kodi was perfect on my Xbox One X (2160p + TrueHD / 2160p + DTS-HD / 2160p + AC3 ...), but since I have and installed Kodi on my new Xbox Series X, only the HD and SD videos are good. All the 2160p doesn't work anymore, the software crash each time I try to play a video in 4K ... I hope there will be an uptade soon for this wonderful software ! Wink
Reply
#13
(2020-11-14, 17:06)filipandman Wrote: I hope there will be an uptade soon for this wonderful software

Willing to donate a Series X to a dev?
Reply
#14
Same issues, kodi crashes with 4k content. Following.
Reply
#15
Looks like several users are having the issues.  Should a issue ticket be submitted?
Reply



Logout Mark Read Team Forum Stats Members Help
Xbox Series X Won't play back H265 4k content0
This forum uses Lukasz Tkacz MyBB addons.