•   
  • 1
  • 28
  • 29
  • 30(current)
  • 31
  • 32
  • 35
  •   
Release HBO Max
Try Use the subtitle and audio settings inside the addon itself.

Eg. Default subtitle: cs
Reply
(2022-04-14, 00:20)Kravatak76 Wrote: and what the Preferred subtitle language => MyLanguage means and I mean that MyLanguage, so in my case does that mean Czech?
In HBO Max addon settings, under Playback -> Default Subtitle -> put your language name (Czech in your case) as it is displayed in Subtitle settings when playing a Video.
After that, when playing some video if there are 3 languages listed, English, Italian and Czech, choose Czech and confirm with "Set default for all media".
(All language names mentioned are when in "Settings-HBO Max -> Look & Feel -> Language" is set to English, and Kodi interface language is also set to English)
Reply
In the addon settings, you ways use the 2 letter code. Eg. cs

That will then by default enable any cs subtitles.
Reply
(2022-04-14, 09:16)matthuisman Wrote: In the addon settings, you ways use the 2 letter code. Eg. cz

Is there a list of shortcuts for all subtitles? Is it taken from this list https://en.wikipedia.org/wiki/List_of_ISO_639-1_codes
If not which is for German and Croatian?
Does code name depend on which language is chosen for addon default language?
Reply
Yes, my addons use ISO 639-1

German is de
Czech is actually cs
Reply
sorry guys, I've tried this before. I set in the add-on default audio - en, default subtitles - cs, still not working, subtitles are still off ... in the subtitle settings during playback I see selected subtitles Czech-cz, but the option to turn on the subtitle is turned off, if I set anything anywhere and nothing works ... I don't understand what the problem is with this add-on, when I don't have any problems with the others.
Reply
(2022-04-15, 01:00)Kravatak76 Wrote: sorry guys, I've tried this before. I set in the add-on default audio - en, default subtitles - cs, still not working, subtitles are still off ... in the subtitle settings during playback I see selected subtitles Czech-cz, but the option to turn on the subtitle is turned off, if I set anything anywhere and nothing works ... I don't understand what the problem is with this add-on, when I don't have any problems with the others.

It seems to me that it's not an addon problem, but more likely Kodi problem, since once the stream starts, addon is "out of the way", all then is on Kodi...
If it were any problem related to HBO Max addon, more people would have such a problem.

I ask again, which version of Kodi and on which device and OS are you using this addon? Have you tried with a fresh installation of another Kodi version?
Besides that, I presume that without (debug)logs nothing can be done to get to the root of the problem...
Reply
@Kravatak76

Kodi settings > player > subtitles > original language

HBO Max > settings > look & feel > language > čeština
HBO Max > settings > player > default audio > original
HBO Max > settings > player > default subtitle > cs

If kodi 18 (not needed for 19+):
HBO Max > settings > player > audio allow list > original
HBO Max > settings > player > subtitle allow list > cs

I have tried these and works great. CS subs enabled by default.
only annoying thing is when the audio is CS, it will also enable CS subs.
I need a checkbox to allow "Dont enable subs if audio language same" or something like that. But not a huge deal
Reply
@matthuisman interesting, when I set it exactly the same, it already works: The question is which of those options caused the subtitles to turn on. it certainly wasn't HBO Max> settings> look & feel> language> čeština, because I then changed this option back to english and the subtitles still work. So I guess it was caused by a change in Kodi settings> player> subtitles> original language, because I had the original Czech there and somehow I don't understand why the original language should be there, it's illogical, but mainly that it works and thank you very much for the help.

Aren't you considering adding an intro skip option when HBO Max allows it?


I might ask if you know how to save an Osmosis watchlist from HBO Max to the Kodi Library, which contains both series and movies. So far, I only have series there, but I would also like to add movies, but HBO Max has only one watchlist in common.
Reply
@matthuisman a quick question regarding high bitrate h265 streams:
On my Firestick 4K with latest Nexus nightly I tried to watch "King Richard" movie with highest 1080p quality; the stream is 11.5 Mbit/s h265 and I only get DD+ audio but no video/picture. If I choose next lower bitrate, 10.2 Mbit/s h265 with DD+ everything works OK. As it's not my internet speed since it exceeds 300Mbit/s measured in Kodi on the FS 4K, where should I look for this limitation?
Is it processing power of my FS 4K, or is Kodi h265 decoder, or something else? Will Kodi log show the culprit, or should I collect debug log?
Reply
@Kravatak76
The Kodi subtitle language to original is what would have fixed. Basically Kodi doesn't know these streams were actually Czech. I think it looks for a certain string or something. Can't remember. Anyway, it was unreliable. That's why my addons have that setting in first place. They actually go and mark the streams as default in the manifest forcing Kodi to select them basically.

I can look into skip intro. I've opened a GitHub issue here to remind me https://github.com/matthuisman/slyguy.addons/issues/180

No idea what osmosis is so won't be supporting. Eventually I hope to add an export to library function.

@Sholander
Not sure sorry. Im pretty sure it's a limitation in inputstream adaptive or the hardware. It basically can't keep up. I thought it had been improved in Kodi 20 and latest inputstream on that. Make sure your running IA 20
Reply
(2022-04-15, 22:35)matthuisman Wrote: Make sure your running IA 20

Yes, I'm running latest inputstream.adaptive-20.1.2.
Reply
can you do full res ok if you disable dolby audio?
Reply
No, chosen audio does not make any difference.
Another thing with this movie (King Richard) is wrong aspect ratio displayed on FS/Nexus; the movie is in 21:9 (2.37:1) but it's displayed in 16:9 (1.77:1) ratio.
(On Nexus nightlies video corrections (Pixel format, zoom, etc) don't work so cannot fix the ratio)
Haven't tried how it's displayed in stable Matrix, where it is possible to fix such display errors with "Pixel format" values. Will try tonight with a fresh installation of official Kodi 19.4, how it works...
Reply
OK, tested with fresh official Kodi 19.4 playing "King Richard" movie, with results:
1. No picture on best quality stream (11.55 Mbit/s h265) no matter which audio is preselected. Limiting bandwidth to 11.0 Mbit/s in the addon, stream plays with 10.2 Mbit/s h265 and everything works OK. I have to choose DD+ to avoid subtitle flicker. Looks exactly the same as on Kodi 20a Nexus. So, Firestick 4K is probably not powerful enough for best stream.
2. The movie is displayed in proper aspect ratio 2.35:1. So wrong aspect ratio (1.77:1) displayed in Nexus is probably due to alpha Kodi version...

One more thing, on both Kodi versions if I choose AC3 (best audio option) audio stream is not recognised/properly displayed in "Player process info" overlay and I get subtitle flicker. Probably also due to underpowered Firestick 4k...
Reply
  •   
  • 1
  • 28
  • 29
  • 30(current)
  • 31
  • 32
  • 35
  •   



Logout Mark Read Team Forum Stats Members Help
HBO Max0
This forum uses Lukasz Tkacz MyBB addons.