v18 Playback problems and slow/unresponsiveness on 18.9 with 4K HDR files
#1
I recently purchased a Shield 2019 (tube) to play my local video files which are located on my NAS. I use Kodi 18.9 as a player. Mostly, playback is working fine. But with some files (most of them large 4K HDR files with TrueHD or DTS-HD audio), everything on Kodi, and the Shield itself as well, just becomes unresponsive and slow. I'm not talking about playback of the videofile itself or anything to do with resolutions or refresh rates.

What I mean is: if I select the 4K HDR file to start playing, often the first 10-15 seconds everything is just very choppy and unresponsive. Video and audio or both are very choppy and often the video speeds up to catch up to the audio. Then after it catches up, sometimes it just works and keeps on playing. But if I then try to pause it, or skip ahead or whatever, it again becomes very slow and unresponsive. And then sometimes Kodi just completely freezes and returns me to the homescreen of the Shield while my remote no longer works. Or the screen stays paused or becomes completely black and the Shield freezes and the remote doesn't do anything anymore, not even the shutdown or the settings button on the remote. I have to wait for it to reboot or do it manually myself with the button on the Shield itself. Other times, the playback does continue smoothly but then sometimes it just randomly starts getting choppy at some point in the video and the same problems occur; slow and unresponsive if I try to pause it or skip ahead/back and freezing Kodi and/or Shield.

I tried multiple types of files and it mostly seems to happen with 4K HDR files:
  • 4K HDR with DD+ lower bitrate audio often has these problems
  • 4K HDR with TrueHD higher bitrate audio often has these problems
  • 1080p files with high bitrate TrueHD audio doesn't have these problems and work very smoothly
This is my setup:
  • Shield 2019 (tube version)
  • Shield is connected to my home network with a cat6 ethernet cable
  • Synology NAS has all my videofiles and is also connected with a cat6 cable
  • I tested my local network speeds with iperf3 and all connections are around 900-950 Mb/s, so I don't think my local network is the problem
  • Shield is connected with a hdmi 2.0 cable to my soundset, which is in turn connected to my LG C7 tv with a hdmi 2.0 cable to passthrough video. (the soundset can passthrough 4k, hdr and dolby vision)
  • Kodi 18.9 is installed with the skin Embuary
Here is my logfile: https://paste.kodi.tv/pofaluqiva

Since I found some 'ActiveAE - large audio sync error' lines in the log, I searched for it and found this other thread, where someone had a similar issue and solved it by increasing the video cache size.
I did that as well and added this code to my advancedsettings.xml to increase the video cache to 125MB.
Quote:<cache>
   <memorysize>131072000</memorysize>
</cache>

At first, this seemed to have solved the problem where most 4K HDR files started playing smoothly. But quickly, I still encountered the problem, although in general the problems with choppy playback, audio catching up to video and slow/unresponsive UI did seem to be less bad. Last night, a 4K HDR videofile I played suddenly started having these problems midway through the file, while the beginning was smooth. It completely froze my Kodi/Shield and I had to reboot the Shield since the remote didn't do anything anymore. So this morning I tried the same videofile again, and it played smoothly so far. But this shows it doesn't always have to start happening in the beginning, but can also randomly happen during a video.

So while it does seem to have improved by increasing the videocache size, it is still occurring. How is this happening? When I was still using my TV's internal video player (before I got the Shield), every 4K HDR file was working perfectly, so I just can't imagine it has something to do with my local network or hdmi cables. Can someone help me try to fix this? Thanks!
Reply
#2
The 'tube' version only has 2GB RAM. I replaced mine with the Pro version and it plays them fine.
Reply
#3
Okay, well my other thread got deleted. I thought since I got no specific answers here, I'd want to switch to another device. But the Shield pro is too expensive for me, so I thought opening another thread in the hardware forum would be the way to go. Apparently not, so there's the same question:


Firstly, 2GB should be more than enough for a 4k HDR stream I would think? Especially if my local network speed is around 900 Mb/s.

So after increasing the video cache size, the problem was less bad, but still there randomly (it seems?) on 4K HDR files. I then added another line to my advancedsettings.xml to increase the readfactor to 25. Again, it improved the issue, but it isn't 100% gone.
I don't know how it can happen, but sometimes playback and the UI work very smoothly on 4K HDR files, but other times on the same file, everything gets choppy and unresponsive and one or multiple of these issues still occur;
  • playback gets very choppy; video has to catch up to the audio (mostly at the start of the video, but sometimes also at random moments)
  • pausing or skipping freezes the UI or becomes very slow and unresponsive
  • the shield remote randomly stops working, but my TV's remote through CEC does still work (how ??) --> restart of shield is necessary
  • kodi crashes back to the main menu of the shield and I often have to wait for it to recognize the remote again

Does anyone know what else I could try?

I'm getting pretty fed up with all these random issues. I just can't get it to work 100% smoothly. Sometimes it works, but other times the same 4K HDR videofile is giving me major problems like described above. Are buggy playback of 4K HDR files, crashes of Kodi and problems with the Shield remote known problems for the Shield 2019 tube version?

I can still return it free of charge, and I'm thinking of getting another device like the Vero 4K+ or the Odroid N2+.  How smooth are these other devices? Or is another device recommended? What I would want in another media player:
  • completely smooth playback of 4K HDR files with HD audio on Kodi through ethernet
  • a fast and snappy UI that does not freeze or crash
  • hdmi CEC so I can control it with my LG TV's remote, also with wake-on-cec so when I select the hdmi input the device automatically starts
  • being able to map red/green/yellow/blue or other buttons on my LG magic remote to functions like play, pause, etc
Reply
#4
(2020-11-21, 19:55)Hitcher Wrote: The 'tube' version only has 2GB RAM. I replaced mine with the Pro version and it plays them fine.
bdmv structure works fine, m2ts and remux mkv not.
I have the tube version too, only for local playback, it's not competent to the task.
Reply
#5
I've noticed the same issue with a few files on my 2015 shield pro with kodi 18.9. Upgrading to a v19 nightly got rid of those issues here.
Reply
#6
Im sitting in the same boat like @illuvattarr

Bought the tube cause ive meant its enough for me. Mostly the same specs. But it seems there are more differences, 1GB Ram smaller, no 64bit ROM etc. Coming from a 40€ chinabox with CoreELEC which running very good, but also has 2GB RAM. So im a bit disapointed with that higherprice device.

Tried over SMB connections and after that via NFS, its all the same. Kodi closes after starting some movies, or it began to be very unsnappy whilest playing some movies. Not all the time, but mostly on DolbyVision content via ExoPlayer. But tried also the latest Matrix Beta with some MP4 Demos, its unplayable via DolbyVision. Here are some lines of Kodi Logs, or here a bit longer.

Tried also Plex where Frameswitching vie ExoPlayer works correctly, on Kodi or my side it does not, but it has also the buffering probs. Whilest playing a demo etc. i can see the buffering line which is a bit infront. But after some seconds it stay still and then it hangs, it buffers again and after some seconds it hangs again.

Ive tested also my LAN speed via iperf3, same results like the OP - 900-950MBits. And im having the same issue with SHIELD remote which dont work anymore somtimes but the remote of my TV (LG B7) works via SHIELD. Maybe there are some bugs in latest FW from Nvidia. Didnt tested the 8.2.0 before after ive bought the SHIELD. Im on latest 8.2.1.
Reply
#7
I noticed this recently myself. I have a 2017 Shield. I attempt to play a movie within Kodi and it freezes randomly. I can play the same movie file in VLC on the shield with no problems at all. 

Considering bumping up to one of the nightlies to see if it makes any difference.
Reply
#8
(2020-12-01, 08:35)Flosshit Wrote:
(2020-11-21, 19:55)Hitcher Wrote: The 'tube' version only has 2GB RAM. I replaced mine with the Pro version and it plays them fine.
bdmv structure works fine, m2ts and remux mkv not.
I have the tube version too, only for local playback, it's not competent to the task.

I'm not playing remuxes though, just 4K HDR encodes of varying bitrates. It even has problems with lower bitrate ones.

Tomorrow I'm gonna give kodi 19 a shot, but if that doesn't work I'm returning it and getting an odroid or vero 4k+.
Reply
#9
I'm trying to install the kodi 19 beta version apk 64 bit on the Shield. But I just can't get it to install. All filebrowsers give the error 'app not installed' and they all have the right permissions.
Reply
#10
The Tube dont have 64bit support. Use 32bit arm7 builds. One of the differences between the "Pro" and the "Tube".
Reply



Logout Mark Read Team Forum Stats Members Help
Playback problems and slow/unresponsiveness on 18.9 with 4K HDR files0
This forum uses Lukasz Tkacz MyBB addons.