Very slow to load TMM
#1
I have been using TMM for a few years and have noticed that the recent (2020-'ish) versions have been very, very slow to load with starting the program.  I have a lot movies in my collection (1000+) but I had over 1000 last year too and TMM was not near as slow then as it is now.  I have always ran TMM from a NAS drive, i.e. the TMM directory is located on a NAS drive and I run the program by running "tinyMediaManager.exe" from the NAS.  It literally takes upwards of 3-4 minutes to load the UI.  Any ideas?  I would like to continue having the TMM db on the NAS so that I can access it from multiple computers on my network.  thanks in advance for the help.
#2
did you check how the memory usage of tmm is? (settings - general - show memory usage (at the bottom)). Maybe you hit the default memory limit of tmm and the garbage collector has too much to do freeing memory.

on my notebook I have a test installation with 3500 movies and I am fine with the default memory settings (512M)... I can imagine what else could slow down loading. are you already on 4.0.5? there has been a huge loading boost for large libraries with a lot of tags
tinyMediaManager - THE media manager of your choice - available for Windows, macOS and Linux
Help us translate tinyMediaManager at Weblate | Translations at 66%
Found a bug or want to submit a feature request? Contact us at GitLab



Logout Mark Read Team Forum Stats Members Help
Very slow to load TMM0
This forum uses Lukasz Tkacz MyBB addons.