•   
  • 1
  • 56
  • 57
  • 58
  • 59(current)
  • 60
  •   
Beta Testflight access to beta version
(2022-07-17, 19:41)Buschel Wrote: Perfectly prepared, looks good: https://abload.de/img/bildschirmfoto2022-07i1jy1.png

Yeah! Smile
Reply
1.11 build 3406
Release Notes

- Fixes a crash seen several times since 1.9 (related to PVR station list update)
- Fixes moving "Edit" button and wrong transparency in custom button view (@amasephy, this was reported by you a while back)
- Adds feature to disable auto-colored UI (falls back to grey) (@howie-f, this one you were looking for)
- Adds new codec icons for VP8 and VP9 (@UlfSchmidt, this adds the icons you provided)
Reply
Thanks Buschel,

I see the edit button moving doesn’t happen anymore.

In regards to the transparency I don’t remember what that issue was. I just read the GitHub issue and I still can’t recall or even tell what exactly it’s referring to.
Reply
Thanks for testing. The transparency issue was happening when adding enough custom buttons to reach the bottom of the screen. In this case the they were visible in the safe area below the edit button.
Reply
Ah yes now I recall. There were some areas in the app where the space was properly masked out and others where the list items would scroll below the mask and become visible below it.
Reply
Buschel,

I just noticed something, not sure if it’s an app issue or some add on I’m missing. When I go to the library data provider in the TV shows section of the app I get this error.

Image

Also, when I clear that error and stay on that screen the cancel button for the search bar has the light theme applied to it making it difficult to see.

Image
Reply
@amasephy, I confirm this (never entered this plugin so far). This issue shows also for older versions of the App, it is not a regression of any kind. The code and the API requests the App sends to Kodi server look correct. Even if I strip down the API request to the bare minimum (asking simply for the directory content of this plugin without any sort or filter) the error pops up. I will ask in the JSON API part of the forum.

Positive side effect: I found an issue in the error message which I could now fix. Smile

Edit: Created a thread in the Development/JSON area -> https://forum.kodi.tv/showthread.php?tid=369077

Edit 2: In the thread linked above a solution and screenshots of the App showing the content is given. The issue is caused by the add-on itself and can be fixed via a change in the add-on scripts.
Reply
Ok good to know. I assume the add on will be fixed eventually.

Thank you for taking the time to write up the issue in the other thread.

We’re you able to confirm the cancel button styling in that second screenshot? It’s pretty tough to even see the cancel button in it.
Reply
(2022-07-29, 03:09)amasephy Wrote: We’re you able to confirm the cancel button styling in that second screenshot? It’s pretty tough to even see the cancel button in it.
Oh, I was not checking this yesterday. This is confirmed, and I just fixed this. Now the searchbar is not even shown per default (you need to pull down like everywhere else). The color of the searchbar is now also correct in this case.
Reply
(2022-03-31, 07:09)Buschel Wrote:
(2022-03-31, 02:12)jcea Wrote: Selecting a TVShow contextual menu and pressing "mark as watched" or "mark as not watched" does nothing at all. I am running Kodi 19.4 (as OSMC in a Raspberry PI).
Thanks for your feedback. I also tested this (iPhone iOS 15.4 and iPad iOS 14.5 simulator against Kodi 19.4 on Linux) for the banner view, the poster list view, the poster grid view and for episodes. This works for me as well.

I can only reproduce such behaviour, if I am already in the app's TV show menu (seeing the banners/posters) and then disconnect Kodi server (e.g. shutting down the device which runs Kodi or ending the Kodi server application). In this case nothing happens when setting a TV show as watched or unwatched, and selecting a TV show results in an error ("Not connected"). Can you please double check if the connection is still established? Which version of the App are you using exactly (iPhone: click on the Kodi icon in the navigation bar of the server list menu, iPad: click on the Kodi icon on the lower right)?
Using 1.11 (3406) I can't seem to mark an entire TV show as (un)watched. At the episode level mark as (un)watched works correctly.
Reply
Hmm, I now see this failing as well. Use case: 
1. Ensure you have an unwatched TV Show (TV Show and episodes are "unwatched").
2. Longpress on this TV Show and set to "Watched"
3. Refresh TV Shows
4. TV Shows falls back to "Unwatched"
5. Enter the Episodes and check them 
6. Episodes still show "Unwatched"

This is the same even when testing older version of the App (e.g. 1.10.1, 1.10, 1.9 or even 1.6). I am testing with Kodi 19.4.

I am somehow quite sure this worked before. Which version of Kodi do you use?

Edit:
The JSON command sent to Kodi seems correct: {"jsonrpc":"2.0","method":"VideoLibrary.SetTVShowDetails","params":{"tvshowid":11, "playcount":1}, "id":2}
The API also responds with "OK".

@howie-f, you think you can double check this one on the Kodi side?
Reply
Really interesting. The Remote App's code to set a whole TVShow as watched/unwatched since ages uses "VideoLibrary.SetTVShowDetails". In comparison, the Chorus Web Interface in this case calls "VideoLibrary.SetEpisodeDetails" for each episode inside the TV Show. Question is: Was setting the playcount via "VideoLibrary.SetTVShowDetails" ever working and is this the desired way? Or will this need to be removed from the App and the App also needs to set playcount for each epsiode?

Edit: I provided a draft PR (#700) which resolves this. I am not sure, if this is a Kodi server issue and this needs to be fixed, or if the App shall change the implementation.
Reply
(2022-08-02, 19:19)Buschel Wrote: Edit: I provided a draft PR (#700) which resolves this. I am not sure, if this is a Kodi server issue and this needs to be fixed, or if the App shall change the implementation.

It hasn’t worked for me (previously using the iOS App Store (version 1.10) on CoreELEC Kodi versions 19.0-19.4 (current).

I also just tested a fresh Kodi 18.9 install on Nvidia Shield (Android TV) and it didn’t work there either. Will keep an eye out for the next TestFlight build.

Thanks for the quick reply and PR!!
Reply
Ok, thanks for testing this on older Kodi versions. This looks like setting playcount for a whole TV Show via "VideoLibrary.SetTVShowDetails" is not desired to work. Funnily enough the API responds with "OK". I opened a thread in the JSON API area of the forum and asked which is the correct implementation for this use case (Setting playcount for a complete TV Show).

What bugs me is that I was sure I was seeing this working before.
Reply
1.11 build 3417
Release Notes

This build has a few fixes and translation updates.
Reply
  •   
  • 1
  • 56
  • 57
  • 58
  • 59(current)
  • 60
  •   



Logout Mark Read Team Forum Stats Members Help
Testflight access to beta version0
This forum uses Lukasz Tkacz MyBB addons.