OS X Stream Video Files from MacBook through Android TV app
#1
Hi everyone!

I'm new to Kodi and slowly figuring out how to set everything up. I'm having trouble getting video files from my hard drive to stream on the Android TV Kodi App after setting up a video source.

I turned on File Sharing on my Macbook and was able to add the SMB as a Video Source on Kodi. They seemed to have connected, as all the video files on my hard drive are appearing on the TV. But when I select a video file/press play, nothing happens. I'm able to scan into my library, but for some reason, the stream isn't working. The Permissions for the shared folder (and enclosed items) allow my User to Read & Write, and that User is linked with the SMB server. It lists the file size, but isn't detecting the resolution/dolby audio/etc. 

I was able to plug a USB into the back of the TV and test a video file, which worked. Would rather stream from the HDD itself, though! I looked at SMBUp but it says it needs to be updated.

Any help would be appreciated! I feel like I've gone as far as I can with this: https://kodi.wiki/view/Adding_video_sources
Reply
#2
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.
4.Upload the log to Kodi Paste Site manually or use the Kodi Logfile Uploader. (wiki) With either method post the link to the log back here.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file (wiki)

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Use the Kodi Paste Site. Post the link to your pasted log in the forum
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#3
(2021-01-14, 03:08)Klojum Wrote: To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.
4.Upload the log to Kodi Paste Site manually or use the Kodi Logfile Uploader. (wiki) With either method post the link to the log back here.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file (wiki)

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Use the Kodi Paste Site. Post the link to your pasted log in the forum

Thanks for your reply. Here is the link for the Kodi Log: https://paste.kodi.tv/konuyaruya.kodi
Reply
#4
set both min/max SMB connection type to v1 in Settings - Services - Samba
Reply
#5
(2021-01-14, 11:46)kambala Wrote: set both min/max SMB connection type to v1 in Settings - Services - Samba

That seemed to do the trick! I thought SMB v1 wasn't recommended?

I'm getting intermittent audio stutter when using passthrough. I need to use passthrough for 5.1, correcct?
Reply
#6
(2021-01-14, 17:23)icansee4miles Wrote: That seemed to do the trick! I thought SMB v1 wasn't recommended?

true, but so far this is the only solution for 10.15 and higher
Reply



Logout Mark Read Team Forum Stats Members Help
Stream Video Files from MacBook through Android TV app0
This forum uses Lukasz Tkacz MyBB addons.