Weird seek bar bug in live PVR
#1
Hi,

I'm pretty new to kodi and currently on my way to replace my main driver for live PVR with a kodi/tvheadend Solution. After LOTS of searching I think I'll settle to Amber as my main skin. really like the look and feel and customizabillity.

But, I encountered a weird Bug in the seek bar, that only happens in live PVR Mode with full osd (enter key on my keyboard). That's the mode where the buttons are displayed in the lower part and the seekbar on top.

I took some pictures running kodi in Mac OS. But the behaviour is the same on all my test computers including RPI3/4. It's just much simpler to test and take screenshots in Mac OSX Smile

ImageImage

This Picture is showing the problem. In this mode (full OSD) i get two position indicators (dots) one of which is moving "randomly" about once a second. It almost feels like showing the buffer state or preloading, but not exactely.

While this show the OSD in "info" mode (pressing the i key)

Image

Only one indicator shown.


Unfortunately I'm very new to Skin and KODI but I'm pretty good at Python,XML, .... So I can also look into this myself but maybe some hints would help pointing in the right direction. Like what File to look at and what might be the difference in the two modes on the seek bar ?


Or, Maybe, this is a known bug with a known fix ?

Stefan
Reply
#2
(2021-01-26, 10:13)leika Wrote: Hi,

I'm pretty new to kodi and currently on my way to replace my main driver for live PVR with a kodi/tvheadend Solution. After LOTS of searching I think I'll settle to Amber as my main skin. really like the look and feel and customizabillity.

But, I encountered a weird Bug in the seek bar, that only happens in live PVR Mode with full osd (enter key on my keyboard). That's the mode where the buttons are displayed in the lower part and the seekbar on top.

I took some pictures running kodi in Mac OS. But the behaviour is the same on all my test computers including RPI3/4. It's just much simpler to test and take screenshots in Mac OSX Smile

ImageImage

This Picture is showing the problem. In this mode (full OSD) i get two position indicators (dots) one of which is moving "randomly" about once a second. It almost feels like showing the buffer state or preloading, but not exactely.

While this show the OSD in "info" mode (pressing the i key)

Image

Only one indicator shown.


Unfortunately I'm very new to Skin and KODI but I'm pretty good at Python,XML, .... So I can also look into this myself but maybe some hints would help pointing in the right direction. Like what File to look at and what might be the difference in the two modes on the seek bar ?


Or, Maybe, this is a known bug with a known fix ?

Stefan
I had some more time and I may have found the issue. The Handling in DialogSeekBAr.xml seems to be correct but there is a second seekbar implemented as part of VideoOSD.xml which is overlapping and seem to have the wrong seek positions. I think that one is left over from earlier kodi versions.

For now i removed that instance and keep the one from SeekBar.xml which seemed to have fixed it for me.
Reply
#3
(2021-01-26, 18:45)leika Wrote:
(2021-01-26, 10:13)leika Wrote: Hi,

I'm pretty new to kodi and currently on my way to replace my main driver for live PVR with a kodi/tvheadend Solution. After LOTS of searching I think I'll settle to Amber as my main skin. really like the look and feel and customizabillity.

But, I encountered a weird Bug in the seek bar, that only happens in live PVR Mode with full osd (enter key on my keyboard). That's the mode where the buttons are displayed in the lower part and the seekbar on top.

I took some pictures running kodi in Mac OS. But the behaviour is the same on all my test computers including RPI3/4. It's just much simpler to test and take screenshots in Mac OSX Smile

ImageImage

This Picture is showing the problem. In this mode (full OSD) i get two position indicators (dots) one of which is moving "randomly" about once a second. It almost feels like showing the buffer state or preloading, but not exactely.

While this show the OSD in "info" mode (pressing the i key)

Image

Only one indicator shown.


Unfortunately I'm very new to Skin and KODI but I'm pretty good at Python,XML, .... So I can also look into this myself but maybe some hints would help pointing in the right direction. Like what File to look at and what might be the difference in the two modes on the seek bar ?


Or, Maybe, this is a known bug with a known fix ?

Stefan
I had some more time and I may have found the issue. The Handling in DialogSeekBAr.xml seems to be correct but there is a second seekbar implemented as part of VideoOSD.xml which is overlapping and seem to have the wrong seek positions. I think that one is left over from earlier kodi versions.

For now i removed that instance and keep the one from SeekBar.xml which seemed to have fixed it for me.
@leika, thank you for bringing this up and for looking further into it. I will fix the video OSD in the next skin update.

Regards,

Bart
Reply
#4
@leika , this is fixed in version 3.2.126 (Leia) and 3.4.13 (Matrix).  Please test and let me know if it is indeed fixed.  Thanks.

Regards,

Bart
Reply



Logout Mark Read Team Forum Stats Members Help
Weird seek bar bug in live PVR0
This forum uses Lukasz Tkacz MyBB addons.