Win Milkdrop viz crashing v19 RC1 playing music
#1
RC1 Crashing playing music. Has happened 3 times. Actually causing tv to shut down. Giving me crash.dmp file too. Not sure how to send that

Log file. Crash at very end
Reply
#2
Can you disable the Milkdrop visualisation you are using to see if that makes any difference.
Reply
#3
(2021-02-03, 20:48)jjd-uk Wrote: Can you disable the Milkdrop visualisation you are using to see if that makes any difference.

I need to do some more testing. I think it may have been an HDMI handshake issue. Looks like the TV was turning itself off because of an incorrect signal from computer. Happened in several different apps, so it may nod be Kodi that is causing problem. Will try again later today or tomorrow to see if it is still happening. Unplugged TV for 60 seconds and everything seems to be working now. More to follow. Thank you.

Without Milkdrop the music player is useless to me, as I have an OLED and as you know can't leave images on the screen for very long because of burn it. Mildrop is a must to listen to music.
Reply
#4
I only meant to temporary disable Milkdrop and then test music playback as Visualisations have been know to crash Kodi in the past, and I see some errors loading the visualisation settings.
Reply
#5
(2021-02-04, 16:36)jjd-uk Wrote: I only meant to temporary disable Milkdrop and then test music playback as Visualisations have been know to crash Kodi in the past, and I see some errors loading the visualisation settings.
There is something definitely going on with Kodi. Got 16:48 minutes of play with milk drop on then crashed and turned off tv again. Restarted and disabled milk drop, went to exit and kodi locked up. Had to reboot to get out. This happened the other day too.
Reply
#6
I'm going to move this post across to our Music forum and perhaps @DaveBlake can take a look at the log.
Reply
#7
(2021-02-05, 15:34)jjd-uk Wrote: I'm going to move this post across to our Music forum and perhaps @DaveBlake can take a look at the log.

Update, disabled Milkdrop. Went for 18:06 before tv shut off again. When I put it back on, music still playing. NOT a kodi issue apparently. HDMI issue between TV and computer.
Reply
#8
Are you getting crash.dmp files everytime? Best way to share those would be via Google Drive, Dropbox, Onedrive or similar. But wait for Dave to respond, as those will be no use for me, to see if he thinks they'll be useful. In the meantime could you get another debug log file as I couldn't see much wrong in the first one, but before you do so I see a lot of Library update process going on, so if the have Update library on startup enabled for Video & Music could you turn them both off temporary before you generate a new log just to try and get a cleaner log without all the update stuff going on, then once you've done the log you can turn them back on.
Reply
#9
(2021-02-05, 15:44)acemt Wrote:
(2021-02-05, 15:34)jjd-uk Wrote: I'm going to move this post across to our Music forum and perhaps @DaveBlake can take a look at the log.

Update, disabled Milkdrop. Went for 18:06 before tv shut off again. When I put it back on, music still playing. NOT a kodi issue apparently. HDMI issue between TV and computer.

Thanks for your reply's on this. I am finding that a lot of people have issue with LG tv's turning off/onn. Weird part is mine is just turning OFF, never back on. And only with Computer connected and active. Shield on other input never causes this problem. Gotta love computers!
Reply
#10
Amd video card?

i have comparable issues, a new setup with amd rx 5600xt and lg oled. Need to do direct hdmi connection to tv due to av processor only being hdmi 1.4. Causes wasapi initialisation issues. Was able to solve it for dolby/hd formats for movies/series but not for flac. Funnily enough no crashes for music with jriver on same machine. On my odroid n2 corelec box also no issues. Mysterious.
Reply
#11
(2021-02-05, 21:22)Littletycoon Wrote: Amd video card?

i have comparable issues, a new setup with amd rx 5600xt and lg oled. Need to do direct hdmi connection to tv due to av processor only being hdmi 1.4. Causes wasapi initialisation issues. Was able to solve it for dolby/hd formats for movies/series but not for flac. Funnily enough no crashes for music with jriver on same machine. On my odroid n2 corelec box also no issues. Mysterious.
Actually Nvidia 1080. I did hard reset, and today it is working okay again. Problem is, it only seems to last a day. I did roll back drivers as I had updated them about same time I installed soundbar. Will report back in a few days.
Reply
#12
@KevinSartori acknowledging your PM, however the logs are of no use to me as it requires a dev, for example @DaveBlake to take a look them. Please do not use PM's to report issues, use the appropriate public thread and if you have privacy concerns about sharing logs then say so and someone will reach out if they have the time to take a look.

For the benefit of everyone including DaveBlake

Quote:Hi,

I wanted to send you a message regarding music playing with Milkdrop crashing my system too. I'm running Windows 8.1 x64 on an Intel NUC with Kodi v19 "Matrix" Release Candidate 1. Like user ACEMT, I have an OLED as well and I haven't tried playing music without also Milkdrop running. Because he didn't upload a crashlog, I thought I'd send you mine through a private message to not clutter up the forum.

How long Kodi will run before it crashes can vary from 5 or 10 minutes to hours. It's strange and seemingly random.

Here's the crashlog:
REDACTED

I don't know if this helps, but here's the kodi.old.log too:
REDACTED

I'm not sure if this is related, but I've noticed another strange thing since moving from 18.9 to 19 RC1. When first boot up and select Party Mode, music plays and it goes to Milkdrop, but the screen is dimmed with a spinning blue circle on top. Music will keep playing and Milkdrop is running, but the blue circle doesn't go away. I have to launch Party Mode, hit the stop button, and then relaunch Party Mode for everything to work fine.

One last thing, I posted a few weeks ago asking about there being no Milkdrop 2 for 19 RC1 and you replied "It's currently not building and is being looked at." Any updates there?

Thanks!
Reply
#13
@acemt and @KevinSartori what do you have Output Configuration in audio settings set to? see https://kodi.wiki/view/Settings/System/A...figuration

If either of you are using Best Match could you try Optimised.

In your case @KevinSartori as it's working through Party Mode playlist for each item there is a pattern of

xml:
2021-02-05 13:26:04.003 T:2948 INFO <general>: PARTY MODE MANAGER: Adding randomly selected song at 9:[musicdb://songs/5448.mp3]
2021-02-05 13:28:51.540 T:1604 INFO <general>: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder mp3float
2021-02-05 13:28:51.702 T:1604 INFO <general>: AudioDecoder: File is queued
2021-02-05 13:28:51.718 T:1604 INFO <general>: PAPlayer:TonguerepareStream - Ready
2021-02-05 13:28:56.388 T:884 INFO <general>: PAPlayer:TonguerocessStream - Stream Finished

however on last track to start shortly before stopping

xml:
2021-02-05 13:28:56.415 T:2948 INFO <general>: PARTY MODE MANAGER: Adding randomly selected song at 9:[musicdb://songs/17480.mp3]
2021-02-05 13:28:56.517 T:104 WARNING <general>: xbmc.translatePath is deprecated and might be removed in future kodi versions. Please use xbmcvfs.translatePath instead.
2021-02-05 13:32:30.360 T:896 INFO <general>: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder mp3float
2021-02-05 13:32:30.505 T:896 INFO <general>: AudioDecoder: File is queued
2021-02-05 13:32:30.520 T:3040 INFO <general>: CActiveAESink::OpenSink - initialize sink
2021-02-05 13:32:30.553 T:896 INFO <general>: PAPlayer:TonguerepareStream - Ready

There's that additional Opensink message which makes me wonder if it has different audio properties to all the other tracks which would force sink to reopen if using Best Match.
Reply
#14
Also to both of you I understand your burn in concern.

If either or both of you have the time, please set aside an hour for testing (@KevinSartori you haven't said what to the maximum time you have to wait for a crash)

Note: this request is only for your period of testing, once you've finished testing then you can revert back to your previous settings.

Please disable Visualisations

Image

Then to prevent any risk of burn in while doing test set up screensaver to kick in a Black screen after 1min (unfortunately 1 min is the lowest wait time)

Image

Then see if you get past the maximum time you've had to previously wait for a crash.

That is all I can come up with for the moment unless DaveBlake has any better ideas.
Reply
#15
Quote:I haven't tried playing music without also Milkdrop running
Well @KevinSartori you log shows errors related to the Milkdrop viz, so it is quite likely that is the source of the crashes. Try disabling it and see if the crashes go away.

If we can prove the crashes are connected to the viz then we can ask the author to investigate, it could be an issue with graphics driver and addon interacting. It could also be interesting to switch to the default skin Estuary and see if you still have an issue.
Reply

Logout Mark Read Team Forum Stats Members Help
Milkdrop viz crashing v19 RC1 playing music0
This forum uses Lukasz Tkacz MyBB addons.