Kodi 18.9 & TV Headend New Install Ubuntu
#1
Bit of a linux noob but having trouble with installing Kodi 18.9 and the TVHeadend kodi client on Linux Lite (Ubuntu).

Want to stay with 18.9 as have a variety of Kodi installs around house (2 x OSMC on Raspberry Pi, couple of Windows PCs and now a low powered old minipc running Linux Lite) which can only currently run 18.9.

If I follow the normal method to install Kodi on the Linux box (sudo apt-get install software-properties-common,  sudo add-apt-repository ppa:team-xbmc/ppa,  sudo apt-get update sudo,  apt-get install kodi) I get version 19, so instead installed by using the ppa:team-xbmc/kodi-old respository, which installs 18.9 fine. I then try to install the TVHeadend addin (kodi-pvr-hts), but receive an error. If I reenable ppa:team-xbmc/ppa, I can then download & install the TVHeadend addon, but it does not show in Kodi at all - there is no entry from PVR clients in My Addons at all.

I know this is a bit vague, but any ideas where I am going wrong?
Reply
#2
The pvr addon from 19 is likely an api mismatch and not recognized in 18.9.  Also python 3 instead of 2. 

You'll need to purge version 19 packages and install 18.9 from old.  Not sure why hts pvr won't install.  You'll need to post a debug log to have someone determine the issue.

I have 19 installed on test machine but having crashes  so holding off on upgrade as well until I can sort the issues with 19.
Reply
#3
(2021-02-27, 21:21)bluzee Wrote: The pvr addon from 19 is likely an api mismatch and not recognized in 18.9.  Also python 3 instead of 2. 

You'll need to purge version 19 packages and install 18.9 from old.  Not sure why hts pvr won't install.  You'll need to post a debug log to have someone determine the issue.

I have 19 installed on test machine but having crashes  so holding off on upgrade as well until I can sort the issues with 19.

Hello, same issue from my side, except it's 18.9 kodi version with ubuntu.

kodi-pvr-hts can be installed from apt but it refuses to be launched as it says that it is incompatible with kodi version...

Any solution ?

Thanks !
Reply
#4
apt policy kodi-pvr-hts
Reply
#5
(2021-04-12, 06:44)wsnipex Wrote: apt policy kodi-pvr-hts
Sorry for the french language :

kodi-pvr-hts:
  Installé : (aucun)
  Candidat : 8.2.4-1~focal
 Table de version :
     8.2.4-1~focal 500
        500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu focal/main amd64 Packa                                                                                        ges
     4.4.20-1 500
        500 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages


and when I try to install version 4.4.20-1 (previous version) :

Les paquets suivants contiennent des dépendances non satisfaites :
 kodi-pvr-hts : Dépend: kodi-api-pvr (= 5.10.3)


problem with a package version (kodi-api-pvr) which prevents to install kodi-pvr-hts
Reply
#6
uninstall all kodi packages, remove the stable ppa, add the kodi-old ppa, install kodi and addons
Reply
#7
OK I finally succeeded, I found and installed an old version of the package.
Thanks for the help.
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi 18.9 & TV Headend New Install Ubuntu0
This forum uses Lukasz Tkacz MyBB addons.