Movies that were scraped before are now NOT scraping OR are scraped wrongly
#1
Hello,
I was using external HDD until now, but I moved to NAS. I mounted my movies and TV shows sources with NFS share. Everything works perfectly, but scraper is somehow awful now.
I know for sure that many movies were scraped automatically just fine and now they are either ignored or they are scraped as a totally different movie (or sometimes like "Making of: [movie title]")...

What should I do before posting a log here? Restart, scrape/refresh library and then post a log? It's like 800 items if I clean my library. Or I could just delete few movies from library that tend to have problems and rescrape.
I don't rename folders or the video files themselves, because reasons (I'd be glad if I didn't have to rename them, because before it was working just fine). Some movies are not in their sub-folder and are just in the FILMY folder itself, but that doesnt matter, because as I stated before...it was working just fine before with this setup and even movies in their own sub/folders have scraping issues.

I heard about tinyMediaManager, but from what I gathered...it won't get posters...or it will just download them to the movie folders which I don't know if I want.
Well, if I'm thinking about it. Backups are tedious and I forget about them, so having NFO and all the scraped info+artwork/posters in the movie folders would be nice to have in case I will re-scrape.


How do you run your setups? I was using this for like 3 years just fine until now. Now like more than 20% is screwed up or missing when I scrape and it drives me mad.

Thank you so much <3
Quote:Example of folder (which was scraped correctly):
/srv/dev-disk-by-uuid-xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/NAS/FILMY/
├── 28 Days Later... (2002) (1080p BluRay x265 HEVC 10bit AAC 5.1 Tigole)
│   ├── 28 Days Later... (2002) (1080p BluRay x265 10bit Tigole).mkv
│   ├── 28 Days Later... (2002) (1080p BluRay x265 10bit Tigole).srt
│   └── Featurettes
│       ├── Alternate Endings.mkv
│       ├── Animated Storyboards.mkv
│       ├── Deleted Scenes.mkv
│       ├── Gallery - Polaroids.mkv
│       ├── Gallery - Production Stills.mkv
│       ├── John Murphy - Taxi (Ave Maria) (Jacknife Lee Remix).mkv
│       ├── .nomedia
│       ├── Pure Rage - The Making of 28 Days Later.mkv
│       ├── Teaser.mkv
│       └── Trailer.mkv

For example this one was not scraped for some reason:
├── Gangs of New York REMASTERED (2002) [1080p]
│   └── Gangs.Of.New.York.2002.REMASTERED.2002.1080p.BrRip.x264.BOKUTOX.YIFY.mkv

And this was was scraped as a behind the scenes of the movie:
├── Chicken Run (2000) (1080p BluRay x265 HEVC 10bit AAC 6.1 afm72)
│   ├── Chicken Run (2000) (1080p BluRay x265 afm72).cs.srt
│   ├── Chicken Run (2000) (1080p BluRay x265 afm72).cs.sub
│   └── Chicken Run (2000) (1080p BluRay x265 afm72).mkv
Quote:My setup:
  1. Raspberry Pi 4 (4GB)
  2. LibreElec (9.2.6)
  3. Scraping to Czech language
  4. 10TB NAS running OMV
  5. Both Raspberry Pi 4 and my NAS are connected by ethernet cable
Reply
#2
(2021-05-04, 22:12)tomini Wrote: Gangs of New York REMASTERED (2002)
There is no film named Gangs of New York REMASTERED (2002) There is probably a film named Gangs of New York (2002), though.

Need a Debug Log for the rest. Enable debug mode, restart Kodi. Then individually scrape some of the problem movies you know of. Trying to scrape the entire library will prevent you from uploading the log as it will be too big.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
(2021-05-04, 23:25)Karellen Wrote:
(2021-05-04, 22:12)tomini Wrote: Gangs of New York REMASTERED (2002)
There is no film named Gangs of New York REMASTERED (2002) There is probably a film named Gangs of New York (2002), though.

Need a Debug Log for the rest. Enable debug mode, restart Kodi. Then individually scrape some of the problem movies you know of. Trying to scrape the entire library will prevent you from uploading the log as it will be too big.
Okay, I will fix the library to an extend and leave out some problematic titles...
What about the Chicken Run (2000) (1080p BluRay x265 HEVC 10bit AAC 6.1 afm72)...? It doesnt have any REMASTERED or Director's Cut Undecided
I will upload the log as soon as I can. Just...how can I delete passwords from 3rd party add-ons? Because it will upload automatically. So download the kodi.log, delete private info and then upload to paste.kodi.tv?
Thanks
Reply
#4
(2021-05-05, 00:19)tomini Wrote: I will upload the log as soon as I can. Just...how can I delete passwords from 3rd party add-ons? Because it will upload automatically.
If add-ons are exposing your login credentials, then they are poorly coded, and most possibly of the variety that are banned here. Check this page first... Banned Add-ons (wiki).

But, yes. Delete the passwords from the log. Do a search and replace before uploading the log and posting the link here.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#5
Here, is that enough? :-)
Reply
#6
(2021-05-05, 00:51)Karellen Wrote:
(2021-05-05, 00:19)tomini Wrote: I will upload the log as soon as I can. Just...how can I delete passwords from 3rd party add-ons? Because it will upload automatically.
If add-ons are exposing your login credentials, then they are poorly coded, and most possibly of the variety that are banned here. Check this page first... Banned Add-ons (wiki).

But, yes. Delete the passwords from the log. Do a search and replace before uploading the log and posting the link here.

Here, is that enough? :-)
Sorry, for double reply, but I forgot to hit reply and I don't know if that would notify you...
Thank you.
Reply
#7
(2021-05-06, 18:17)tomini Wrote: is that enough? :-)
Definitely not. Full log with Debug mode enabled.
But I do see how badly your movies and folders are named, and I am not surprised that nothing scrapes for you.

There is not much else I can do for you. Fix your naming and you should have no problems.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#8
(2021-05-06, 21:46)Karellen Wrote:
(2021-05-06, 18:17)tomini Wrote: is that enough? :-)
Definitely not. Full log with Debug mode enabled.
But I do see how badly your movies and folders are named, and I am not surprised that nothing scrapes for you.

There is not much else I can do for you. Fix your naming and you should have no problems.
Ok, so upload whole log. I think I have debug set to ON. I will double-check it. Is it in the GUI settings or is it burried somewhere?

I finally made Sonarr and Radarr work on my NAS. I saw that it renames all new stuff added to library and I can rename previously added folders, too. It just keeps the title and year. But now my scraper scrapes with filename...I saw scraper setting "Movies are in separate folders that match the movie title". So should I remove all that 1080p HEVC 5.1 cr*p from folder names and just keep the movie (tv show) title and year...AND enable that scraper option?
Yeah, and add movies that doesn't have their own folder and just sit between each other in the main source folder to their folder...
Thanks.

PS: I'm getting a lot of Python 30.0 errors...that is just that I don't have Kodi Matrix and those updates for addons are for Matrix running on Python 3.0.0, right? Just curious if it doesn't have anything to do with my issue...
Reply
#9
(2021-05-06, 23:43)tomini Wrote: . I will double-check it. Is it in the GUI settings or is it burried somewhere?
In the GUI. Settings>System>Logging, then restart and replicate the problem.

(2021-05-06, 23:43)tomini Wrote: So should I remove all that 1080p HEVC 5.1 cr*p from folder names and just keep the movie (tv show) title and year
Definitely. Then enable Movies are in separate folders that match the movie title . This will then use the clean folder name for the search.

(2021-05-06, 23:43)tomini Wrote: Yeah, and add movies that doesn't have their own folder and just sit between each other in the main source folder to their folder...
Sorry, I don't know what you mean here.

(2021-05-06, 23:43)tomini Wrote: : I'm getting a lot of Python 30.0 errors
I'll have a look once you upload the log.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
Movies that were scraped before are now NOT scraping OR are scraped wrongly0
This forum uses Lukasz Tkacz MyBB addons.