Updated Dependencies for Eminence on Matrix (19.1)
#1
EDIT (by jurialmunkey 3-Oct-2021) - Eminence is now available on official repo for Matrix. Dependencies have been updated to work with Matrix out of the box so no workarounds are necessary

I was able to get Eminence cleanly running on Matrix and all functionality seems to be there.  Note that this is a pretty ugly hack, but it seems to work fine and I hope it helps anyone (like me) who absolutely NEEDED Eminence.  If you're experienced with Kodi, filesystems and editing files, this should take you about 10 minutes.  Also note that I did all this on a clean install of 19.1

---

First, go here: https://github.com/kodi-community-addons and download the following.  (Go to Code and download Zip)

script.module.thetvdb
script.module.musicbrainz
script.module.metadatautils
script.module.cherrypy
script.skin.helper.service

Then get these from:

https://mirrors.kodi.tv/addons/matrix/sc...-3.0.2.zip
https://mirrors.kodi.tv/addons/matrix/sc...trix.1.zip
https://mirrors.kodi.tv/addons/matrix/sc...trix.1.zip
https://mirrors.kodi.tv/addons/matrix/pl...-2.0.1.zip
https://mirrors.kodi.tv/addons/krypton/r...-0.0.6.zip

Install them in this order:
  1. script.module.thetvdb
  2. script.module.musicbrainz
  3. script.module.soupsieve-2.1.0+matrix.1
  4. script.module.beautifulsoup4-4.9.3+matrix.1
  5. script.module.metadatautils
  6. script.module.cherrypy
  7. script.skin.helper.service
  8. script.image.resource.select-3.0.2
  9. plugin.program.autocompletion-2.0.1
  10. resource.images.weathericons.white-0.0.6

Then finally the skin:

https://github.com/jurialmunkey/skin.eminence.2 (Go to Code and download the Zip)

Extract the zip to some folder.
Open addon.xml and update the dependent addon versions to reflect the following (note that I removed the now-defunct script.extendedinfo):

xml:
     <requires>
        <import addon="xbmc.gui" version="5.15.0" />
        <import addon="script.skinshortcuts" version="1.1.5" />
        <import addon="script.skin.helper.service" version="1.1.36" />
        <import addon="script.image.resource.select" version="3.0.2" />
        <import addon="plugin.program.autocompletion" version="2.0.1" />
        <import addon="resource.images.weathericons.white" version="0.0.6" />
    </requires>
        
These have each been updated for Python 3 and safely run on Matrix.

You'll need to replace the addon.xml in your downloaded zip file with the edited one.  Go to Addons and install from zip file, select your downloaded zip file with the replaced xml file.  It should work fine.
#2
Awesome mate!
I'll be upgrading (clean install) to 19.1 asap and try your method out.
I'll report back once done. 

Many thanks!
#3
Just installed a fresh copy of CoreELEC with Kodi v19.1
Reproduced all steps as mentioned above and I can confirm Eminence has been installed without any problem!
It seems to be working fine so far. (no extensive testing)

Many thanks @KennethC
#4
(2021-05-19, 09:33)Panja0 Wrote: Just installed a fresh copy of CoreELEC with Kodi v19.1
Reproduced all steps as mentioned above and I can confirm Eminence has been installed without any problem!
It seems to be working fine so far. (no extensive testing)

Many thanks @KennethC

Awesome, glad to hear it's working for you.
#5
eccch i have no experience editing kodi resources, im on the verge of ditching kodi for good without this skin, would it be possible to get more detailed steps?
#6
Thanks for this. It works without any problems. To install those scripts, you need to go into Kodi and go to Settings>Add Ons>Install from ZIP file. Those navigate to where you downloaded these files and follow the install order.
#7
(2021-06-11, 04:41)bruce87 Wrote: Thanks for this. It works without any problems. To install those scripts, you need to go into Kodi and go to Settings>Add Ons>Install from ZIP file. Those navigate to where you downloaded these files and follow the install order.

i get trouble with autocomplete keyboard. yours works perfect??
#8
Works "Show Background Video" on RPi4 with LE10? My background video flickers like hell..

Same here...
https://forum.kodi.tv/showthread.php?tid...pid3057897

Tested short some Matrix supported skins with the Show Background Video flickering and Widget flickering issue; opened a TV stream url:

Aeon MQ 5 MatrixMOD: Background = ?, Widget = flickering
Aeon Tayo: Background = stable but async, Widget = flickering
Amber: Background = ?, Widget = flickering
Bello 8: Background = stable but async, Widget = ?
Emuary (Matrix): Background = stable but async, Widget = ?
Estuary (Kodi default skin): Background = stable, Widget = ?
Estuary MOD V2 Matrix: Background = stable, Widget = ?
fTV: not tested yet..
Metropolis: Background = ?, Widget = flickering
Pellucid: Background = ?, Widget = stable but async
Quartz: Background = stable, Widget = ?
Unity: Background = stable, Widget = ?


Also for me nearly every skin crashes after switching the skin an going strait to Live-TV.
After reboot it works.

P.S.: sry, too lazy for log sharing. Maybe later.
RPi3 | RPi4 | LibreElec Kodi
#9
FYI - Alpha Verson of Official Port to Matrix is here:
https://forum.kodi.tv/showthread.php?tid=364517

ExtendedInfo, SkinHelper, and Autocomplete dependencies have been removed. SkinHelper look-ups have been replaced with TMDbHelper.

Some things will be broken. I've still got to implement ExtendedInfo replacement using TMDbHelper. Support for GlobalSearch/NextUp/NextAired/ColorPicker addons also needs to be updated. But most of these things would have been broken anyway, so this version should at least get things working on Matrix without any need for third party repos or workarounds.

Report any bugs in the main thread or on github (there will be bugs as this is very much an alpha! but I will be updating it to get it up to speed for official release).
Arctic Fuse - Alpha now available. Arctic Horizon 2 - Beta. Support me on Ko-fi.
#10
Closing this thread as Matrix version of Eminence has now been accepted in the Official Repo and workarounds are no longer necessary.
Arctic Fuse - Alpha now available. Arctic Horizon 2 - Beta. Support me on Ko-fi.

Logout Mark Read Team Forum Stats Members Help
Updated Dependencies for Eminence on Matrix (19.1)0
This forum uses Lukasz Tkacz MyBB addons.