Bug where Kodi won't play an episode in library
#1
Hey all, looking for some help with this bug. An episode of Big Sky that will not play no matter what I try.

So I've got 2 logs attached, I tried 1 version of an episode last night in SD 480p. That didn't play even though it was scraped into the library but all the other episodes in my library would play. So I figured maybe I had a corrupt copy so I got another copy, a 1080P HD version. I only went for this because it was such a different version so it should just play right? I don't know why but it loads a "busy spinner" for maybe 1/10 a second then back to the episode list. Next episode fires up right away.

The second time I tried to play the episode, maybe 30 seconds later, I got the message "This file is no longer in your library." which is weird because this episode is most definitely in my library, it hasn't gone anywhere. I've tried all different scrapers and it always scrapes into my library. Trying to think of any other info that would help.. Naming convection goes /TV Shows/Big Sky/Season 01/Big Sky - S01E07 - I Fall To Pieces and it follows the exact way I've done it for 6 years so naming isn't the issue. I can play the file in VLC so I know it isn't a corrupt file, this just seems like a bug in Kodi that won't allow playback of this one episode no matter which file of it I try to use. I'm posting this in the Windows help section although this bug happens on all my Nvidia Shield's and my other Windows PC so it's not Windows specific.

If someone can help me look through the debug log, maybe I've skipped over something but I don't see any indication of what's causing this as all I see related to this is "error: could not open file" but I can't see why it won't open.

Yesterday's Log

Today's Log

Appreciate any help you can throw my way.
Reply
#2
@theflink

Both logs: This page is no longer available. It has either expired, been removed by its creator, or removed by one of the Pastebin staff.

Try Kodi's own pastebin webpage instead.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#3
(2021-06-05, 15:18)Klojum Wrote: @theflink

Both logs: This page is no longer available. It has either expired, been removed by its creator, or removed by one of the Pastebin staff.

Try Kodi's own pastebin webpage instead.
Weird, okay. Updated these to go on Kodi's pastebin instead.

Here's yesterday

And here's today

As additional info, the episode we're looking for is S01E07 - I Fall To Pieces.
Reply
#4
I'm not a big MariaDB guru, but this seems off:
Code:
2021-06-04 22:19:02.613 T:1876 DEBUG: DatabaseUtils::GetSortFieldList: unknown field 31
2021-06-04 22:19:02.626 T:6316 ERROR: CVideoPlayer::OpenInputStream - error opening [smb://osmc/Media Storage/TV Shows/Big Sky/Season 01/Big Sky - S01E07 - I Fall To Pieces.mkv]
2021-06-04 22:19:02.627 T:6316 NOTICE: CVideoPlayer::OnExit()

There have been others with MariaDB hickups, perhaps you can do a forum search for more info.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
Bug where Kodi won't play an episode in library0
This forum uses Lukasz Tkacz MyBB addons.